Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

FPS drop

- - - - -

  • Please log in to reply
35 replies to this topic

#16
Shana

Shana

    L6: Expert

  • ET Member
  • 992 posts
666
Has a brilliant future
  • EvolveHQ:th3ory13
  • Admin:16
  • Server:NQ1
  • Alias:Th3ory, Shana
  • Steam ID:STEAM_0:1:72802134
  • T-M:ET: 11-6

I just wanted to clarify that r_swapInterval is the only setting that enables or disables vsync. r_finish forces the game to wait for the OpenGL commands to finish before executing which can prevent extraneous mouse samples from rendering on the same frame. Otherwise you all have covered everything nicely. ^_^

 

  1. In the Control Panel > Hardware and Sound > Power Options: Make certain that the Power saver mode is not selected (preferably set to High Performance while playing ET). 
  2. I agree with Xernicus. Check for Malware.
  3. I also agree with Kari that installing ET on a different hard drive could be beneficial for testing whether the current one is failing.
  4. You could also try reverting to a previous GPU driver, but unless you've enabled beta driver updates I see no reason that this would help.

 

Since you haven't changed anything it's quite probable that the issue is hardware related. However in severe cases network problems can cause FPS drops as well. So please post a 100 packet WinMTR report which can be downloaded here.

 

Regards,

xenozbad

Having vsync off in nvidia panel might not work since there are cvars in et to have it on. So we tried turning them off and on using those 2 cvars. Yes I know what those 2 cvars do. And thanks ;)

 

Great idea with 1st and malware.

 

About winmrt, he has been using laptop(I guess on the same internet) and there were no fps drops(at least since he turned off threadded optimization)




Click here to login or here to register to remove this ad, it's free!

#17
Arkinder

Arkinder

    L3: Novice

  • Platinum VIP
  • 126 posts
76
On the road to fame
  • Server:None
  • Alias:o{^_^}o

Having vsync off in nvidia panel might not work since there are cvars in et to have it on. So we tried turning them off and on using those 2 cvars. Yes I know what those 2 cvars do. And thanks ;)

 

Great idea with 1st and malware.

 

About winmrt, he has been using laptop(I guess on the same internet) and there were no fps drops(at least since he turned off threadded optimization)

 

For Nvidia cards disabling vsync in the control panel will cause r_swapInterval to do nothing (at least on my two machines). It's a common misconception that r_finish is some how related to vsync and it's not - they are in no way related. My goal was to simply clarify that for anyone else reading this.

 

If that's the case then the WinMTR report will not be needed, and I still lean towards trying the 2nd and 3rd options in my first post. Is the machine with FPS drops a laptop as well?

 

Regards,

xenozbad



#18
Mr.Karizmatic

Mr.Karizmatic

    Why So Serious..?

  • Recruiting Team
  • 2,291 posts
1,984
Name known to all
  • EvolveHQ:Mrkarizmatic1
  • Admin:17
  • Server:Insurgency
  • Alias:=F|A=Mr.Karizmatic
  • Steam ID:STEAM_0:0:84857256
  • T-M:ET: 14-7
    INS: 1-1

Donator

Contributor

ok i was bzy with my RL so i didnt open ET on my pc lately but yesterday i run malware and got 3 error and removed them and later today i played ET and the FPS was 30-35 and i can move have some kills it was not the worse so any suggestions from there



#19
Arkinder

Arkinder

    L3: Novice

  • Platinum VIP
  • 126 posts
76
On the road to fame
  • Server:None
  • Alias:o{^_^}o

Run HitmanPro, CCleaner, and defrag your HD if you have not already done so. 

 

Regards,

xenozbad



#20
Mr.Karizmatic

Mr.Karizmatic

    Why So Serious..?

  • Recruiting Team
  • 2,291 posts
1,984
Name known to all
  • EvolveHQ:Mrkarizmatic1
  • Admin:17
  • Server:Insurgency
  • Alias:=F|A=Mr.Karizmatic
  • Steam ID:STEAM_0:0:84857256
  • T-M:ET: 14-7
    INS: 1-1

Donator

Contributor

defrag?

 

i downloaded and installed hitmapro and cc clean and run and got one virus removed it and did everything and restarted and played ET still 17 fps



#21
RedBaird

RedBaird

    What does this thing do? I will push it and see...

  • Leader
  • 6,179 posts
4,844
Glorious beacon of light
  • EvolveHQ:FA_Redbaird
  • Admin:20
  • Server:Jay1
  • Alias:=F|A=RedBaird
  • T-M:ET: 13-4

Donator

 

 

-did you defragment et folder?

 

 

 

 and defrag your HD if you have not already done so. 

 

 

Assuming you have Windows:

 

Kariz-DefragCLIP.jpg

 

I have Nortons Suite, which "replaces" the Windows Defragger program that you can see in the top line of the SS.



#22
Mr.Karizmatic

Mr.Karizmatic

    Why So Serious..?

  • Recruiting Team
  • 2,291 posts
1,984
Name known to all
  • EvolveHQ:Mrkarizmatic1
  • Admin:17
  • Server:Insurgency
  • Alias:=F|A=Mr.Karizmatic
  • Steam ID:STEAM_0:0:84857256
  • T-M:ET: 14-7
    INS: 1-1

Donator

Contributor

done still same prob 11fps,Reinstalled et again..

 

anyone link me to the latest drivers i think i shld try that once shld i ?



#23
Shana

Shana

    L6: Expert

  • ET Member
  • 992 posts
666
Has a brilliant future
  • EvolveHQ:th3ory13
  • Admin:16
  • Server:NQ1
  • Alias:Th3ory, Shana
  • Steam ID:STEAM_0:1:72802134
  • T-M:ET: 11-6

Maybe try installing older drivers? Since latest ones did not fix the problem.



#24
Mr.Karizmatic

Mr.Karizmatic

    Why So Serious..?

  • Recruiting Team
  • 2,291 posts
1,984
Name known to all
  • EvolveHQ:Mrkarizmatic1
  • Admin:17
  • Server:Insurgency
  • Alias:=F|A=Mr.Karizmatic
  • Steam ID:STEAM_0:0:84857256
  • T-M:ET: 14-7
    INS: 1-1

Donator

Contributor

ok i rollback to my old drivers now i get GLW_StartOpenGL() - could not load OpenGL subsystem error and i m pretty sure its cause of old drivers so any help 



#25
Mr.Karizmatic

Mr.Karizmatic

    Why So Serious..?

  • Recruiting Team
  • 2,291 posts
1,984
Name known to all
  • EvolveHQ:Mrkarizmatic1
  • Admin:17
  • Server:Insurgency
  • Alias:=F|A=Mr.Karizmatic
  • Steam ID:STEAM_0:0:84857256
  • T-M:ET: 14-7
    INS: 1-1

Donator

Contributor

ok today i and theory tried alot of this first i uninstalled my drivers and then reinstalled it and then installed directx and then opened ET which i installed new in new folder and then my fps was still same and then Redbaird told me 2 cvars /pb_sleep and /pb_lan which i tried and it was good for some time as my fps was between 25-60 then later it got again wierd and then theory gave me some more pb related cvars bt didnt helped a bit.. anyone else can help?



#26
Xernicus

Xernicus

    Certified Mikutard

  • ET Member
  • 2,693 posts
2,608
Is a bearer of wisdom
  • EvolveHQ:Xernicus
  • Admin:16
  • Server:Jay3
  • Alias:=F|A=Xernicus
  • Steam ID:0:0:57748879
  • T-M:ET: 7-6
Contributor

Do this to make sure those settings are saved:
/pb_security 0
/pb_sleep 500
/pb_WriteCfg

and then -only after- joining a server, /pb_lan 1. This will need to be set after each re-join.

Before you join a server type /pb_system 0, this will remain set.



#27
RedBaird

RedBaird

    What does this thing do? I will push it and see...

  • Leader
  • 6,179 posts
4,844
Glorious beacon of light
  • EvolveHQ:FA_Redbaird
  • Admin:20
  • Server:Jay1
  • Alias:=F|A=RedBaird
  • T-M:ET: 13-4

Donator

Interesting post on the OpenGL error :  https://www.opengl.o...l=1#post1196515 in the OpenGL.org forums.

 

The Download link is wrong, the new one is http://www.realtech-...rt/download.php  for the OpenGL Extensions Viewer.

 

Down the thread, the expert says, (after he tells the victim to uninstall old drivers completely)

"Did you check if you have video acceleration enabled in the windows settings ? There's a tab for it somewhere if I remember well. If it's set to lower than full acceleration, OpenGL will fall back to the software drive, even if a proper driver was installed."

 

That actually does sounds like your FPS problem.  If the video acceleration is not on full and the OpelGL uses its software mode instead of hardware mode...that would result in bad FPS.

 

 

I was just repeating the  Pb_sleep and Pb_lan info Xernicus told us.

 

 



#28
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,968
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor

None of our servers require PB in our servers. We run our own anti cheat so you can delete PB complete and remove PB services completely. 

 

While running game open task manager and check your CPU usage through task manager. Post the task manager screenshot here. 

 

Post the stats of CPU, RAM usage while you are playing. Sound megs on jay2 should be set to 160MB if you have available RAM to catch all sounds in memory when map starts.

 

##########

 

If you get malaware or trojans in your system take back ups and re install windows 7. 

 

################

 

Check your hard drive health and fix your CPU temp. CPU temp affects ET by good amount on low end CPU's. AMD used to manufactures POS CPU's for desktops while back. Not sure if anything has changed since last 2 years because I have been out of touch with new AMD processors. 

 

Open up your desktop, apply new thermal paste and change FAN if it's desktop and if laptop clean up hit sink fans and get the temperature under 40C.

 

#########

 

Did you used to get FPS above 50 anytime before?



#29
Mr.Karizmatic

Mr.Karizmatic

    Why So Serious..?

  • Recruiting Team
  • 2,291 posts
1,984
Name known to all
  • EvolveHQ:Mrkarizmatic1
  • Admin:17
  • Server:Insurgency
  • Alias:=F|A=Mr.Karizmatic
  • Steam ID:STEAM_0:0:84857256
  • T-M:ET: 14-7
    INS: 1-1

Donator

Contributor

None of our servers require PB in our servers. We run our own anti cheat so you can delete PB complete and remove PB services completely. 

 

While running game open task manager and check your CPU usage through task manager. Post the task manager screenshot here. 

 

Post the stats of CPU, RAM usage while you are playing. Sound megs on jay2 should be set to 160MB if you have available RAM to catch all sounds in memory when map starts.

 

##########

 

If you get malaware or trojans in your system take back ups and re install windows 7. 

 

################

 

Check your hard drive health and fix your CPU temp. CPU temp affects ET by good amount on low end CPU's. AMD used to manufactures POS CPU's for desktops while back. Not sure if anything has changed since last 2 years because I have been out of touch with new AMD processors. 

 

Open up your desktop, apply new thermal paste and change FAN if it's desktop and if laptop clean up hit sink fans and get the temperature under 40C.

 

#########

 

Did you used to get FPS above 50 anytime before?

i used to get fps always above 50 (60-80 ) and it is normal for me but now after 2-3 weeks this started and i got pics of the HDD and task manager..and fan temperatures....and i have got a new fan like 1 mnth back so i dont think fan is the problem...

 

and Wintmtr reading of jay2.clan-fa.com

 

|------------------------------------------------------------------------------------------|
 
|                                      WinMTR statistics                                   |
 
|                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |
 
|------------------------------------------------|------|------|------|------|------|------|
 
|                             192.168.1.1 -    0 |  101 |  101 |    0 |    0 |    0 |    0 |
 
|                        ras.beamtele.net -    0 |  101 |  101 |    0 |    0 |    2 |    0 |
 
|                        ras.beamtele.net -    0 |  101 |  101 |    1 |   10 |  132 |    5 |
 
|                        ras.beamtele.net -    0 |  101 |  101 |    1 |    1 |    8 |    2 |
 
|121.240.252.25.STATIC-Hyderabad.vsnl.net.in -    0 |  101 |  101 |    0 |    0 |    3 |    1 |
 
|                   No response from host -  100 |   21 |    0 |    0 |    0 |    0 |    0 |
 
|   ix-0-100.tcore1.MLV-Mumbai.as6453.net -    3 |   93 |   91 |   16 |   20 |   54 |   16 |
 
|     if-2-2.tcore2.MLV-Mumbai.as6453.net -    5 |   87 |   83 |  205 |  209 |  232 |  224 |
 
|     if-6-2.tcore1.L78-London.as6453.net -    0 |  102 |  102 |  208 |  216 |  227 |  221 |
 
|     if-4-2.tcore1.NJY-Newark.as6453.net -    0 |  102 |  102 |  210 |  213 |  247 |  210 |
 
|     if-2-2.tcore2.NJY-Newark.as6453.net -   32 |   47 |   32 |  211 |  211 |  219 |  211 |
 
| if-14-14.tcore2.NTO-New-York.as6453.net -    2 |   98 |   97 |  208 |  211 |  324 |  209 |
 
|                           63.243.128.69 -    0 |  102 |  102 |  208 |  208 |  269 |  209 |
 
|     ae-9.r05.nycmny01.us.bb.gin.ntt.net -    0 |  102 |  102 |  206 |  206 |  212 |  207 |
 
|          ae3.ar1.nyc3.us.as4436.gtt.net -    2 |   98 |   97 |  291 |  292 |  301 |  291 |
 
|  as20473.ae7.ar1.nyc3.us.as4436.gtt.net -    0 |  102 |  102 |  284 |  288 |  296 |  284 |
 
|ethernet1-2-2-c1-16-b2-1.pnj1.choopa.net -    0 |  102 |  102 |  204 |  214 |  529 |  217 |
 
|               108-61-21-94.constant.com -    0 |  102 |  102 |  226 |  262 |  277 |  226 |
 
|________________________________________________|______|______|______|______|______|______|
 
   WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

Attached Thumbnails

  • aaaa.jpg
  • bbb.jpg
  • ccc.jpg
  • dddd.png
  • eeeeeee.png


#30
g.o.a.t.

g.o.a.t.

    L3: Novice

  • Inactive Member
  • 321 posts
89
On the road to fame
  • Admin:12
  • Server:Jay1
  • Alias:G.o.a.t.
  • T-M:ET 1-1

Donator

Contributor

When I used to have a windows laptop, the game would start acting up whenever my hard drive was getting full, so I installed and ran the game through an external 1tb hard drive and kept the important services on my C drive. Might help but to be honest, ever since getting my Mac, I haven't had a slowdown of any kind. It's really something I'd recommend to anyone and everyone for school, work, absolutely anything. 

 

Really hope your problem gets fixed somehow, fresh system reinstall the whole windows is the drastic route if all fails. Windows=headache.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users