Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

AMD Catalyst 14.7 RC3 Beta discussion

- - - - - graphics amd beta drivers catalyst

  • Please log in to reply
13 replies to this topic

#1
Xernicus

Xernicus

    Certified Mikutard

  • ET Member
  • 2,693 posts
2,608
Is a bearer of wisdom
  • EvolveHQ:Xernicus
  • Admin:16
  • Server:Jay3
  • Alias:=F|A=Xernicus
  • Steam ID:0:0:57748879
  • T-M:ET: 7-6
Contributor

This topic is meant for anybody who is using AMD's latest Catalyst beta drivers (to date, 9/8/2014- 14.7)

I'm wondering what various people's experiences have been so far.

I can say for certain that the OpenGL performance has really just blown me away, with enormous increases in my FPS rate, as well as compatibility with newer games.

However, on the con side, I've gotten a BSOD about... once a week or so since I installed this latest update, and the latest was during some mundane text scrolling.

I'm wondering if people have noticed/gotten similar results or not, and if they have found any other pros and/or cons. Let me know!




Click here to login or here to register to remove this ad, it's free!

#2
Chameleon

Chameleon

    Chameleon

  • Co-Leader
  • 6,262 posts
3,758
Is a bearer of wisdom
  • Admin:19
  • Server:COD4 #3
  • Alias:=F|A=Chameleon
  • Steam ID:STEAM_0:0:58393770
  • T-M:11-6 COD4

Donator

  Over all, I have had a good experience with the drivers..  I have had, as you also said, a huge leap in fps, even Titanfall has ran so smoothly..

 

  I have not experienced the BSOD, but I will say since installing them, Titanfall has crashed to desktop on several occasions.. With the previous, stable release, I did not have this issue..

 

  But mostly, it has been a good experience, and if they keep up with this type of quality, I look forward to future releases  :D



#3
Achiyan

Achiyan

    Huge thanks to Vix. I love this!!!

  • ET Member
  • 2,439 posts
611
Has a brilliant future
  • Admin:14
  • Server:Jay1
  • T-M:ET: 1-1

Donator

oh yeah, im updating then :D i havent even been playing Wolfenstein (the new one) cus of framerate issues. and also, i've been playing The Typing of the Dead 3 lol. but the previous version of Catalyst were making the zombies either disappear or have disappearing parts. imma check this one out and see if i can go back to primitives_1 in ET too



#4
Achiyan

Achiyan

    Huge thanks to Vix. I love this!!!

  • ET Member
  • 2,439 posts
611
Has a brilliant future
  • Admin:14
  • Server:Jay1
  • T-M:ET: 1-1

Donator

didnt know it auto updated for me. its on 14.2 and when i check for updates, 14.7 doesnt show up. says its up to date :/



#5
Xernicus

Xernicus

    Certified Mikutard

  • ET Member
  • 2,693 posts
2,608
Is a bearer of wisdom
  • EvolveHQ:Xernicus
  • Admin:16
  • Server:Jay3
  • Alias:=F|A=Xernicus
  • Steam ID:0:0:57748879
  • T-M:ET: 7-6
Contributor

didnt know it auto updated for me. its on 14.2 and when i check for updates, 14.7 doesnt show up. says its up to date :/

http://support.amd.c...ndows-beta.aspx



#6
Achiyan

Achiyan

    Huge thanks to Vix. I love this!!!

  • ET Member
  • 2,439 posts
611
Has a brilliant future
  • Admin:14
  • Server:Jay1
  • T-M:ET: 1-1

Donator

well, i didnt clarify...everytime i update from the AMD site, it jacks everything up. then i have to roll back to my originally installed version and let the program update for me....but i'll give it a shot



#7
Achiyan

Achiyan

    Huge thanks to Vix. I love this!!!

  • ET Member
  • 2,439 posts
611
Has a brilliant future
  • Admin:14
  • Server:Jay1
  • T-M:ET: 1-1

Donator

oh, silly me. it did auto-update lol. no wonder i was confused. i uninstalled and re-installed and still seen 14.2......i see what i was looking at now lmao. 

 

anhvh1.png



#8
Vanaraud

Vanaraud

    L10: Grand Master

  • ET Member
  • 3,416 posts
822
I am just really nice
  • Admin:15
  • Server:Jay2
  • Alias:Vael
  • T-M:ET:2-1
Contributor

Still giving amd driver crashes while surfing net(not happening when gaming), TF is still fracked up and don´t see really any difference in ET. So nothing much changed for me.



#9
Xernicus

Xernicus

    Certified Mikutard

  • ET Member
  • 2,693 posts
2,608
Is a bearer of wisdom
  • EvolveHQ:Xernicus
  • Admin:16
  • Server:Jay3
  • Alias:=F|A=Xernicus
  • Steam ID:0:0:57748879
  • T-M:ET: 7-6
Contributor

Yes that seems to be when I have BSODs myself. Gave me a second this week, and I turned on the Windows Driver Verifier in programmers mode to see if I can catch what exactly is going on here.

Been considering a new graphics card for awhile now, and I think this might be about the right timing... the last driver I had was garbage, and I've had to rollback countless times to an old 13.xx version to get a working version of OpenGL. If this doesn't get ironed out (which I'm sure it will), I'm putting that new card on my credit- forget about saving up. Ain't nobody got time fo dat.



#10
Achiyan

Achiyan

    Huge thanks to Vix. I love this!!!

  • ET Member
  • 2,439 posts
611
Has a brilliant future
  • Admin:14
  • Server:Jay1
  • T-M:ET: 1-1

Donator

i guess im the only person in the world that doesnt have horrible problems. the worst was when ET wouldnt get over 20 frames.....but /seta r_primitives 2 worked that out. i dont get blue screens or none of that other mess. my biggest issues is disappearing body parts in Typing of the Dead. but thats not really a big deal.



#11
Xernicus

Xernicus

    Certified Mikutard

  • ET Member
  • 2,693 posts
2,608
Is a bearer of wisdom
  • EvolveHQ:Xernicus
  • Admin:16
  • Server:Jay3
  • Alias:=F|A=Xernicus
  • Steam ID:0:0:57748879
  • T-M:ET: 7-6
Contributor

i guess im the only person in the world that doesnt have horrible problems. the worst was when ET wouldnt get over 20 frames.....but /seta r_primitives 2 worked that out. i dont get blue screens or none of that other mess. my biggest issues is disappearing body parts in Typing of the Dead. but thats not really a big deal.

I only needed to adjust r_primitives for Silent and NQ mods, JayMod worked fine regardless. :dntk



#12
Xernicus

Xernicus

    Certified Mikutard

  • ET Member
  • 2,693 posts
2,608
Is a bearer of wisdom
  • EvolveHQ:Xernicus
  • Admin:16
  • Server:Jay3
  • Alias:=F|A=Xernicus
  • Steam ID:0:0:57748879
  • T-M:ET: 7-6
Contributor

Got my first BSOD again after nearly a month. :( Though the AMD Beta portal, the page hasn't been updated since 8/17, but if you check for updates via the CCC, there is an update available.
Via Information -> Software Update -> Check for updates now. I chose to download the update via CCC, however there is an option to go to the AMD website to download the standalone executable.
CCC Update.png

In addition, 14.9 has been released as of 9/28, whereas this thread is detailing 14.7 RC3... which apparently is the latest beta driver. Regardless, I suggest updating to the stable branch via the AMD website, or the new beta via CCC, as I deem this to be a buggy release.



#13
RedBaird

RedBaird

    What does this thing do? I will push it and see...

  • Leader
  • 6,177 posts
4,843
Glorious beacon of light
  • EvolveHQ:FA_Redbaird
  • Admin:20
  • Server:Jay1
  • Alias:=F|A=RedBaird
  • T-M:ET: 13-4

Donator

attachicon.gifCCC Update.png

In addition, 14.9 has been released as of 9/28,

 

Yes, I didn't have the RC, but rather had a desktop popup offer the update on 9/29 to the same version # as in Xernicus's post.



#14
Masa_1964

Masa_1964

    Masa_1964

  • ET Member
  • 1,964 posts
1,030
Name known to all
  • EvolveHQ:Masa_1964
  • Admin:15
  • Server:NQ1
  • Alias:=FA= Masa_1964
  • T-M:ET: 3-3
I did try 14.7RC but did not get any other extra than bit higher temps and few crash. So went back on older official one. Will try new version asap.

Masa_1964





Also tagged with one or more of these keywords: graphics, amd, beta, drivers, catalyst

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users