Jump to content
  • 0
dTECT

Invalid guid

Question

A friend of mine has a problem getting a GUID. I instructed him to do the following http://fearless-assassins.com/tutorials/article/200-how-to-get-a-new-etkey-guid-since-pb-dropped-et-support/ and he put etkey in etmain and appdata-blabla-etmain folder aswell. He gets kicked for Invalid GUID http://www.xfire.com/screenshots/128927561 .  He also tried to reconnect after getting kicked multiple times. He tried to do /pb_cl_enable; pb_system 1; pb_writecfg; reconnect in console. He is running Windows 7. Any ideas? I thought this would be fixed with the pb_cl_enable command but I guess it doesn't work if he can't even get in to a server with PB to do it...

Share this post


Link to post
Share on other sites

20 answers to this question

Recommended Posts

  • 0

A friend of mine has a problem getting a GUID. I instructed him to do the following http://fearless-assassins.com/tutorials/article/200-how-to-get-a-new-etkey-guid-since-pb-dropped-et-support/ and he put etkey in etmain and appdata-blabla-etmain folder aswell. He gets kicked for Invalid GUID http://www.xfire.com/screenshots/128927561 .  He also tried to reconnect after getting kicked multiple times. He tried to do /pb_cl_enable; pb_system 1; pb_writecfg; reconnect in console. He is running Windows 7. Any ideas? I thought this would be fixed with the pb_cl_enable command but I guess it doesn't work if he can't even get in to a server with PB to do it...

 

From what server does he get kicked ? =F|A= Servers doesnt kick for no guid so it makes me think his etkey file might be corrupted or just wrong.

He should get another one and try again

Else he can always try another general @ etkey.org

Share this post


Link to post
Share on other sites
  • 0

He tried FA1 among other ones. I'll tell him to try etkey.org and put it in both folders and we'll see what happens. 

 

E: Didn't work :z

Edited by dTECT

Share this post


Link to post
Share on other sites
  • 0

He tried FA1 among other ones. I'll tell him to try etkey.org and put it in both folders and we'll see what happens.

windows 7 is etmain folder only :P

Share this post


Link to post
Share on other sites
  • 0

Just a guess, maybe the cvar cl_guid is filled with some crap in his (writeprotected) config.

 

Other than that, double check that the etkey file is really in the etmain folder, punkbuster is installed, run ET as admin. Do pb_cl_enable before joining the server and check what cl_guid says in console (pb_system is not needed btw).

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I don't think invalid guid can be a problem caused by wrong etkey. Maybe he should check his config, disable hax (joking :P) etc. etc.

 

Anything that could cause his cl_guid to be wrong. If his etkey is in the wrong place, then he would get no guid imho, but not a cl_guid with wrong format

Share this post


Link to post
Share on other sites
  • 0

I already told snatix to fix his cl_guid issue and that would fix this issue. 

Share this post


Link to post
Share on other sites
  • 0

there was a similar topic to this one a while ago, which seemed to fix the problem

http://fearless-assassins.com/topic/50391-no-xp-save-installed-from-etkeyorg-pb-enabled-etc-help-plz/

hope this helps :)

Note that the victim's last post in that topic was that he ran ET as Admin, and it worked, finally.

 

In my Vista64 installation, I right-click on the shortcut to ET.exe and click on "run as administrator" to start the game. The etkey has to be properly installed, but in Windows OS after XP, this seems to be the only safe way.

 

(I also have ET.exe set to "run as admin" and the shortcut to "run as admin". That may or may not be overkill, but I am computer-superstitious. :) )

Share this post


Link to post
Share on other sites
  • 0

Make sure the etkey file isn't saving as any other format other than .cfg. You might have to use Internet Explorer to download it.

Share this post


Link to post
Share on other sites
  • 0

.cfg ? I though that file had no extansion :P

Share this post


Link to post
Share on other sites
  • 0

Maybe this sounds weird but when you open try to change your name with /name and connect then.
I had this issue sometimes too and when I changed my name I could come in.

Perhaps im wrong but it worked for me I generally got this error when I was changing my name or had no name at all.

Share this post


Link to post
Share on other sites
  • 0

Check what cl_guid you have. It must have the correct length and format.

Share this post


Link to post
Share on other sites
  • 0

His config is fine I checked it. Problem isn't in etkey because he tried mine and it didn't work. He's running ET as admin.

Share this post


Link to post
Share on other sites
  • 0

Quo vardis is right the key he's trying to use is corrupt imo.

 

@ Snattix make sure you can see hidden files and extesnions in windows 7 (use google to see how, if you haven't done it already)

 

ET key is a hiddden file and has no extesnion to it.

Delete what ever you've got in Et main that says it's etkey and generate a new key at etkey.org paste the key into ET main.

 

Start ET click play online, right hand under the servers it should say enable pb or disable pb make sure it's enabled, join server and alll should be fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×