Jump to content
  • 0
untitled

some tip needed

Question

Hi ! I've just upgraded my win7 to win8.1 and downloaded the game again etc... I have the old etkey ( thanks to : Teacher :P ) so my exp and everything is saved. BUT it(ET) seems to have some "system" problem, i mean when i played on win 7 i didnt have any fps or monitor problems , and now the game seems lagging ( fps seem to be low ) but it shouldnt.. Im sure its not my fps or my net connection... Thats why im asking for tips :) It would be nice if some1 could help me :) 

Thanks  , unt!tled !

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0

My guess is it's a driver/setting issue. What's your video card and current driver version?

Share this post


Link to post
Share on other sites
  • 0

My guess is it's a driver/setting issue. What's your video card and current driver version?

 

Videocard :  ATI Radeon HD 3850 

  Driver : Advanced Micro Devices, Inc.   version : 8.97.10.6

Share this post


Link to post
Share on other sites
  • 0

I know its not the best and kinda old one but it worked well :P still no problems with any other games though

Share this post


Link to post
Share on other sites
  • 0

Have you tried /r_primitives 2 yet?

And also check in the CCC to make sure there's no "AMD enhanced video" or any custom "3D Application Settings"

  • Like 3

Share this post


Link to post
Share on other sites
  • 0

Ehh , still laggin :s btw where can i set  no "AMD enhanced video" or any custom "3D Application Settings" ? :) 

Share this post


Link to post
Share on other sites
  • 0

Before we tinker with that, I noticed there is a newer version of Catalyst for your graphics card, and the fact that you upgraded to Win8 slipped my mind. I have personally used this build (13.1) and confirm that it works as smooth as butter with all games.

Here is the link to download: http://www2.ati.com/drivers/legacy/13-1-legacy_vista_win7_win8_32_dd_ccc.exe

I remember there being graphics driver conflicts when I upgraded to Windows 8.1, so I suggest doing the following (which might be a pain to you, dunno)
 

  1. Download the file
  2. Disconnect from the internet
  3. Uninstall your current driver and reboot
  4. Install the new version of Catalyst and reboot
  5. Reconnect to the internet

The reason for disconnecting from the internet is it literally just takes seconds for Windows to get some basic driver from Windows Update and plop that in there, and that's not what you want. ;)

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Okay ! THanks a lot dude :) Ill have more free time on the weekend so im definitely going to try that! :P

Share this post


Link to post
Share on other sites
  • 0

Wooooo ! I think its gonna be cool from now :)) Thanks a lot Xernicus :P ( btw the link you sent didnt work  , but i could get it from elsewhere ) 

Share this post


Link to post
Share on other sites
  • 0

Hi ! I've just upgraded my win7 to win8.1 and downloaded the game again etc... I have the old etkey ( thanks to : Teacher :P ) so my exp and everything is saved. BUT it(ET) seems to have some "system" problem, i mean when i played on win 7 i didnt have any fps or monitor problems , and now the game seems lagging ( fps seem to be low ) but it shouldnt.. Im sure its not my fps or my net connection... Thats why im asking for tips :) It would be nice if some1 could help me :) 

 

Thanks  , unt!tled !

Haven't seen that topic before. And np for previous help :P Good that the problem is already solved. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
  1. Disconnect from the internet

 

Was pain in the you-know-where also when I first installed win8.1 drivers. To my knowledge Win keeps basic drivers in some system directory so I doubt how effective dc from net can be.  Though I stumbled on google to this solution: go to Control Panel\System and Security\System -> Advanced Settings "Hardware" and "Device installation settings" and disable any automatisation. No need to DC from net and Win8.1 doesn´t automatically install its own versions of drivers while you try to clean the old installations.

Share this post


Link to post
Share on other sites
  • 0

You can also extract the atioglxx.dll from ATI driver and put it in your main game directory where ET.exe is. That way you can have the latest gfx driver on your system but ET will use the version of the driver (atioglxx.dll) you have placed in ET folder. This file will be in an archive in your C:/AMD/support folder when the driver pack is written to disc before install. Its an archive so its atioglxx.dl_ and you need to unpack it and add the dll to the game directory. I have AMD and CCC version 14.4 on my win7 machine but the game is using the .dll from 13.1 and always will regardless of the main system version installed. I have tested way back to 12.1 and found that 13.1 is best. I can still use the current version by deleting the atioglxx.dll from the game directory.

 

Hope that made sense.   

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

You can also extract the atioglxx.dll from ATI driver and put it in your main game directory where ET.exe is. That way you can have the latest gfx driver on your system but ET will use the version of the driver (atioglxx.dll) you have placed in ET folder. This file will be in an archive in your C:/AMD/support folder when the driver pack is written to disc before install. Its an archive so its atioglxx.dl_ and you need to unpack it and add the dll to the game directory. I have AMD and CCC version 14.4 on my win7 machine but the game is using the .dll from 13.1 and always will regardless of the main system version installed. I have tested way back to 12.1 and found that 13.1 is best. I can still use the current version by deleting the atioglxx.dll from the game directory.

 

Hope that made sense.   

Well i dont rly speak chineese but thanks for the help mate . Hehehe Im kiddin ! Its fixed now so i hope there wont be any trouble , but ill take this advice :) TY

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

If the problem still occurs and your game is still laggy with the drivers up date, try these (ingame of course); 

/cl_packetdup 0 

/set pb_sleep 500 (best lag reducer of all  :D)

/set com_hunkmegs 256

/set cl_maxpackets 30

/set com_maxfps 76 

/set cg_autorate 1

/set cg_optimizepredition 0

/set cg_smoothclients 0

/r_lodbias 2

/r_mode 3

 

Hope this helped 

Edited by bLade.
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.