Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

unplayable ET need help

- - - - -

  • Please log in to reply
10 replies to this topic

#1
=Plat00n=

=Plat00n=

    L5: Journeyman

  • Regular User
  • 641 posts
113
On the road to fame
  • Admin:4
  • Server:None

Hi guys i not been playing much ET lately i have issues since i got a new GPU R9 380. I always remember when i used to have my old gpu everytime i update drivers et would go to f*** and i would have to go back to old driver.

 

So if there is any AMD users that knew the setting to use for amd catalyst control center for ET or if there any topics i have missed about this issue.

 

Thanks Plat00n




Click here to login or here to register to remove this ad, it's free!

#2
Shana

Shana

    L6: Expert

  • ET Member
  • 993 posts
666
Has a brilliant future
  • EvolveHQ:th3ory13
  • Admin:16
  • Server:NQ1
  • Alias:Th3ory, Shana
  • Steam ID:STEAM_0:1:72802134
  • T-M:ET: 11-6
Could you describe more specifically what issues you have with et?
If it's fps drops try different values on r_primitives 2 (values 0 1 2, default 0) do vid_restart after each value change.

#3
=Plat00n=

=Plat00n=

    L5: Journeyman

  • Regular User
  • 641 posts
113
On the road to fame
  • Admin:4
  • Server:None

its more to do with jaggered edging, screen tearing and keep getting black in windows and on players.

 

its most be 100% to do with ccc and this being a old game there most be a setting in ccc which is making the game unplayable.

 

my r_primitives has always been on 2 will try 0-1 now 



#4
Shana

Shana

    L6: Expert

  • ET Member
  • 993 posts
666
Has a brilliant future
  • EvolveHQ:th3ory13
  • Admin:16
  • Server:NQ1
  • Alias:Th3ory, Shana
  • Steam ID:STEAM_0:1:72802134
  • T-M:ET: 11-6
Have you tried uinstalling drivers in safe mode? Then you might want to use amd's auto driver detect? (solved my problem with display driver errors). You could also set lowest avaliable setting for et profile or use program settings in amd's drop down menus. No overheating there I'm assuming :)

#5
=Plat00n=

=Plat00n=

    L5: Journeyman

  • Regular User
  • 641 posts
113
On the road to fame
  • Admin:4
  • Server:None

Tried  r_primitives values no luck there 

 

Only time i have ever had issues with this game was when i tried to update new drivers it happened on my old gpu and now doing the same with my new gpu 

 

I tested all my games and they all working just ET playing up is there something that need to be turned off in ccc to play older games.



#6
Puni

Puni

    L3: Novice

  • ET Member
  • 318 posts
194
On a distinguished road
  • Admin:14
  • Server:Jay3
  • Alias:=F|A=Puni
  • T-M:ET: 5-2

I remember when I used to have amd..

 

Try going into the Catalyst Control Center, set the "Wait for vertical refresh" to preformance or something like that.

Also try to set the OpenGL to enable.

 

It may fix it

 

Puni.



#7
Barn!e

Barn!e

    L3: Novice

  • Regular User
  • 183 posts
113
On the road to fame
  • EvolveHQ:Barnie
  • Server:Jay3
  • Alias:Joll!fications

Donator

Dont use Crimson drivers they dont work with ET. 16.3.2 or similar is current and works on my AMD. Crimson is usually Beta and sucks :)

 

Vsync off should fix tearing.

 

r_ignorehwgamma 0 or 1 depending which you prefer and map..

 

You can also tell ET which opengl to use, cant remember exactly how but you extract a file from the AMD driver set you want and put in main et directory. If the above doesnt fix it let me know I will dig out the instructions for manual opengl version setup.


Edited by Barn!e, 31 May 2016 - 12:38 PM.


#8
Mortemex

Mortemex

    L3: Novice

  • Regular User
  • 188 posts
88
On the road to fame
  • Admin:7
  • Server:Silent #1

Donator

Open up ET with Administrator rights and run it in compatibility mode.  Make sure the control catalyst isn't running as well.

 

Have you tried to do a fresh install of ET with no Custom CFG and the issue still occurring?

 

Also try running ET with your Firewall Turned off.


Edited by Mortemex, 06 June 2016 - 12:35 PM.


#9
JohnTV

JohnTV

    L5: Journeyman

  • Regular User
  • 617 posts
499
Has a brilliant future
  • Admin:0
  • Server:Hardcore ET
  • Alias:Oink.
  • T-M:ET: 2-1

Catalyst Control Center is most likely the issue. Manually disable the following in CCC, if they apply to your system:

  • Threaded Optimization
  • Antialiasing (and all related options)
  • Shader Cache
  • Vertical Sync

Disabling Catalyst AI - Please read

 

Make sure the Raptr overlay is not active for ET. Even better, disable Raptr and AMD Gaming Evolved entirely.

 

Use /r_primitives 2

Try /r_swapinterval 0



#10
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,970
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor

GPU Mode - 

Drivers version - 

CC Version - 

 

Take game screenshot and tweet it to AMD every few days asking for the help with game name. You use the media presence and they will fix it up for next release. :)



#11
HOTSPUR

HOTSPUR

    L2: Beginner

  • Regular User
  • 31 posts
18
A step in the right direction
  • Admin:4
  • Server:Jay2
  • Alias:hotspur

Can't you just roll back the driver to previous,or is this just for nvidia. :unsure:






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users