Jump to content
  • 0
OnionKnight

Black Textures?

Question

Hmm I had this before but only on castle attack. But recently it has increased to different maps like Oasis, Battery ..etc.

 

wet20100618215741.png

 

Its really weird though. Some maps don't have any issues (like gold rush), and others are completely bonkers (like oasis and battery). Also it only affects the floor. Never the walls or sky

 

I also do not have this problem with any other game. I tried TF2, Borderlands, Crysis, CS:S, Deus Ex: Invisible War, NS2 engine, Blur, Dirt 2 ..etc and everything runs perfectly.

Share this post


Link to post
Share on other sites

51 answers to this question

Recommended Posts

  • 0

I can sent you my cfg (copy paste ) by pm if you need it .

Share this post


Link to post
Share on other sites
  • 0

Not sure, because I managed to get rid of the torn textures on walls and ceilings with 10.5 finally, but I still have weapons coated in quicksilver (no texture, just lightmap+reflection). I also haven't touched my computer since last night because of this. It irritates me so much that ATi does this from time to time. The last time I had an issue like this with their drivers was with Soldat.

The latest driver 10.6 updated OpenGL support for versions 3.3 and 4.0, and I have a feeling that changed something else but I've not been able to figure it out completely yet. I'm going to try a clean uninstall of the video card drivers if I can manage, because apparently just using the ATi installer to uninstall the drivers and restart doesn't do that. Of course, I might just try Windows' Driver Rollback.

 

I did submit a driver feedback survey to AMD/ATi about this though. Hopefully they'll actually try to fix it, unless they go, "Oh it's an old game so it doesn't matter."

If I could manually load textures in W:ET in the console, I might be able to fix it, but I'd almost imagine we'd have to add it to our cfg so it happens every time. But this is definitely a OpenGL issue with ATi's latest driver, and whatever it is, it really messes everything up.

 

Mm, just thought. Info about my system:

Windows XP Media Center Edition 2003 SP3

Intel Core 2 Duo E2180 (2.0~GHz)

2GB of DDR2 RAM

ATi Radeon HD 2600 Pro (PCIe 16x 512MB card)

Share this post


Link to post
Share on other sites
  • 0

I've been running 10.5 and have the same quicksilver effect on my guns. Namely the MP40 seems to show the most. It doesn't bother me as much probably since I usually don't draw guns.

 

Otherwise I haven't had any problems. Thanks for the heads up on 10.6. Looks like I'll hold on an upgrade.

Share this post


Link to post
Share on other sites
  • 0

Not sure, because I managed to get rid of the torn textures on walls and ceilings with 10.5 finally, but I still have weapons coated in quicksilver (no texture, just lightmap+reflection). I also haven't touched my computer since last night because of this. It irritates me so much that ATi does this from time to time. The last time I had an issue like this with their drivers was with Soldat.

The latest driver 10.6 updated OpenGL support for versions 3.3 and 4.0, and I have a feeling that changed something else but I've not been able to figure it out completely yet. I'm going to try a clean uninstall of the video card drivers if I can manage, because apparently just using the ATi installer to uninstall the drivers and restart doesn't do that. Of course, I might just try Windows' Driver Rollback.

 

I did submit a driver feedback survey to AMD/ATi about this though. Hopefully they'll actually try to fix it, unless they go, "Oh it's an old game so it doesn't matter."

If I could manually load textures in W:ET in the console, I might be able to fix it, but I'd almost imagine we'd have to add it to our cfg so it happens every time. But this is definitely a OpenGL issue with ATi's latest driver, and whatever it is, it really messes everything up.

 

Mm, just thought. Info about my system:

Windows XP Media Center Edition 2003 SP3

Intel Core 2 Duo E2180 (2.0~GHz)

2GB of DDR2 RAM

ATi Radeon HD 2600 Pro (PCIe 16x 512MB card)

 

Windows 7

Athlon II x 4 620

8GB of DDR3

2 x HD 5770

 

I guess it really is the drivers issues. Also I will roll back to 10.5 again and do a clean install this time to see if everything gets fixed

Share this post


Link to post
Share on other sites
  • 0

Yeah, since you're running a completely different OS than myself, that definitely shoots it down to just a driver issue (probably ATi's implementation of OpenGL commands). And since NoGooD confirmed that 10.5 was also giving issues, looks like I'll be pushing back to 10.4 on my PC.

 

I also noticed that it quicksilvers not only the guns, but open med-kits and ammo-kits on racks, and the tank.

 

10.6 does all of the quicksilver, plus torn textures, and messes up water to either having a solid texture, or making it black. Pretty much breaks the game.

10.5 quicksilvers the guns and items, but not much else.

 

I also tried disabling OpenGL extensions in W:ET, and that fixed everything, but brought up a new problem. Frame rate. With OpenGL extensions, I'd have 90fps +/-5fps. With OpenGL extensions turned off, I'd have... 5fps on average. So also a game breaker.

 

Edit: Uninstalled 10.6 ( I reupgraded in vain hope of it fixing it), used a registry cleaner, then installed 10.4 Catalyst. Everything works fine now... though now I wonder how well Borderlands will perform... Ah good, still runs rather well. Which is strange, it used to lag like crazy, yet I haven't updated any hardware yet.

Anyway, 10.4 Catalyst fixes everything.

Edited by SkyeDarkhawk
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Yeah, since you're running a completely different OS than myself, that definitely shoots it down to just a driver issue (probably ATi's implementation of OpenGL commands). And since NoGooD confirmed that 10.5 was also giving issues, looks like I'll be pushing back to 10.4 on my PC.

 

I also noticed that it quicksilvers not only the guns, but open med-kits and ammo-kits on racks, and the tank.

 

10.6 does all of the quicksilver, plus torn textures, and messes up water to either having a solid texture, or making it black. Pretty much breaks the game.

10.5 quicksilvers the guns and items, but not much else.

 

I also tried disabling OpenGL extensions in W:ET, and that fixed everything, but brought up a new problem. Frame rate. With OpenGL extensions, I'd have 90fps +/-5fps. With OpenGL extensions turned off, I'd have... 5fps on average. So also a game breaker.

 

Edit: Uninstalled 10.6 ( I reupgraded in vain hope of it fixing it), used a registry cleaner, then installed 10.4 Catalyst. Everything works fine now... though now I wonder how well Borderlands will perform... Ah good, still runs rather well. Which is strange, it used to lag like crazy, yet I haven't updated any hardware yet.

Anyway, 10.4 Catalyst fixes everything.

 

Ya but unluckily for me, 10.4 is still one of the unstable patches for HD 5000 series. Apparently 10.4 patch has an idle clock speed of 150 which causes some stability issues with the cards. So in 10.5 and 10.6 they uped it to 400 mhz. I might just roll back though so i can play ET at least lo.

 

Thanks for helping out. I'll give you some rep lol

Share this post


Link to post
Share on other sites
  • 0

Just found this, it's a little long but it might help. The thread it came from was from someone having crashing problems while watching streaming media via Flash.

Date Posted: 05/10/2010 03:33 AM

Posted By: fart888 (Member)

Hi there,

 

I have similar audio problems with my HD5770 as well.

 

I have a ticket opened with AMD's support on that and it has recently been escalated. I am impatiently waiting for their answer on it.

 

In my case, there is even more than the Flash streaming problems.

 

Yes, disabling the hardware acceleration in Flash helps the problem and give better streaming quality (less picture freeze and audio distortion), but the real problem is somewhere else with the way the card down/up-clock and /or change the voltage - hence: the way CCC manages the cards settings depending on the laod on it. I am categoric on this one.

 

There are now tons of forum threads on this topic and there is something going on for sure. I had to troubleshoot for a full 3 days before finally finding a temporary solution. I just can't use my card without having to tweak it; otherwise, my audio start freaking out [i'm not using the Hi-def audio over the HDMI thing yet], or I get freezes in streaming and/or while during desktop tasks.

 

I since then did more research and found post dating back to 2004 on this clock speeds/voltage issues.

 

Anyway, I'll have more on the topic soon (hopefully) once and if I get a useful reply from AMD.

 

But here's what worked for me:

 

I have to create a profile and edit it so that the card will never have its core and memory downclock below 600MHz.

 

To do so, you have to create a new profile in CCC, save it and do not activate it yet. While your are there, create a second one that you will call "DEFAULT" or something else explanatory to reverse your changes if needed. Now, do a Windows search for the name or your profile [the one you want to use to tweak] and make sure to include the hidden files and folders. The file should be a [your profile name].xml file type. [you might have to repeat the search a 2nd time sometimes to see it].

 

---> OR go check under: C:\Documents and Settings\[your user name]\Local Settings\Application Data\ATI\ACE\Profiles

 

Open that .xml file with notepad and there you will see the values that you can tweak.

 

OK, let me stop right here! I want to say that this is done at your own risks and I don't want to be accused on any problems that may or may not occur. I don't want AMD to accuse me of reverse engineering or software hacking either. These changes in settings are just tweaks that allow me to use their card and if this can help others; then let's be it. Basically, I have to do this to use the card or I have to RMA it - so give me a break....!!

 

By default for my HD5770 profile looks like this:

 

<Feature name="CoreClockTarget_0">

<Property name="Want_0" value="15700" />

<Property name="Want_1" value="60000" />

<Property name="Want_2" value="85000" />

</Feature>

<Feature name="MemoryClockTarget_0">

<Property name="Want_0" value="30000" />

<Property name="Want_1" value="120000" />

<Property name="Want_2" value="120000" />

</Feature>

<Feature name="CoreVoltageTarget_0">

<Property name="Want_0" value="950" />

<Property name="Want_1" value="1000" />

<Property name="Want_2" value="1125" />

 

And to fix all my problems, I have to change it to this:

 

<Feature name="CoreClockTarget_0">

<Property name="Want_0" value="60000" />

<Property name="Want_1" value="60000" />

<Property name="Want_2" value="85000" />

</Feature>

<Feature name="MemoryClockTarget_0">

<Property name="Want_0" value="60000" />

<Property name="Want_1" value="90000" />

<Property name="Want_2" value="120000" />

</Feature>

<Feature name="CoreVoltageTarget_0">

<Property name="Want_0" value="1000" />

<Property name="Want_1" value="1000" />

<Property name="Want_2" value="1125" />

 

So basically pushing the card NOT to 'downclock' to the normal power saving Want_0 mode and forcing it to iddle at 600/600MHz/1V.

 

Finally, you can use the CCC option to enable the Hotkeys binding and set it so you can swithc between your tweaked and default mode on the fly. In my case, I cannot go back to the normal profile without getting my audio/video problems reappearing within seconds...

 

And that means that in order to just be able to use that card, I have to let go of (almost) all it's power saving advantages: the main reason that brought me to chose that card over one of the other major competitor in the first place. But this downclocking issue is real for me and is clearly not a Flash only problem. I've never had to disable the HW Flash acceleration to get proper streaming on my previous green cards either.

 

So there you go! Sorry for the long post, but hopefully this will be useful to some and maybe also push AMD/ATI to work on a solution. I want to be able to use my card without having to hack [sorry! tweak] it and I also want to see a low power consumption: up to to the level that they commercialize it toward.

 

Maybe, only maybe, could it just be a matter of changing CCC to only downclock to 157MHz core/300MHz mem ONLY after a longer low GPU load period; see 1, 10 or 20 minutes maybe....

 

Peace out!

Share this post


Link to post
Share on other sites
  • 0

Yeah, since you're running a completely different OS than myself, that definitely shoots it down to just a driver issue (probably ATi's implementation of OpenGL commands). And since NoGooD confirmed that 10.5 was also giving issues, looks like I'll be pushing back to 10.4 on my PC.

 

I also noticed that it quicksilvers not only the guns, but open med-kits and ammo-kits on racks, and the tank.

 

10.6 does all of the quicksilver, plus torn textures, and messes up water to either having a solid texture, or making it black. Pretty much breaks the game.

10.5 quicksilvers the guns and items, but not much else.

 

I also tried disabling OpenGL extensions in W:ET, and that fixed everything, but brought up a new problem. Frame rate. With OpenGL extensions, I'd have 90fps +/-5fps. With OpenGL extensions turned off, I'd have... 5fps on average. So also a game breaker.

 

Edit: Uninstalled 10.6 ( I reupgraded in vain hope of it fixing it), used a registry cleaner, then installed 10.4 Catalyst. Everything works fine now... though now I wonder how well Borderlands will perform... Ah good, still runs rather well. Which is strange, it used to lag like crazy, yet I haven't updated any hardware yet.

Anyway, 10.4 Catalyst fixes everything.

 

Thanks for the info Dark. Just a quick ? for you guys which may be redundant. Have you guys experienced this on mods other than pub? I only mention it b/c I haven't noticed it on my NQ server, but then again it could be I just never noticed since as I stated before I generally don't draw guns.

 

I've tried disabling OpenGL extensions as well...and I'll second you...it's a game killer.

 

FYI

Windows XP Pro

AMD Athlon X2 4200

1GB DDR

ATI 4870 10.5

 

 

 

Ya but unluckily for me, 10.4 is still one of the unstable patches for HD 5000 series. Apparently 10.4 patch has an idle clock speed of 150 which causes some stability issues with the cards. So in 10.5 and 10.6 they uped it to 400 mhz. I might just roll back though so i can play ET at least lo.

 

Thanks for helping out. I'll give you some rep lol

 

Onion, from what I've heard from others with the HD 5000 series, 10.5 is probably your best solution. From the impression I got of 10.4 with those cards, it was cause for alot of headaches.

Share this post


Link to post
Share on other sites
  • 0

Thanks for the info Dark. Just a quick ? for you guys which may be redundant. Have you guys experienced this on mods other than pub? I only mention it b/c I haven't noticed it on my NQ server, but then again it could be I just never noticed since as I stated before I generally don't draw guns.

 

I've tried disabling OpenGL extensions as well...and I'll second you...it's a game killer.

 

FYI

Windows XP Pro

AMD Athlon X2 4200

1GB DDR

ATI 4870 10.5

 

 

 

 

 

Onion, from what I've heard from others with the HD 5000 series, 10.5 is probably your best solution. From the impression I got of 10.4 with those cards, it was cause for alot of headaches.

 

10.5 is giving me the same issues. Apparently some users reported issues with 10.5 and black textures. But 10.6 came and everyone has the problem lol. They said they will make a fix for 10.7 and it has something to do with OpenGL.

Share this post


Link to post
Share on other sites
  • 0

Ah, the joy's of having graphics cards that are to old for new updates xD (The only good thing about them):D

Share this post


Link to post
Share on other sites
  • 0

Ah, the joy's of having graphics cards that are to old for new updates xD (The only good thing about them):D

rofl, I also updated to 10.6 becoz they added flash gpu acceleration. with this 3200 hd, there is no difference with any of the games. just as same as ever.... :lol:

old card FTW

Share this post


Link to post
Share on other sites
  • 0

Lol, I'm using a Nvidia card from '02 I don't think they will becoming out with update's for it anymore :yahoo

Share this post


Link to post
Share on other sites
  • 0

the problem has been reported to AMD few weeks ago... so if you update ati card with driver 10.5 (that have the bug and they didn't fix the issue in driver 10.6) go back to 10.4, personally I didn't update my driver and still on 10.4

 

from AMD forum you can read that the issue will be fixed in next release 10.7 so wait:

 

It is fixed in the drivers I have and that you don't have yet.

Game.AMD.com Forum Moderator

 

I cannot be specific since I am under NDA. I'd imagine you will get the fix in the 10.7 drivers.

Game.AMD.com Forum Moderator

 

so wait and see

Share this post


Link to post
Share on other sites
  • 0

That does it....I'm poppping in my 6600GT and once again rock at 76 FPS

Share this post


Link to post
Share on other sites
  • 0

Lol rolled back drivers, computer completely messed up and wouldn't start so i had to do system restore. Clean install and I still got the problem. I mean look at MLB_Temple !!

 

99677700-4.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×