Jump to content
  • 0
LaGg3r

Help cant hear sounds

Question

Hey guys it,s me lagg3r well i was playing on F|A Hardcore got headshots and bodyshot sounds but after quitting game and going ENY other server but hardcore There is no headshots but bodysounds plz help Thanks!

 

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

I tried to help him out on the server today with his problem.

 

Basically: Sounds work ok on HC.

 

When he goes to another server, he will hear body shots, but will not hear headshots.

 

I asked him to run pk3 cleaner. He refused, and after some convincing finally did it. Came back to HC, said it didn't run, it crashed his computer, Windows explorer stopped working, malware, virus blahblahblah swearing at me etc..

 

So that's all the progress we made. I don't believe this is an issue with /cg_hitsounds (i believe is the cvar) as he has bodyshot sounds, but just no headshot sound.

 

This is why I wanted to start with the pk3 cleaner, sounds like a pk3 problem? Any other suggestions?

Share this post


Link to post
Share on other sites
  • 0

I have the same issue when I am at my parents playing and going from one server to the next.  It does not always happen.  It happened more at the beginning of December so I don't know if it is something that works itself out.

Restarting ET usually fixed the problem.  Closing ET then opening it back up not reconnect.

Share this post


Link to post
Share on other sites
  • 0

I have a similar problem, but with hearing the Vsay since yesterday (V54, V22 etc.. they works, but make no sound), can't figure it out why yet, any idea?

Share this post


Link to post
Share on other sites
  • 0

I have a similar problem, but with hearing the Vsay since yesterday (V54, V22 etc.. they works, but make no sound), can't figure it out why yet, any idea?

 

I dont understand the Problem, to be honest. 

Share this post


Link to post
Share on other sites
  • 0

I have a similar problem, but with hearing the Vsay since yesterday (V54, V22 etc.. they works, but make no sound), can't figure it out why yet, any idea?

 

 

 

Should probably make your own thread since this guy is banned. Bit it sounds like the problem that you played on Jaymod, then came to HC. Exit ET before connecting to Silent servers after playing on Jaymod

 

Other information to add:

Does it show the vsay text on screen?

Do any vsay sounds work that you have binded for custom binds?

Did you play on Jaymod before coming to Silent?

Do vsays work on Jaymod?

Do you hear other peoples vsays?

Did you make any cfg changes recently, or try another cfg?

Share this post


Link to post
Share on other sites
  • 0

Could be to do with custom silent mod hitsounds.. Try \cg_hitsounds 1 - I think that's a valid cvar anyway..

Share this post


Link to post
Share on other sites
  • 0

Or maybe cg_novoicechats is turned on?

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

try /snd_restart in game. Works for me.

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

 

 

 

Should probably make your own thread since this guy is banned. Bit it sounds like the problem that you played on Jaymod, then came to HC. Exit ET before connecting to Silent servers after playing on Jaymod

 

Other information to add:

1-Does it show the vsay text on screen?

2-Do any vsay sounds work that you have binded for custom binds?

3-Did you play on Jaymod before coming to Silent?

4-Do vsays work on Jaymod?

5-Do you hear other peoples vsays?

6-Did you make any cfg changes recently, or try another cfg?

1- Yes

2 - None are working, even the binded one

3- Yes, Jay2

4- Yes

5- No

6- Yes

 

Could be to do with custom silent mod hitsounds.. Try \cg_hitsounds 1 - I think that's a valid cvar anyway..

I've already this one on config : seta b_hitsounds "1"

 

Or maybe cg_novoicechats is turned on?

THAT'S SIMPLY THE SOLUTION!!!!! THANK YOU Platon :)

Don't know why it was turned ON ... 

I've added seta cg_novoicechats "0" now = SOLVE my pb

 

So, may it be my path/passage on the Jay2 server that at turned my Vsay SOUND off ? that's the question now ^^

try /snd_restart in game. Works for me.

Not working for me

 

Thanks a lot for help mates :)

  • Like 3

Share this post


Link to post
Share on other sites
  • 0

Lagg3r's original problem related to this (going from silent to other mods) http://fearless-assassins.com/topic/45191-jaymod-hs-sounds/
 
The Jaymod manuals shows "Added cg_hitsounds flag 2 - only play headshot hitsounds." 
Silent 0.30 release: "Reworked cg_hitSounds client cvar. Now a new option play only headshots is available"
 
NQ and Legacy are documented for the codes below:
cg_hitsounds, type:bitmask
bit-val--decimal code--binary code..description 
0--0--0000..no hitsounds (default in ETlegacy)
1--1--1000..all hitsounds (default in NQ, must be set for any sounds to be heard)
2--3--1100..no teamhits  (head & body enabled)
4--5--1010..no headshots (team & body enabled)
8--9--1001..no bodyhits  (team & head enabled)
--15--1111..(no team, no head, no body = 0 sounds, right?  :)  maybe)
Looking here:  http://www.quarkclan.com/index.php?/topic/5105-silent-sounds/page__view__findpost__p__91278  shows the same hitsound problem noted and the solution given as "restart et before going to another type of mod".
 
Looking in my Silent\...\etconfig, I find that:
seta cg_hitSoundType "0" (use server-defined sounds)
seta cg_hitSounds "4" (no headshots) 
I wonder if we could set this to 1 and if the mod would not set it back to 4''. 

OK, I just seta cg_hitsounds 1 on hardcore and the setting survived a quit and restart.  On the other hand, my hitsounds had changed from 4 to 1 when I went from HC to Jay1 before the change. Lag3r was saying on a jay server that his cg_hitsounds was 1 there, but he did not have Headshot sounds.  I have not tested whether I actually hear headshots with this setting after switching from Silent to other mods or not.
 
AntiChrist's idea of running pk3 was a good one, because the cg_hitSoundType "0" value I found in my etconfig is required to allow sounds from custom paks to be used in Silent.



@ First = "B_codes" are for etpro only.  /CG_hitsounds 1 is correct for the other mods

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×