Jump to content
  • 0
darkfang77

Vsays only seem to work on Jay 3

Question

Hi,

So i've just started playing ET again and i've noticed that I'm unable to use vsays on any server except J3. Whenever I trigger a vsay nothing happens, I've checked all my settings, even tried v91 on NQ to no effect, restarted the game, and still no results.

 

Should I try re-install or .pk3 cleaner? or something in settings I'm missing?

 

Thanks

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0

maybe check your config

 

cg_noVoiceChat  

 

 

it should be 0.

  • Like 4

Share this post


Link to post
Share on other sites
  • 0

maybe check your config

 

cg_noVoiceChat  

 

 

it should be 0.

 

Sorry I'm still rusty on ET: how/where do I open my .cfg file?

Share this post


Link to post
Share on other sites
  • 0

go to your ET folder, then click on etmain   the filename should be  autoexec

 

or you could change ingame  open console [ ~ ]  type /cg_novoicechat 0 r 1

Share this post


Link to post
Share on other sites
  • 0

go to your ET folder, then click on etmain   the filename should be  autoexec

 

or you could change ingame  open console [ ~ ]  type /cg_novoicechat 0 r 1

 

couldn't find a file called autoexec under etmain, goes from 1944_beach to adlernest then am_hydro then baserace when arranged alphabetically.

 

tried copying "/cg_novoicechat 0 r 1" into console when opening ET: states cmd not recognised; also tried variants of /cg_novoicechat, no result. 

 

I did find a .cfg file called etconfig, but after searching for "novoice" via Notepad couldn't find anything related to it.

 

Sorry if I have missed anything out, but is there anything else I can do?

Share this post


Link to post
Share on other sites
  • 0

type in console

 

/cg_noVoiceChats  0

 

with letter s . If it worked, then type in console

 

/writeconfig autoexec.cfg

 

to save it. You can also do that for

 

/cg_noVoiceText 0

 

You can open that autoexec.cfg from notepad to check for that config.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

True, if you havent created any autoexec.cfg then theres any. But under ET->any_mod->Profiles there is etconfig.cfg and thats the file I´ve been modifing. Only keep the format(when using openoffice for example DONT save it as .odt file).

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Had the same problem today. When visiting jay 3 a new pack was downloaded. After this, on every server, except jay 3, my voicechats didn't work. So I closed et. Deleted the pk3 file that was installed by the jay3 server (zz_jaymod-0.3.pk3). After this, problem was solved and I can use all my voicechats again.

Maybe there is a problem in this pk3?

Share this post


Link to post
Share on other sites
  • 0

Entering  "/cg_noVoiceChat 0" in console in one mod will not change it in all mods, i.e., entering "0" in NQ, will leave "1" set in Jaymod.

 

It may not save that setting, either.  It is best to follow the above advice about autoexec and writecfg, etc., to make it "permanent".

 

BTW, my voice-sounds were okay before and after the new pk3 download mentioned. 

 

My cgame_mp_x86.dll was replaced with a slightly smaller one, presumably by that newest FA pk download.  There are signs that I only had a partial download the first time, to a file of size 233kb, but I now have no proof.

 

My cgame_mp_x86.dll has the same date today as my hunkusage.dat, 11/6/13.  The ZZ_jaymod.. has a filedate of 11/4.

 

Dr. Watson!  Come here!  I need you!

 

 

 

 

 

 

 

 

 

 

 

 

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

yeaa for a while yesterday vsays were bugged for me and so was the console for some reason. But restarting the game worked fine for me .

 

 

you should download the pk3 cleaner if you havnt already theres a new version since the last time you played. 

 

http://fearless-assassins.com/files/file/374-enemy-territory-auto-pk3-cleaner/

Share this post


Link to post
Share on other sites
  • 0

Still not working? Tried new installation yet using FA download's ET full version?

Share this post


Link to post
Share on other sites
  • 0

If you want it to save into your etmain/etconfig for all mods you have to type seta before the command, then it will add it to your etconfig in etmain. If you just type cg_novoicechats 0 it changes for only that session of the game.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Entering  "/cg_noVoiceChat 0" in console in one mod will not change it in all mods, i.e., entering "0" in NQ, will leave "1" set in Jaymod.

 

It may not save that setting, either.  It is best to follow the above advice about autoexec and writecfg, etc., to make it "permanent".

 

BTW, my voice-sounds were okay before and after the new pk3 download mentioned. 

 

My cgame_mp_x86.dll was replaced with a slightly smaller one, presumably by that newest FA pk download.  There are signs that I only had a partial download the first time, to a file of size 233kb, but I now have no proof.

 

My cgame_mp_x86.dll has the same date today as my hunkusage.dat, 11/6/13.  The ZZ_jaymod.. has a filedate of 11/4.

 

Dr. Watson!  Come here!  I need you!

 

Agreed. I just visited Jay 1, 2 and 3 today. When I returned to HC my vsays didn't work anymore. /cg_novoicechats 0 was set correctly in all cfgs, etcfg, autoexec, and my /exec cfg.

 

No easy/quick fix found yet. I just reinstalled ET, dropped in my etkey and silent folder, and it works fine again. I assume connection to jaymod changes a file in etmain, Since the only thing I saved from that folder were map pk3s and my etkey.

Share this post


Link to post
Share on other sites
  • 0

It may be related to my most recent Jaymod Tracker post, which is marked "work in progress."

Share this post


Link to post
Share on other sites
  • 0

Had the same problem today. When visiting jay 3 a new pack was downloaded. After this, on every server, except jay 3, my voicechats didn't work. So I closed et. Deleted the pk3 file that was installed by the jay3 server (zz_jaymod-0.3.pk3). After this, problem was solved and I can use all my voicechats again.

 

Maybe there is a problem in this pk3?

Just closing ET, and reopening it when changing server would have solved it. Probably some setting from that server was carried over, and you wrongly thought there was something wrong with your ET.

 

I don't do much serverhopping, I just connect to one and that's it, so I never noticed this problem up to now.

 

No easy/quick fix found yet. I just reinstalled ET, dropped in my etkey and silent folder, and it works fine again.

Don't reinstall ET every single little problem, I never reinstalled it in 7 years 99.9999% of the problems can be always solved without reinstalling, if you know how.

 

It works fine again because it's just a coincidence, not because you reinstalled it.

 

I assume connection to jaymod changes a file in etmain, Since the only thing I saved from that folder were map pk3s and my etkey.

There isn't just 'files', there are settings or cvars which are not saved in your config, but they are just temporary until you close ET. If it was a file, then closing and reopening ET wouldn't fix it.
  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×