Jump to content
  • 0
Sign in to follow this  
Antichrist

Mouse getting stuck

Question

I've been having an issue lately, and it's been ocurring more and more.

 

My mouse will get STUCK while I'm running or strafing, or any combination of the two. By 'STUCK' I mean that any movements of my mouse, do not make any movements in game, but I'm still moving with the keyboard, and this means I'm running into walls, into enemies, and cant fight back.

 

Last night I had this issue again, and found that by stopping keyboard movement frees up the mouse, enabling me to use it again.

 

Keyboard is a SealShield Model SSKSV107 USB input.

Mouse is a Logitech Model MX300 (Optical) USB input.

 

This has never happened before. And doesn't happen while using windows that I've noticed...

 

Any ideas?

 

EDIT: Now that I think about it, I did change seta m_pitch from default "0.022000" to "0.016" as found in a cfg posted in our cfg section, I'm reverting back now to see if I have any issues.

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

m_pitch can't cause this problem.

It happens randomly, or just when you hold some specific keys?

Share this post


Link to post
Share on other sites
  • 0

It happens randomly. Any mouse movement while holding any movement keys. (Default WASD keys are used)

 

I haven't noticed it while only specific movements are performed. Obviously most movement is forward, and while going forward/ forward left/ forward right the mouse freezes and won't turn to look left/right/up/down. I am still able to fire though. (MOUSE1)

Share this post


Link to post
Share on other sites
  • 0

Did you overclock your mouse to 1000hz by any chance? When I overclocked one of my mice to a 1000 I remember getting this problem as well. Other things you could try is using a different port too? Idk

Share this post


Link to post
Share on other sites
  • 0

It's hard to tell, my guess is that it all happens outside the game, maybe your cpu doesn't have the time to refresh the mouse position, because as far as I know there is no way to block mouse moves in game other than setting the sensitivity to 0, even the wait command doesn't block your mouse moves...

/cl_debugmove 1

will open a debug graph at the bottom of your screen, showing your mouse movement, but if you don't move fast enough it's not detected by the graph... maybe try to see if the graphs still moves when it's locked, but I strongly doubt it. I think the game doesn't read any mouse movement at all..

Edited by SunLight

Share this post


Link to post
Share on other sites
  • 0

Hmm maybe caused by 2 things, a dirty mouse or driver/software. Dip a q-tip in rubbing alcohol and clean the little lazer eye on the mouse. And clean off the mousepad.

Try to re-install keyboard and mouse drivers. Are you using the logitech driver? If so, what are the settings?(accel, dpi, hz) Does the keyboard have any special macro keys or settings?

Share this post


Link to post
Share on other sites
  • 0

Myself and a few other people on jay3 got this the other day, had to restart et..

 

But it's been happenning to me on the saboteur since too..

Share this post


Link to post
Share on other sites
  • 0

Never overclocked. (I didn't even know that was possible)

USB ports... I can try another one, but I don't foresee a change.

 

Regarding my CPU not having time to refresh the mouse:

CPU: 2.3g Dual core

RAM: 3g

 

I've never had this issue on slower PCs, and shouldn't have an issue now.

 

Mouse settings in game: 9.01 sens

Smooth mouse on.

 

Cleaned mouse: Nothing major inside, a little dust, but barely visible on the Qtip. Mousepad is also clean.

 

As far as I know I'm using standard drivers that windows installed for both.

 

Looking up keyboard: HID Keyboard device. Driver provider is Microsoft.

The keyboard is a plain keyboard, No extra hotkeys, buttons, macro settings etc...

 

Looking up mouse: HID-compliant mouse. Driver also by Microsoft.

 

No options available to Update the driver for keyboard or the mouse. I'm going to try to locate mouse drivers now.

EDIT: Logitech website does not offer drivers for this mouse, stating that drivers are not necessary with Vista.

 

Hmm Chuckun... This is happening to me on SilentMod Hardcore..

Share this post


Link to post
Share on other sites
  • 0

Did you overclock your mouse to 1000hz by any chance? When I overclocked one of my mice to a 1000 I remember getting this problem as well. Other things you could try is using a different port too? Idk

 

This happens to mice on my PC. Try opening up setpoint and changing your polling rate to 500hz or lower.

 

Looks like the default rate in vista is 125... Not sure if you are running that or not.

http://www.ngohq.com/news/15043-how-to-increase-usb-sample-rate-in-windows-vista-7-a.html

 

There is software on there called mouse rate that should tell you.

Share this post


Link to post
Share on other sites
  • 0

This was an issue I had awhile ago when I first started to experiment with overclocking. I've always used 500 because it is very stable and doesn tend to fluctuate as much as 1000hz.

Share this post


Link to post
Share on other sites
  • 0

I've had this problem randomly over the past few months. No special mods to the computer, just a stock Compaq. It typically takes me getting killed before it resets itself or sometimes it lasts a few life/death cycles.

 

I figure its just another random glitch that cannot be explained thought it just recently started.

Share this post


Link to post
Share on other sites
  • 0

Mice do die too. Go to Best Buy and get a new mouse and try it out. I believe you can return it free of charge. My friend recently test drove a 560gtx video card and returned it for at no charge

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×