Jump to content
  • Sign Up
  • 0

punkbuster api problem


{DoG}Jarheadurpukes
 Share

Question

I can't connect to et at all anywhere, with the exeption of servers that don't run punkbuster. I've been told by friend that I'm being disconnected for an api issue. The only problem is that the only message I get is "Server disconnected for unknown reason." I updated my drivers and as a last resort will reinstall et. I manually updated pb as well and checked /pb_cvarlist which came up clean.

 

The question is how do I locate my pb cdkey and save it so I don't loose my xp upon a fresh install. I'm running Windows XP 32 bit. I read up on this API issue and it say on many websites that its only related to Vista and Windows 7. Anyone have any suggestions ?

Link to comment
Share on other sites

Recommended Posts

  • 0

I can't connect to et at all anywhere, with the exeption of servers that don't run punkbuster. I've been told by friend that I'm being disconnected for an api issue. The only problem is that the only message I get is "Server disconnected for unknown reason." I updated my drivers and as a last resort will reinstall et. I manually updated pb as well and checked /pb_cvarlist which came up clean.

 

The question is how do I locate my pb cdkey and save it so I don't loose my xp upon a fresh install. I'm running Windows XP 32 bit. I read up on this API issue and it say on many websites that its only related to Vista and Windows 7. Anyone have any suggestions ?

 

Okay part of the problem was corrupt et files, so I reinstalled them. Now I'm getting unpure client kicks.

Don't know how to fix that.

Link to comment
Share on other sites

  • 0
  • Administrators

Try joining F|A ETPUB and F|A #2 Jaymod. It will show you reason why PB kicked you. 2.55 has bug which doesn't show why PB kicks you. Both those 2 servers will show you exact reason.

 

Edit Post the screenshot.

Link to comment
Share on other sites

  • 0

Try joining F|A ETPUB and F|A #2 Jaymod. It will show you reason why PB kicked you. 2.55 has bug which doesn't show why PB kicks you. Both those 2 servers will show you exact reason.

 

Edit Post the screenshot.

 

 

It says API function 131125. I have no idea how to correct this. I get kicked slower on etpub than anywhere. But it kicks me for 0 minutes.

Link to comment
Share on other sites

  • 0
  • Administrators

1. Make sure you don't have trojan or worms on your PC.

 

2. Make sure you are not using graphics overlay programs.

 

3. http://evenbalance.com/troubleticket/new_ticket.php?game=et

 

Make a ticket with EB and tell them you are getting kicked for that reason. Prolly they will tell known softwares causing conflict with it.

 

Let us know what EB tells you.

Link to comment
Share on other sites

  • 0

1. Make sure you don't have trojan or worms on your PC.

 

2. Make sure you are not using graphics overlay programs.

 

3. http://evenbalance.com/troubleticket/new_ticket.php?game=et

 

Make a ticket with EB and tell them you are getting kicked for that reason. Prolly they will tell known softwares causing conflict with it.

 

Let us know what EB tells you.

 

I am having the same problem, I can join Etpub ok, and some other random servers I assume because there is no Pb? I resinstalled ET, and that didn't seem to help. I get disconnected for an unknown reason, I have also seen the message "CL_parseserver message 22". Any ideas? Kniw a good trojan.worm remover thats free?

Link to comment
Share on other sites

  • 0

I have a player on our servers that is having the same issue and getting kicked for the same API #.

 

He recently downgraded his laptop from Vista to XP and reinstalled ET. He could play fine on Vista, but Vista caused random crashes. XP is more stable but he is getting kicked for the same API problem. One suggestion I would like to make is you guys should post as much info on your computers as possible. Something like this might help if players getting kicked for the same things are say, running laptops with the same radeon GFX card.

 

I would suggest adding these when you ask for help on a computer issue;

 

OS

CPU

GPU (graphix card)

RAM manufacturer/Amount

MotherBoard manufacturer/Brand of computer

Power Supply manufactuer/wattage

(I'm sure I'm leaving out something)

Connection speed/ISP

 

:edit: Good luck to you guys. It would be nice to figure out what is causing this issue.

Edited by NoGooD
Link to comment
Share on other sites

  • 0

I have a player on our servers that is having the same issue and getting kicked for the same API #.

 

He recently downgraded his laptop from Vista to XP and reinstalled ET. He could play fine on Vista, but Vista caused random crashes. XP is more stable but he is getting kicked for the same API problem. One suggestion I would like to make is you guys should post as much info on your computers as possible. Something like this might help if players getting kicked for the same things are say, running laptops with the same radeon GFX card.

 

I would suggest adding these when you ask for help on a computer issue;

 

OS

CPU

GPU (graphix card)

RAM manufacturer/Amount

MotherBoard manufacturer/Brand of computer

Power Supply manufactuer/wattage

(I'm sure I'm leaving out something)

Connection speed/ISP

 

:edit: Good luck to you guys. It would be nice to figure out what is causing this issue.

 

 

Using NVIDIA

3 MPS/SEC DSL

Ram 2.3 gigs Supertalent

Not sure of the power supply.

 

I got a response from Pb stating that if I'm using the following which I'm not:

"Note #2: If you are running Airfoil to stream music to an Apple Airport, please shut it down before starting a PB-enabled game. This should resolve your kick.

 

Let us know if it does not, or you are not running Airfoil." via Punkbuster support.

Link to comment
Share on other sites

  • 0

Using NVIDIA

3 MPS/SEC DSL

Ram 2.3 gigs Supertalent

Not sure of the power supply.

 

I got a response from Pb stating that if I'm using the following which I'm not:

"Note #2: If you are running Airfoil to stream music to an Apple Airport, please shut it down before starting a PB-enabled game. This should resolve your kick.

 

Let us know if it does not, or you are not running Airfoil." via Punkbuster support.

 

 

Hit START, then either in the search tab at bottom (vista) or the RUN tab (XP) enter "dxdiag", hit ENTER.

 

This will show you your system information and most importantly ALL your graphics information. Be more specific about your computer.

 

 

GOOD LUCK!!

Link to comment
Share on other sites

  • 0
  • Administrators

one question for you all. are you changing screen resolution before you get kicked?

 

Does win API res change error happens in XP also? I tried changing resolution in XP and it worked for mine. It never works on Vista though.

Link to comment
Share on other sites

  • 0
  • Administrators

Does win API res change error happens in XP also? I tried changing resolution in XP and it worked for mine. It never works on Vista though.

 

It does, but its most common in Vista. Oddly it only happend to me on vista x32 not the x64. I say blame ATi and nvidia nub drivers, btw getting new pair x5870 from a girl @ ati for my bday.

Link to comment
Share on other sites

  • 0
  • Administrators

It does, but its most common in Vista. Oddly it only happend to me on vista x32 not the x64. I say blame ATi and nvidia nub drivers, btw getting new pair x5870 from a girl @ ati for my bday.

 

Duh! I am stuck on laptop. :(

Link to comment
Share on other sites

  • 0

I found the issue. It was a program called AVG link scanner. What ever you do, don't ever install that.

It caused the whole pb api problem. Hopefully, pb will be aware of this. I was on other forums as well and many agree AVG is junk.

Edited by {DoG}Jarheadurpukes
Link to comment
Share on other sites

  • 0

I found the issue. It was a program called AVG link scanner. What ever you do, don't ever install that.

It caused the whole pb api problem. Hopefully, pb will be aware of this. I was on other forums as well and many agree AVG is junk.

 

Punkbuster denied that I found a simple solution.

 

I got a final response from pb:

 

Punkbuster:

"I doubt that is the issue as I personally use AVG products and PB with no issues at all."

 

My response:

 

"I disagree, the AVG link scanner was removed, thus correcting the issue.

I also deleted and manually reinstalled punkbuster. I have been to over 10 forums regarding this and all agreed that was the issue since there has been a history of AVG problems with ET users. In my case this use of the AVG link scanner was removed etc. I think pb should list what can work and cannot work with ET pb enabled, since punkbuster is always running on our computers.

I hope that you add do not install AVG link scanner to your computer as a means of helping fellow gamers like I did."

 

This proves that punkbuster is unwilling to listen even if a viable solution is found, which is just plain ignorant.

Link to comment
Share on other sites

  • 0
  • Administrators

This proves that punkbuster is unwilling to listen even if a viable solution is found, which is just plain ignorant.

 

LOL they replied to my PB Authentication ticket after 2-3 months :P

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.