Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

Mouse drifting on its own.

- - - - -

  • Please log in to reply
9 replies to this topic

#1
SiD

SiD

    Captain Jerkface

  • COD Member
  • 2,854 posts
4,249
Glorious beacon of light
  • Admin:15
  • Server:None
  • T-M:5-4

Donator

So for some reason my mouse seems to drift on its own in ET.

 

Was trying to get shit straightened out and noticed in the menus that the slightest movement causes the cursor to drift in one direction slowly. Can't do shit because I'm getting annoyed.

 

Using a logitech g600.

Unplugged it and tested with my touchpad does the same thing/

Disabled touchpad use G600, still doing it.

 

Anyone have this before?




Click here to login or here to register to remove this ad, it's free!

#2
Aniky

Aniky

    L9: Master

  • Regular User
  • 2,491 posts
2,050
Is a bearer of wisdom

Donator

Double drivers? Might want to update, reinstall drivers, seems something is messing up with software.



#3
Raskin

Raskin

    L8: Grand Teacher

  • Regular User
  • 1,889 posts
1,975
Name known to all
  • Admin:5
  • Server:Jay1
  • Alias:Raskin,pookie'

Donator

Yeah..I had before..had to delete drivers then reinstall downloaded drivers..or check in device manager to disable some drivers showing that are extra..you can't really totally delete all windows default drivers..think you have to leave one

Edited by Raskin, 20 September 2015 - 04:59 PM.


#4
SiD

SiD

    Captain Jerkface

  • COD Member
  • 2,854 posts
4,249
Glorious beacon of light
  • Admin:15
  • Server:None
  • T-M:5-4

Donator

Wait which drivers? Just the mouse drivers?

 

I checked in device manager and there's no duplicate mouse drivers.

 

I tested a bunch of games and it only seems to happen with ET at the moment. It also stops when the console is open surprisingly.



#5
Raskin

Raskin

    L8: Grand Teacher

  • Regular User
  • 1,889 posts
1,975
Name known to all
  • Admin:5
  • Server:Jay1
  • Alias:Raskin,pookie'

Donator

Yeah just mouse drivers..Or worst case reinstall ET? No other options option I can think of..

#6
Piotr2

Piotr2

    L3: Novice

  • Regular User
  • 101 posts
64
Getting Better
  • Admin:2
  • Server:Jay1
  • Alias:Piotr

Wait, Could you check for negative accelaration. MAybe you change sensitivity and it causes problems with mice.



#7
Ann![email protected]

Ann![email protected]

    L11: Assassin

  • Leader
  • 5,165 posts
6,675
Honorable bastion of truth
  • EvolveHQ:FA_Annibal
  • Admin:20
  • Server:Jay3
  • Alias:[email protected]
  • T-M:ET: 20-14

There's an option in device manager to unhide some devices unplugged. Try that and check if there's a driver installed in these hidden ones.

 

 

edit: use RevoUninstaller to remove the driver. This way you will be able to do a clean intall of this driver after reboot.


Edited by Ann![email protected], 22 September 2015 - 08:48 AM.


#8
SiD

SiD

    Captain Jerkface

  • COD Member
  • 2,854 posts
4,249
Glorious beacon of light
  • Admin:15
  • Server:None
  • T-M:5-4

Donator

Already installed ET. Didn't fix the issue.

 

Wasn't negative accel. Usually works a little different.

 

Checked for hidden drivers, nothing extra in there.

 

 

Uninstalled and reinstalled mouse drivers to no avail. Did find a new piece of the puzzle though.

 

I am using an external monitor for a dual setup on this laptop. I run my games on the monitor because it's bigger. For Shits'n'Giggles I moved ET's window back to the laptop side and the mouse drift stopped. So it seems for some reason my cursor is trying to move to the laptop screen when the window in on the external monitor.

 

Dafuq yo?



#9
Raider-

Raider-

    L3: Novice

  • Regular User
  • 126 posts
60
Getting Better

Blow into the optics, you probably have dust in it.



#10
Raskin

Raskin

    L8: Grand Teacher

  • Regular User
  • 1,889 posts
1,975
Name known to all
  • Admin:5
  • Server:Jay1
  • Alias:Raskin,pookie'

Donator

Disable dual monitor when playing games on big screen...maybe in your laptop graphics display settings also in graphics settings has tab for single display performance mode on 3D settings and you pick the program(game) to cusomize

Edited by Raskin, 22 September 2015 - 10:02 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users