Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

et lags in ubuntu

* * * * * 1 votes lag

  • Please log in to reply
30 replies to this topic

#1
rajaah thunder

rajaah thunder

    L4: Apprentice

  • Inactive Member
  • 446 posts
77
On the road to fame
  • Admin:12
  • Server:Silent #1
  • Alias:=F|A=Rajaah Thunder
  • T-M:ET: 1-0
hey guys , i recently installed ubuntu and et for linux , configured the sound and now everything's fyn except the fact tat the game is now too laggy .. here's a short demo of how i lag Attached File  2012-10-14-154420-venice_ne4.dm_84.zip   2.4MB   56 downloads


Click here to login or here to register to remove this ad, it's free!

#2
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,970
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor
Did u installed u GPU drivers?

#3
rajaah thunder

rajaah thunder

    L4: Apprentice

  • Inactive Member
  • 446 posts
77
On the road to fame
  • Admin:12
  • Server:Silent #1
  • Alias:=F|A=Rajaah Thunder
  • T-M:ET: 1-0

Did u installed u GPU drivers?

i checked in additional drivers and it dint show anythng ... my gpu is intel gma 950

#4
Antimony

Antimony

    L6: Expert

  • Inactive Member
  • 922 posts
108
On the road to fame
  • EvolveHQ:Antimony
  • Admin:12
  • Server:Jay1
  • T-M:1-1
Contributor
Check if you get good fps in glxgears.

Just type in terminal : glxgears

#5
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,090 posts
3,225
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor
I get poor fps in glxgears (and fgl_glxgears) unless I kill the composite manager, I also kill it when I play ET.
Maybe something in your desktop uses your gpu (transparency, shadows, and all sort of effects)

You can benchmark from within ET,

- download the radar demo in this post and put it in etman/demos (why this demo? because many people use it for benchmarks so you can compare the results...)
http://fearless-assa..._30#entry355465

- open et, type
/timedemo 1
and then
/demo radar
it will go as fast as possible and when it finishes, open the console and it will tell you how many fps you had.

Better than glxgears since it's ET itself.

#6
rajaah thunder

rajaah thunder

    L4: Apprentice

  • Inactive Member
  • 446 posts
77
On the road to fame
  • Admin:12
  • Server:Silent #1
  • Alias:=F|A=Rajaah Thunder
  • T-M:ET: 1-0

Check if you get good fps in glxgears.

Just type in terminal : glxgears

i get around 60 fps in glxgears .. is tat gud or bad
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
295 frames in 5.0 seconds = 58.856 FPS
300 frames in 5.0 seconds = 59.849 FPS
299 frames in 5.0 seconds = 59.653 FPS
300 frames in 5.0 seconds = 59.836 FPS
300 frames in 5.0 seconds = 59.844 FPS
300 frames in 5.0 seconds = 59.841 FPS


as for sunlight's post, i downloaded the demo ... will check into it asap

#7
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,090 posts
3,225
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor
so first of all you should disable vsync because for ET vsync = mouse lag

edit:
in glxgears you should get thousands of fps, I get more than 3600 with a crappy pc and atm I am doing other stuff together. Anyway I think it's a poor benchmark, I see it more as a tool to see if your drivers were installed properly, you should benchmark with et imho.

#8
rajaah thunder

rajaah thunder

    L4: Apprentice

  • Inactive Member
  • 446 posts
77
On the road to fame
  • Admin:12
  • Server:Silent #1
  • Alias:=F|A=Rajaah Thunder
  • T-M:ET: 1-0

so first of all you should disable vsync because for ET vsync = mouse lag

edit:
in glxgears you should get thousands of fps, I get more than 3600 with a crappy pc and atm I am doing other stuff together. Anyway I think it's a poor benchmark, I see it more as a tool to see if your drivers were installed properly, you should benchmark with et imho.


i cudn't run the demo .. the map almost loaded ..but suddenly it disconnected sayin some "unknown error 130 "

but the loading times were slower than normal :(

#9
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,090 posts
3,225
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor

i cudn't run the demo .. the map almost loaded ..but suddenly it disconnected sayin some "unknown error 130 "

but the loading times were slower than normal :(

It's an etmain demo, you shouldn't load any mod. Have you tried disabling vsync?

#10
rajaah thunder

rajaah thunder

    L4: Apprentice

  • Inactive Member
  • 446 posts
77
On the road to fame
  • Admin:12
  • Server:Silent #1
  • Alias:=F|A=Rajaah Thunder
  • T-M:ET: 1-0

It's an etmain demo, you shouldn't load any mod. Have you tried disabling vsync?

oh i loaded silent mod .. seems tatz y .. am downloading compiz settings manager , will notify u asap

#11
rajaah thunder

rajaah thunder

    L4: Apprentice

  • Inactive Member
  • 446 posts
77
On the road to fame
  • Admin:12
  • Server:Silent #1
  • Alias:=F|A=Rajaah Thunder
  • T-M:ET: 1-0
benchmarked it !! it was just 16.5 fps average :( ..any suggestions?

#12
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,090 posts
3,225
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor
First of all, disable vsync if possible (I don't know how, honestly, but you might have some control panel for that) or anyway make sure that in et you have:
/r_swapinterval 0

Then, I don't know much about Ubuntu and Unity, but check if you can kill compiz or any composite manager you might have (no idea about what ubuntu uses atm).

You could try running et in a separate X server if you have enough ram, and configure it to run with a basic window manager, but that would be a bit more complex imho

googling around I found a thread with people doing
metacity --replace &
then running a game
and then
unity --replace &

You should ask someone who uses Ubuntu, because I use Arch Linux and I don't even use a DM, just Openbox as window manager. But I do kill compton (a thing for transparency and compositing) when I play et, then I reload it after.
When I run et I also use a script with cpuset, to force everything to one core, and et alone in another, it feels a bit more responsive but maybe it's placebo. Anyway 16fps is wayy 2 low for this to have any effect, imho it's unity.

#13
rajaah thunder

rajaah thunder

    L4: Apprentice

  • Inactive Member
  • 446 posts
77
On the road to fame
  • Admin:12
  • Server:Silent #1
  • Alias:=F|A=Rajaah Thunder
  • T-M:ET: 1-0

First of all, disable vsync if possible (I don't know how, honestly, but you might have some control panel for that) or anyway make sure that in et you have:
/r_swapinterval 0

Then, I don't know much about Ubuntu and Unity, but check if you can kill compiz or any composite manager you might have (no idea about what ubuntu uses atm).

You could try running et in a separate X server if you have enough ram, and configure it to run with a basic window manager, but that would be a bit more complex imho

googling around I found a thread with people doing
metacity --replace &
then running a game
and then
unity --replace &

You should ask someone who uses Ubuntu, because I use Arch Linux and I don't even use a DM, just Openbox as window manager. But I do kill compton (a thing for transparency and compositing) when I play et, then I reload it after.
When I run et I also use a script with cpuset, to force everything to one core, and et alone in another, it feels a bit more responsive but maybe it's placebo. Anyway 16fps is wayy 2 low for this to have any effect, imho it's unity.

i never had this problem in windows ...
downloaded compiz config settings to disable vsync nd disabled it be4 benchmarking ... i no nthng about scripts .. my pc specs are
PROCESSOR:intel core 2 duo t2300 @1.66 ghz
RAM: 512 mb :P
HDD:60gb
GRAPHICS : INTEL GMA 950
grr ..... ubuntu users , check this post nd help me!!!!

#14
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,090 posts
3,225
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor
Windows is not Linux, so the way you do things is different, of course.
And in general they make drivers for windows first, and then (if, and when they do) for linux, so I don't know which drivers you are using for that card. If there are no proprietary drivers for linux then you are out of luck (if you wanna play games).

I tell you that I go faster on Linux than on Win (radeon card + proprietary drivers), or anyway it's smoother (I go faster if I set an option in my driver that lags my mouse, so I prefer not to)

back to the topic:
- disabling vsync is not *that* important (as long as you have r_swapinterval 0 in your et config) but it should be done from some graphics driver control panel or command line, I am not sure about doing it from compiz, it 'doesn't sound right' to me, Maybe you tell compiz not to use vsync but that's another matter than disabling it globally, i.e. from your graphics drivers setting (imho)
- unity and compiz may use opengl for their effects, and they could slow down et, that's why I suggested that thing metacity --replace (replacing compiz with metacity, which is lighter) but you might experience problems with it.

And the main problem here is your drivers performance in my opinion. Even if you used a very fast window manager like openbox or similar, without the correct drivers it would still be slower than windows.

#15
Anton Chigurh

Anton Chigurh

    L6: Expert

  • Recruiting Team
  • 926 posts
401
Has a brilliant future
  • Admin:17
  • Server:Beginners #2
  • Alias:=F|A=Anton
  • T-M:ET: 6-3
    CoD: 0-0
    TF2: 0-0
Intel GMA 950 isn't the best graphics card out there and the Linux support for Intel integrated chips doesn't even come close to Windows.

@Sun i guess your right.

And the main problem here is your drivers performance in my opinion. Even if you used a very fast window manager like openbox or similar, without the correct drivers it would still be slower than windows.


Been struggling with this issue before and decided for this hardware to use Windows.





Also tagged with one or more of these keywords: lag

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users