Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

Kick from Jaymod for MAX_CVARS

- - - - -

  • Please log in to reply
6 replies to this topic

#1
NoGooD

NoGooD

    L7: Teacher

  • Clan Friend
  • 1,092 posts
53
Getting Better
  • Server:None
Hey guys, I'm hoping one of your knowledgeable admins/players can help me out.

Most of the time I exec my cfg any of your jaymod servers, ET closes down with some kind of max_cvars error. Of course when I tried to recreate the problem today in your Jay#2 server, the damn thing worked fine.

I've gotten this on a few other jaymod servers running 2.1.7 or 2.1.8, but on any other mod I play (pub, NQ or Pro) I'm fine.

Just wondering if anyone else has had this problem?


Click here to login or here to register to remove this ad, it's free!

#2
vke

vke

    L6: Expert

  • Co-Leader
  • 991 posts
74
On the road to fame
  • Admin:19
  • Server:Hardcore ET
  • Alias:Valkyrie
  • Steam ID:STEAM_1:1:29319748
  • T-M:ET:1-0
Contributor
This happens to me everytime i try to connect to a jaymod server right after playing on another server. It was solved for me just by restarting ET everytime i want to play on a different server.

Also, it could be that your cfg is too large, try to make it several files instead of one, by having a line that says "exec binds.cfg" or something like that.

#3
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,970
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor
Type in console cvarlist and at the end if will tell you numbers. Let me know what it says. PM me your config or post it here.

#4
NoGooD

NoGooD

    L7: Teacher

  • Clan Friend
  • 1,092 posts
53
Getting Better
  • Server:None

This happens to me everytime i try to connect to a jaymod server right after playing on another server. It was solved for me just by restarting ET everytime i want to play on a different server.

Also, it could be that your cfg is too large, try to make it several files instead of one, by having a line that says "exec binds.cfg" or something like that.



That could be it. When I tried it today, I went straight to the F|A Jaymod server and it failed to kick me like it usually does.

I'll give that a shot Dare. I know where your going with it, and I was starting to think the same thing. Just to many CVARS. Right now my cfg is broken up into several smaller cfgs. Maybe I'll just have to make a "Jaymod Special" install of ET.

#5
-=Medic=-

-=Medic=-

    L10: Grand Master

  • Honored Veteran
  • 3,148 posts
178
On a distinguished road
  • Admin:14
  • Server:Jay1
  • Alias:-=Medic=-
Contributor
it's a bug on ET 2.55 not all time happen, that was fixed after 2.6b.

to avoid any future Max_cvars error be sure your cfg don't exceed 16K or never have more then 1000 lines... and like Valkyrie said split your config to 2 or 3 files ... i do have one for binds, script and one for game setting :P

Here a part changelog on 2.6b version :

MAX_CVARS increased to 2048 from 1024, as ET is relatively close to the 1024 limit with both client

and server cvars. Enlarged FILE_HASH_SIZE to compensate for the enlarged cvar table size.



#6
NoGooD

NoGooD

    L7: Teacher

  • Clan Friend
  • 1,092 posts
53
Getting Better
  • Server:None
Thanks medic.

My cfg is actually broken up into several smaller pieces, all of them being under 4-5 kb's. Most are much smaller. I'm guessing it's probably something to do with the actual number of cvars. I'll give Dares recommendation a try and post back.

Thanks for the info though guys. I'll check it out today and see what I come up with.

#7
NoGooD

NoGooD

    L7: Teacher

  • Clan Friend
  • 1,092 posts
53
Getting Better
  • Server:None
After testing out your suggestions and messing around a little bit, I think it's exactly like Valkyrie said. It only happens when your coming from another mod, which I usually am. I'm running/changed 963 cvars, have no cfg files bigger than 5kb and if I go straight into a 2.55 Jaymod server I don't get the game shutting down like usual. Hell, I might start playing Jaymod a bit again.

One thing I haven't tried yet was if this happens on 2.06b. I may try that tonight for the hell of it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users