Jump to content
  • 0
Thule

Couple bind questions ....

Question

Hello all.  I have a couple of minor issues with mouse binds that maybe someone can help with.  Since I started playing ET around late-2005-ish, I've normally bound mouse1 to fire, mouse2 to reload, and mouse3 to weapon-alt.  After a decade or so, one gets used to a particular setup.  Anywho, as to the issues:

 

Silent Mod:  For some reason I have to always rebind mouse2 to reload.  It is no big job, but it would be nice if it stayed put between sessions.

 

JayMod:  For some reason, I cannot get weapon-alt to bind to mouse3.  It has been some years since I've seriously played this mod, so I forget the work-around, or if there is even one.

 

Anyway, if anyone has a solution to either or both, I would value the information.  Thank you. :)

Edited by Thule

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

you can try to put your binds in an autoexec.cfg file and save it in the mod folder.

 

1.) Create new text file

2.) Rename it to autoexec.cfg (make sure you see known file types so you can change the .txt to .cfg)

3.) Right click and open the file

4.) Put in your binds like:

bind MOUSE1 "+attack"
bind MOUSE2 "+reload"
bind MOUSE3 "weapalt"
bind MWHEELUP ...
bind MWHEELDOWN ...
ECHO ^1 Executed autoexec ^6:) _ ^7=F^6|^7A=redy^6. ^7is such a wonderful person, heheh :)

5.) Save the file in the mod folder

6.) ingame open the console and execute it ones with "exec autoexec"

 

it should load now every time you start the game and you can update and expand it if you like

 

Ps: dont forget the echo :P heheheh

Share this post


Link to post
Share on other sites
  • 0

I think jaymod has a different cvar for alternate weapon. I do not currently have access to my computer so I cannot check what cvar it is. Try doing /bindlist to check or go to settings where you can check the cvar for alternate fire. It should be under ESC > Jaymod > Misc.

Edited by blackknight8653

Share this post


Link to post
Share on other sites
  • 0

For Jaymod, once in game, hit ESC, Jaymod, Misc, and there is a place to select ALT fire bind.

 

For Silent, I'm not sure what your issue exactly is, but I would try to /unbind and then /bind.

Edited by docwarren

Share this post


Link to post
Share on other sites
  • 0

@redy.  Thanks!  I'll give that a whirl tomorrow.  Lol @ echo. :)

 

@docwarren.  Thank you.  I've tried that, but it just flashes the "???" response whenever I try that.  It is really odd.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

OK. Then go under ESC, Controls and find out what mouse 3 is bound to and change it before you go into the Jaymod, Misc thing.

Share this post


Link to post
Share on other sites
  • 0

 

@docwarren.  Thank you.  I've tried that, but it just flashes the "???" response whenever I try that.  It is really odd.

 

The ??? means that the next key that you press will be set to that command, unless it is esc to leave the menu.  

 

If you do set this and then check the alt-fire in the ET-options, it will be disabled there while you have jaymod loaded.  That is normal.  

 

If you then load Silent or another mod, the ET-options alt-fire will look normal again.  We hope. :)

Share this post


Link to post
Share on other sites
  • 0

Sorry, I should have phrased that better.  It shows the "???" as it should, then the next keypress is the right one (mouse3), but instead of accepting the entry it just blinks "???" without changing.  I'll give it another whirl though.  Thank you. :)

Share this post


Link to post
Share on other sites
  • 0

Sorry, I should have phrased that better.  It shows the "???" as it should, then the next keypress is the right one (mouse3), but instead of accepting the entry it just blinks "???" without changing.  I'll give it another whirl though.  Thank you. :)

 

I just tested that and it works for me.  Why don't you do "/bind mouse3 say eek!", just to see if the signal is getting through to ET.


 

ADDED:  I just checked my jaymod\profiles\redbaird and found that the config there contains this:

 

bind MOUSE2 "+attack2"  //this is my alt-fire button

 

so you could try /bind MOUSE3 "+attack2"

Edited by RedBaird
added attack2

Share this post


Link to post
Share on other sites
  • 0

Resetting it through the JayMod-specific menu did the trick.  I had forgotten that particular setting was under Misc in that mod.  It has been a while.  Thanks all.  Much appreciated. :)

Edited by Thule

Share this post


Link to post
Share on other sites
  • 0

YW :) from us All.

 

BTW, I just found that Silent also uses the +attack2 for alt-fire

Share this post


Link to post
Share on other sites
  • 0

Thanks for the heads up, RedBaird.  Much obliged. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×