Jump to content
  • 0
ZillA*

Ubuntu and ET

Question

Hey guys,

 

I installed Ubuntu recently but it seems like I can't get ET working on it.

I got to the point it runs with no sound and when connecting it says there is no GUID.

 

I know there a lot of how-to's but still, I can't seem to make it work.

How did you guys make it work? I know there is playdeb but I don't quite understand the installation steps.

 

 

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0

I had the issue with sound also when I ran ET on Ubuntu a few years ago. THere IS a fix, I Googled it and it worked. I'll try to find it. The other option is to run it with Wine

 

Edit:: Try this: https://ubuntuforums.org/showthread.php?t=1500435

Edited by -=HipKat=-

Share this post


Link to post
Share on other sites
  • 0

For some reason I think I might installed this game in a wrong way.

I don't have ".etwolf" located in /home/username/ :dntk

Share this post


Link to post
Share on other sites
  • 0

For some reason I think I might installed this game in a wrong way.

I don't have ".etwolf" located in /home/username/ :dntk

Which steps did you follow?

 

As regards the sound it's normal there is no sound I think, unless you use et-sdl-sound

Share this post


Link to post
Share on other sites
  • 0

I've tried installing using playdeb.

 

EDIT:

 

Ok I managed to get the game working. I installed wine and ran the .exe setup with it.

Only problem now is I don't find the location of my etmain folder to put cfg in it.

Also the console is not showing up when i press the ²-key :(

Edited by ZillA*

Share this post


Link to post
Share on other sites
  • 0

I had the issue with sound also when I ran ET on Ubuntu a few years ago. THere IS a fix, I Googled it and it worked. I'll try to find it. The other option is to run it with Wine

 

Edit:: Try this: https://ubuntuforums.org/showthread.php?t=1500435

 

I tried this:

 

sudo killall esd

sudo -i

echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss

exit

et

 

but But it says Bash: /proc/asound/card0/pcm0p/oss: File or folder does not excist.

 

EDIT: I've managed to get ET working, for now I only got issues with the sound and i can't seem to constrol my fps at the moment.

Even with /com_maxfps it won't change :s

Edited by ZillA*

Share this post


Link to post
Share on other sites
  • 0

I never did really like playing it on Ubuntu. No custom configs, so everything was default settings and I never could figure out how to fix that except what you could change in the menu but it just was terrible in my opinion

Share this post


Link to post
Share on other sites
  • 0

I never did really like playing it on Ubuntu. No custom configs, so everything was default settings and I never could figure out how to fix that except what you could change in the menu but it just was terrible in my opinion

Actually I'm just trying this out to see if it runs more smoothly or not

Share this post


Link to post
Share on other sites
  • 0

I tried this:

 

sudo killall esd

sudo -i

echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss

exit

et

 

but But it says Bash: /proc/asound/card0/pcm0p/oss: File or folder does not excist.

don't use uberold tutorials that maybe don't work with more recent Linux versions (and also don't type commands if you don't have at least an idea about what they do)

 

I use Arch Linux so I can't help much with Ubuntu, but in order to have sound you need et-sdl-sound I think

 

EDIT: I've managed to get ET working, for now I only got issues with the sound and i can't seem to constrol my fps at the moment.

Even with /com_maxfps it won't change :s

are you sure it's not a drivers problem (like playing with vsync on?)

 

 

I never did really like playing it on Ubuntu. No custom configs, so everything was default settings and I never could figure out how to fix that except what you could change in the menu but it just was terrible in my opinion

Why no custom configs lol... it's the same as on Windows. You probably installed it wrong, or you don't know where the files for the configs are (i.e. ~/.etwolf)

 

Actually I'm just trying this out to see if it runs more smoothly or not

It won't run more smoothly if you run it under wine (which is a Windows emulator) you need to run the real Enemy Territory for Linux

 

by the way, if you use wine you should look in ~/.wine/drive_c

 

but really it makes no sense to me running it via wine when you have the native Linux one

 

About the console, the key on Linux is different for me (actually, it's the same if you use wine, I talk about the *real* ET for Linux) but I have an Italian keyboard so I don't know which key will open it for you. I need to press Alt Gr + a key near enter you probably don't have

Share this post


Link to post
Share on other sites
  • 0

I'd like to use it without wine ofcourse.

 

et-sdl-sound is indeed the right thing I need but at the moment I have no idea where to find it and what i should do with it.

About the FPS, yes it probably is a setting I need to change.

 

EDIT: I managed to open the console.

Edited by ZillA*
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

et-sdl-sound is a script to launch ET with a library that adds the sound, I could zip it and upload it in the download section maybe.

 

Here I found an et-sdl-sound installer, maybe you could try it, or wait till I check mine

http://http.kernwaffe.de/et/ET-Installer/

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

et-sdl-sound is a script to launch ET with a library that adds the sound, I could zip it and upload it in the download section maybe.

 

Here I found an et-sdl-sound installer, maybe you could try it, or wait till I check mine

http://http.kernwaffe.de/et/ET-Installer/

 

If i run that file using

ch ./et-sdl-sound

Wolfenstein starts running but again without sound...

 

EDIT: maybe this can help us out ?

------- sound initialization -------
Sorry but your soundcard can't do this
------------------------------------
Sound memory manager started
Sys_LoadDll(/home/tim/.etwolf/etmain/ui.mp.i386.so)... 
Sys_LoadDll(/home/tim/.etwolf/etmain/ui.mp.i386.so) failed:
"/home/tim/.etwolf/etmain/ui.mp.i386.so: cannot open shared object file: No such file or directory"
Sys_LoadDll(/usr/local/games/enemy-territory/etmain/ui.mp.i386.so)... ok
Sys_LoadDll(ui) found **vmMain** at  0xdbb13f40  
Sys_LoadDll(ui) succeeded!

Edited by ZillA*

Share this post


Link to post
Share on other sites
  • 0

et-sdl-sound must be configured, in particular SDL_AUDIODRIVER, maybe you need pulse instead of alsa if you use pulseaudio

Share this post


Link to post
Share on other sites
  • 0

et-sdl-sound must be configured, in particular SDL_AUDIODRIVER, maybe you need pulse instead of alsa if you use pulseaudio

Allright, I got the sound working.

I had to set the GAME PATH and LIBSDL. Allthough the sound quality is very poor. (scratchy sound)

 

Now I'm looking to fix the 60fps/60Hz issue.

 

EDIT: I've managed to increase my fps! In settings I had to choose the right driver that fit my graphics card, Nvidia.

 

Thanks for the help, I hope this topic can mean something for somebody in future.

You can set this in GAME_PATH environment variable
# GAME_PATH="/home/tim"

# libSDL.so
#
# You can set this in LIBSDL environment variable
# LIBSDL="/usr/lib/i386-linux-gnu/libSDL-1.2.so.0"
Edited by ZillA*

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×