Jump to content
  • 0
Naron Bashorr

ET on Macbook Pro (2013 version) not able to run

Question

Want to start playing ET again after +5 years, I got a brand new MB pro a year ago, but it seems like I can't run it anymore. Anyone with a quite recent MBP who knows how to run ET ?

 

I get the error message that my laptop doesn't support PowerPC applications anymore.

 

Specs:

 

I am running on OSX Mavericks 10.9.2,

- 2.9 GHz Intel Core I7

- 8GB RAM, 1600 MHz DDR3

- Videocard:  Intel HD Graphics 4000 1024 MB

 

Hope I can find some help soon, would highly appreciate it :)

 

Thanks in advance !

 

 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Yes, the issue is that W:ET is a PowerPC application- and support (Rosetta) for those was dropped with the introduction of 10.7 Lion.

Here's a newer port of W:ET that will work on your mac: http://www.etlegacy.com/

Have fun! :)

Share this post


Link to post
Share on other sites
  • 0

Hi there Xernicus !

 

I can only find download links for Linux and Windows it seems .. :(

http://www.etlegacy.com/index.php?r=etlcontrol/release/download

 

 

Yes, the issue is that W:ET is a PowerPC application- and support (Rosetta) for those was dropped with the introduction of 10.7 Lion.

Here's a newer port of W:ET that will work on your mac: http://www.etlegacy.com/

Have fun! :)

Share this post


Link to post
Share on other sites
  • 0

Bump & update;
 

Posted on etlegacy forums, they might consider a Mac version "in the future", anyone else has a working solution to play it at the moment :) ?

Share this post


Link to post
Share on other sites
  • 0

I'll compile you a version that will work. Should be done this evening, as I'm busy throughout most of the day.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I'll compile you a version that will work. Should be done this evening, as I'm busy throughout most of the day.

 

Whatever fits you ! Really glad you're helping :)

Share this post


Link to post
Share on other sites
  • 0

Sorry it's taking me awhile.
I'm looking for some source code that allows you to join servers besides SilenT and Legacy mod. It supposedly exists, I just have to do some digging through their git repository. :P

Share this post


Link to post
Share on other sites
  • 0

Sorry it's taking me awhile.

I'm looking for some source code that allows you to join servers besides SilenT and Legacy mod. It supposedly exists, I just have to do some digging through their git repository. :P

 

I'll keep checking this tread from time to time :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×