Jump to content
  • 0
Sign in to follow this  
Blackguard

Framerate drops

Question

Alright so I seem to have noticed that I am unable to hold my fps cap regardless of what my settings are. This only tends to be on certain maps though. So I need some advice on tweaking my cfg, because try as I might to find a workable setup, it still escapes me. I have included my CFG for review.

 

So my system spec is:

 

Vista Ultimate SP2 - Tweaked unnecessary services, not using an aero theme.

 

AMD Athlon X2 6000+ 3.0 Ghz

4 gigs of ram (actually 3 at the moment, but thats extremely temporary)

Nvidia 9800 GTX+ 512MB

 

Its definitely time for a new machine, but this is what I have to work with at the moment.

 

 

So right now I default to com_maxfps 125, on a few maps my FPS dips below this level and then I just choke it back to 76. However occasionally I'm finding that my frame rate begins dropping even below 76 capped ( Most recently on Goldrush ). Which doesn't make a ton of sense to me given that on other maps I'm throttling at 125 without a problem.

 

It seems to be related in some way to the direction I am facing in game as if rendering into the distance was the problem. So I decided to try tweaking r_lodbias and r_lodscale. However these didn't seem to really help in any way. I originally had r_picmip at 0, then 1, and now 2 which didn't seem to have a serious effect on my frame rate one way or another, and didn't help me keep my cap either. I've really got no idea at this point, if I can't diagnose whats causing the drop in FPS I can't really fix it. So anybody with any idea to try, I would be extremely grateful.

 

I would like to keep my resolution at 1680x1050 if possible, but if you think my system can't handle it I'd be happy to give adjusting it a try.

 

Note: My cfg was written in notepad with a monospaced font, so it might not look very organized if you open it with wordpad.

blackguard.cfg

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Wierd... my comp has less gpu power, but i can squeeze 250 fps most maps, 125 on oasis and fuel.

 

 

I think you should try a map specific cfg just for the maps that your fps sux. Set all graphics as low as possible, except res, save it as autoexec_goldrush(or other map name).cfg. I think this works in jaymod, but idk.

 

Try

r_picmip2 "3"
r_picmip "3"
r_lodbias "3"
r_texturebits "16"
r_simpleMipMaps "1"
r_subdivisions "2"
r_fastsky "1"
r_drawSun "1"
r_lodCurveError "250"

Share this post


Link to post
Share on other sites
  • 0

Jaymod doesn't support map specific cfgs.

 

Try r_mode 6.

Share this post


Link to post
Share on other sites
  • 0

Jaymod doesn't support map specific cfgs.

 

Try r_mode 6.

 

 

Is there any particular reason you chose r_mode 6? Or just because its a lower resolution? Because I'd prefer to still set a widescreen resolution if its just the amount of pixel data you think is the problem.

 

In either case, testing r_mode 6 now for improvement.

 

Update:

 

Still experiencing the same effects at r_mode 6. Unable to hold steady at either 125 or 76 facing certain directions. No idea whats up.. but dropping the resolution anymore I might as well go back to pong.

Share this post


Link to post
Share on other sites
  • 0

This is what ET support officially. Offcourse you can try r_mode -1 but then again frame drops.

 

shot0002.jpg

 

More or less remove the r_displayRefresh 60. ET will read the value from monitor drivers. If you have stable connection use 100 maxpackets and remove seta rate 42000 from config. Jaymod will auto optimize it.

 

Edit: Post the screenshots with lagometer on. I can get stable 125 or even 333 from my friends desktop.

Share this post


Link to post
Share on other sites
  • 0

Alright I made the changes to my config that you suggested.

 

Got some screenshots, I took most of them from spec, but I tried to stay in places I would possibly or could actually be. They're at different resolutions as I was checking different r_mode for improvement in the FPS drop. I'll include the whole album rather than post everything I uploaded to keep this from being 8 miles long.

 

Screenshot Album

 

 

 

Here @ 1360x768 facing down an empty bridge in Venice

39spec.jpg

 

 

Here @ r_mode 6, just facing the spawn point buildings in venice.

48spec.jpg

 

 

Here back @ my original 1680x1050 resolution.

56Play.jpg

 

 

 

 

In the album there is one of me facing a wall doing 64 fps lol. For the majority of most maps I'm stable at 125 fps even @ 1680x1050. It only seems to be facing certain locations that I'm butchered down to sub 76 frames. I would suspect certain maps are just worse on frame rate in general, but it seems like I should still be able to manage 76 fps minimum with my settings low @ r_mode 6. Anyway thanks for taking the time to have a look. Let me know if you want any other screen shots at different resolutions or settings.

Share this post


Link to post
Share on other sites
  • 0

Those are map errors. Only mappers can fix it. I think UJE clan is still around. I will pass on screenshots to them so if they like they can fix it in their new version.

 

I am not sure what it is called technically but Paul/Ninja knows what causes FPS drop at certain locations in map for no reason.

Share this post


Link to post
Share on other sites
  • 0

Map errors, huh. Alright then that sucks pretty hard for me lol. They're not all so bad, but places like facing down the bridge or toward the spawn point in venice make it pretty hard to play sometimes. Usually trying to get by top rated fraggers there who don't have the same problem facing the other direction lol.

 

Anyway thanks for passing it on to UJE. I suppose I'll try again to find a combination of settings that keeps these areas reasonably playable for me. Thanks again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.