Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

How I Solved PB, Finally

- - - - -

  • Please log in to reply
3 replies to this topic

#1
HipKat

HipKat

    L1: Learner

  • Deactivated
  • 13 posts
2
Unknown at this point
  • Server:None
  • Steam ID:HipKat2000
Redbaird asked me to post this after we finally got my PB to work, although it's still not perfect.

The problem was that by running pb_cl_enable and then reconnecting, I would have this really bad lag every few seconds. The game would freeze for just a second.

What I did was go to etkey,org, naturally, and ran THIS PB installation: http://wolffiles.de/filebase/ET/Tools/ETPunkBuster_Setup_And_KeyGen.zip

I already had pbsvc.exe from way back, so I ran that, too. I also added punkbuster a and punkbuster b to my startup menu, then rebooted and started ET.
Also, with Vista and Win 7, you need to go to Users\[USER NAME\] or Administrator\, if you use the Super Administrator Mod, then ...\AppData\Local\PunkBuster\ET\etmain and copy your etkey to that folder. I had to creat the path ...\ET\etmain\ and THAT was why I had the lag. The path to the etkey was incorrect.

When I join the server, pb is not running, (Probably because I use TZAC and play ET Pro a lot) so l I have to run pb_cl_enable in console (I made it a bind in my cfg now) and then reconnect, but the lag is gone and I finally have XP Save.

I'm not sure if this helps or if anyone will read this and think I'm an idiot for something you already knew, but I did say I would post it


Click here to login or here to register to remove this ad, it's free!

#2
Heretic121

Heretic121

    People. F*cking people.

  • Honored Veteran
  • 3,221 posts
2,728
Is a bearer of wisdom
  • Xbox Live:Heretic121
  • EvolveHQ:Heretic121
  • Admin:20
  • Server:COD4 #3
  • Alias:=F|A=Heretic121
  • Steam ID:STEAM_0:1:51700684
  • T-M:ET: 6-5
    COD: 11-6

Donator

Contributor
Thanks for the information, Hipkat. I'm sure someone will find it of some use :)

#3
RedBaird

RedBaird

    What does this thing do? I will push it and see...

  • Leader
  • 6,189 posts
4,860
Glorious beacon of light
  • EvolveHQ:FA_Redbaird
  • Admin:20
  • Server:Jay1
  • Alias:=F|A=RedBaird
  • T-M:ET: 13-4

Donator

then ...\AppData\Local\PunkBuster\ET\etmain and copy your etkey to that folder. I had to creat the path ...\ET\etmain\ and THAT was why I had the lag. The path to the etkey was incorrect.

Thanks for posting, you not-an-idiot. It seems people with Win7 have more PB problems than others. That TZAC glitch is known, but not by all.

Do you think that the incorrect path in AppData was a PB install error, or from a prior attempt to manually place the etkey in the path?

Did you /seta pb_sleep 500 ?

It was very gratifying to see you re-connect to FA Jaymod and have that nice long GUID from your etkey showing.

#4
HipKat

HipKat

    L1: Learner

  • Deactivated
  • 13 posts
2
Unknown at this point
  • Server:None
  • Steam ID:HipKat2000

Thanks for posting, you not-an-idiot. It seems people with Win7 have more PB problems than others. That TZAC glitch is known, but not by all.

Do you think that the incorrect path in AppData was a PB install error, or from a prior attempt to manually place the etkey in the path?

Did you /seta pb_sleep 500 ?

It was very gratifying to see you re-connect to FA Jaymod and have that nice long GUID from your etkey showing.


Thanks, Yeah, I put that in my CFG too so it runs when I exec my cfg




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users