Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

~ key sucks!

- - - - -

  • Please log in to reply
10 replies to this topic

#1
Dan Havoc

Dan Havoc

    L2: Beginner

  • User
  • 35 posts
0
Unknown at this point
  • Admin:0
  • Server:None
How do I change the button that opens the console? I keep opening the console when I need to select my knife :/


Click here to login or here to register to remove this ad, it's free!

#2
Hulk

Hulk

    L7: Teacher

  • Deactivated
  • 1,177 posts
28
A step in the right direction
  • Admin:0
  • Server:None
You would probably get more responses if you posted in right section this one is for making an apply.Try this My link

#3
Saizou

Saizou

    L7: Teacher

  • Leader
  • 1,445 posts
107
On the road to fame
  • Admin:20
  • Server:Jay1
  • Alias:Saizou, Boris
Contributor
You'll have to edit it either in your .cfg (if you don't have one, it might be good to create it now) or do /unbindall in console (NOT recommended as all controls will be removed, only do this if you have a .cfg ready which you can /exec and restore controls).
If you edit in the .cfg, search for the line that says:
bind ` "toggleconsole"
and replace ` with whatever key you want.

#4
ohurcool

ohurcool

    L5: Journeyman

  • Regular User
  • 710 posts
32
Getting Better
  • Admin:0
  • Server:Hardcore ET
use the main menu if all else fails

Esc > Controls..

#5
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,093 posts
3,231
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor
you can assign it to another button (in addition to the standard one), but afaik you cannot remove the original bind

if you use your knife a lot and you are not accurate enough not to hit another key, the only solution is binding weaponbank 1 to another key... or maybe remap the keyboard in some way outside the game, I have no idea if it would work

#6
ZeeKoh

ZeeKoh

    L3: Novice

  • User
  • 280 posts
1
Unknown at this point
  • Admin:9
If you don't use your mouse wheel to scroll through weapons, which, obviously you don't, then you can and SHOULD bind mousewheelup and mousewheeldown to something else. You can easily set one to switch to weapon bank 1, in other words your knife, and set the other to switch to anything else. My mousewheelup is bound to weaponbank 6 and my mousewheeldown is bound to weaponbank 5. So when playing as a Medic, when I scroll my wheel up, I switch to med packs, when I scroll down, I switch to my syringe. I use to have the knife set to mousewheelup but I found the number 1 a lot easier to hit, than 5 or 6. I don't do it a whole lot, but sometimes when I go to revive people, I accidentally hit 4 and prime a nade because I'm usually in a hurry. Using my wheel negates that from ever happening. :P

#7
Dan Havoc

Dan Havoc

    L2: Beginner

  • User
  • 35 posts
0
Unknown at this point
  • Admin:0
  • Server:None

You'll have to edit it either in your .cfg (if you don't have one, it might be good to create it now) or do /unbindall in console (NOT recommended as all controls will be removed, only do this if you have a .cfg ready which you can /exec and restore controls).
If you edit in the .cfg, search for the line that says:

bind ` "toggleconsole"
and replace ` with whatever key you want.


I edit it with notepad and write the name of the key [eg:bind Home "toggleconsole"]?

And I do this for every instance it appears in the ,cfg?

you can assign it to another button (in addition to the standard one), but afaik you cannot remove the original bind

if you use your knife a lot and you are not accurate enough not to hit another key, the only solution is binding weaponbank 1 to another key... or maybe remap the keyboard in some way outside the game, I have no idea if it would work


Every time you post, I spend more time watching your avatar than reading the thread...

#8
Saizou

Saizou

    L7: Teacher

  • Leader
  • 1,445 posts
107
On the road to fame
  • Admin:20
  • Server:Jay1
  • Alias:Saizou, Boris
Contributor

I edit it with notepad and write the name of the key [eg:bind Home "toggleconsole"]?

And I do this for every instance it appears in the ,cfg?


There should be only one line like that by default. Unless you have multiple keys to open it. Just edit one instance of it and delete others (if there are any).

#9
Dan Havoc

Dan Havoc

    L2: Beginner

  • User
  • 35 posts
0
Unknown at this point
  • Admin:0
  • Server:None
Oh, I see it now. It looked like a Mash when i opened it in notepad. there were no line breaks (but there were when I copied the text- IDK). It appears one for ` and once for ~

:thanks

#10
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,093 posts
3,231
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor

Oh, I see it now. It looked like a Mash when i opened it in notepad. there were no line breaks (but there were when I copied the text- IDK). It appears one for ` and once for ~

:thanks


sorry for animated avatar :P

but if you want to *disable* that key, I think it's impossible. you can open your game console even after an /unbindall because it's hard coded.

#11
ZeeKoh

ZeeKoh

    L3: Novice

  • User
  • 280 posts
1
Unknown at this point
  • Admin:9
If you REALLY are annoyed by it, you can use a program called KeyTweak to remap the buttons on your keyboard in Windows. You can find it here. Download and run the app. When you get the program to load up, just find your ~ key on the on-screen keyboard, it should be the key with a 1 on it, select it and change what button you want it to be set to in the drop-down menu on the bottom half of the screen. Click the "Remap Key" button to the right of the drop-down menu. Afterward, click the Apply button in the bottom right corner of the window and click yes to restart your computer.

Just keep in mind that this will change the key's function in Windows itself, not just in-game. So you might want to remap ~ to whatever key you used to replace it. Otherwise you'll just have 2 of the same key on your keyboard. There's also a "Disable Key" button for disabling keys, but I wouldn't condone disabling a key altogether. You can always load up KeyTweak and click on the "Restore All Defaults" button to set everything back to normal.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users