Jump to content

  • Log in with Facebook Log in with Twitter Log In with Google Sign In
  • Create Account
Photo

Bf4 browser suggest?

- - - - - bf3 bf4

  • Please log in to reply
3 replies to this topic

#1
2rk

2rk

    L2: Beginner

  • Regular User
  • 33 posts
30
Getting Better
  • Server:Silent #1
  • Alias:2rk'ich.

Hi everyone,I m not pretty sure about Bf3 and bf4 have same way about supports or errors,

when I m trying to join servers it says " Unsupported browser"

but also I have been tried already 3 browser and both system(32-64bit) and moved to settings and tried to exchange privacy options but still doesnt work.

any1 have an idea for solution? thx for now




Click here to login or here to register to remove this ad, it's free!

#2
equaLz

equaLz

    L5: Journeyman

  • Regular User
  • 725 posts
451
Has a brilliant future
  • Xbox Live:Nefarious Cheat
  • EvolveHQ:equaLz
  • Admin:10
  • Server:Silent #1
  • Alias:equaLz

Donator

Which browser do you use? I would recomend Firefox.

Also make sure you got the Battlelog Plugin installed.

Edited by equaLz, 28 June 2016 - 02:13 AM.


#3
2rk

2rk

    L2: Beginner

  • Regular User
  • 33 posts
30
Getting Better
  • Server:Silent #1
  • Alias:2rk'ich.

already I triend on firefox at first my friend ,when I took that error,I installed edge(ie) and at tha last chrome but same error :(



#4
equaLz

equaLz

    L5: Journeyman

  • Regular User
  • 725 posts
451
Has a brilliant future
  • Xbox Live:Nefarious Cheat
  • EvolveHQ:equaLz
  • Admin:10
  • Server:Silent #1
  • Alias:equaLz

Donator

I would recommend you to use this client: http://tempstatic.ro...m/Battlelogium/







Also tagged with one or more of these keywords: bf3, bf4

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users