Jump to content
Ol Smoke

Echo in Teamspeak found....

Recommended Posts

I have been using Teamspeak3 for about a month or so and had no problems until today.

Several guys on there said I was the cause of a constant echo, and that my microphone was

constantly on.  This seemed odd to me because it had worked great up to then.

 

So I set about to find out what happened. And here is what I found:

 

I plugged in my speakers the other day to hear some new music from a group I am helping.

I unplugged the USB mike-set that I had been using.

When I got back on Teamspeak I did not unplug the speakers but only turned them off.  I then

plugged in the USB mike-set as usual.  And that is what caused the echo effect heard on

Teamspeak today.  Event though the speakers weren't on, they were still plugged into the sound

board and the sound board treated them as being on.  So when I plugged in the USB Mike-set

I had a loop effect going, but could not hear it because the speakers were turned off.

 

So if you are using a headset with a microphone on it, be sure to unplug the speakers before using

Teamspeak.

Edited by Ol' Smoke
  • Like 2

Share this post


Link to post
Share on other sites

So when you unplug the speakers, there's no echo?

Share this post


Link to post
Share on other sites

Good catch, and good to know.

Share this post


Link to post
Share on other sites

Aha, that may be the answer to some echo issues i've been having as well.

.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×