Jump to content
  • 0
stoney baloney

hello! and help (ubuntu problems)!

Question

hey guys-- some of you may remember me from Jay2... i had to leave for several months for a job that ended up being absolutely terrible! so i'm back closer to civilization, and needing to play et again.

 

the only problem is... i have a new computer with Ubuntu on it (love it!), but i can't seem to install ET properly. i'm having permission errors that i've tried to resolve using chmod, and also trying to re-install under my 'guest' account, but that doesn't work either... i'm just now learning linux, so i've scoured many forums with mostly the same result. et will run and allow me to *start* to connect to a server, but it tells me the same old song (invalid GUID) that most new installations create, but on Ubuntu, i can't put the etkey in the etmain directory, because of permission errors. i've tried logging on as a super user, and even that doesn't work.

 

is there any way someone can walk me through this? after months of NO gaming, i really need to sublimate my aggression in a healthy way.

 

i hope this finds you all well... i want to get ET running again, and then i will reconnect with you all... especially you, Bacon. i'll connect with you ALLLL night.

 

peace,

-Stoney

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

etkey should be added to ~/.etwolf/etmain

That is, under your home folder there should be a hidden folder ".etwolf"

If you are in Nautilus File Browser or something similar, you should be able to go to Menu > Files > Preferences > Show hidden files

 

If it still doesn't work after putting the etkey there, you might try downloading PB Setup to run manually

 

 

If you want to start from scratch, here are some guides:

 

While on Ubuntu 13.04 I used PlayDeb. Here is a link to Enemy Territory in PlayDeb.

Playdeb has OUTDATED instructions: How to Install Games from PlayDeb

So here are some more accuracte instructions:

  1. Configure the repository manually:
    1. Go to Software & Updates (either search "Software" in Unity Launcher or click system button and go System Settings)

    2. Go to Other Software tab

    3. Click Add and type in: deb http://archive.getdeb.net/ubuntu raring-getdeb games

    4. Make sure it is checked as selected in the list after you add it

  2. Update your repositories

    1. Go to Terminal (search "Terminal" in Unity Launcher)
    2. type in: sudo apt-get update
  3. Install game

    1. manually from Ubuntu Software Center:

      1. Go to Ubuntu Software Center (search "Ubuntu Software" in Unity Launcher)

      2. Next to the All Software tab there is a drop-down arrow. Select GetDeb from the drop-down

      3. Search for enemy-territory

      4. Install enemy-territory and enemy-territory-data

    2. automatically from PlayDeb website

      1. Go to the PlayDeb page of enemy territory

      2. Click the "Install this now" button below the screenshot

      3. In The Launch Application window select apturl

        1. If apturl isn't listed, click Choose to select it: File System > usr > bin > apturl

 

 

While on Mint MATE 15, I installed it manually, but that is a bit of a chore.

There are many tutorials out there.

Debian Tutorial

Ubuntu Tutorial

Fearless Assassins Tutorial

The important thing I can note is that on newer linux systems I needed the SDL hack to get my sound working.

 

Edited by a dog

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×