Jump to content
  • 0
schNee

...fps/mouse struggling, ram issue, websites & et

Question

...ello =)

 

so since 2 days i notice that i have a weird issue while playing.

 

my et is limiting my fps to 60fps (i can see on screen, that it wants more fps but just dont get up).

at the same time, my mouse feels like freezed a bit. this issue comes from time to time and is gone after mostly a minute again.

 

another weird thing is, that as soon as im opening a website while playing, i have big lag spikes. if there is activity on this website e.g. getting message on facebook, i got lags :o

how can this be, i assume it's about hunkmegs, but i have more than enough RAM for this tiny game.

 

Thanks for support.

 

cookie for ur help!

 

I'll can upload my cfg later, afaik i also made a demo and screenshot while it was happening.

 

cheers Saskia

 

edit: i tweaked my cfg a bit the last days so my ping becomes bit better, this actually worked out (now on silent ~100, before i had 130) dunno if its important.

post-19741-0-04165600-1475573772_thumb.jpg

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

First thing I´d check CPU\GPU temps, clean up pc if necessary. Also Task Manager doesn´t show any resource hogging applications running?

Maybe Vsync is turned on?(ticked ON in GPU driver settings?)

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

for your fps check vertical sync like vanaraud said, it limits your fps to your monitor refresh rate which is 60 usually, it should be OFF. There's a cvar for it on ET too but im not sure if it has any impact; r_swapinterval 0

 

for me I usually close all innecessary programs so my game can run smoothly, maybe give it a go 

Share this post


Link to post
Share on other sites
  • 0

First thing I´d check CPU\GPU temps, clean up pc if necessary. Also Task Manager doesn´t show any resource hogging applications running?

Maybe Vsync is turned on?(ticked ON in GPU driver settings?)

 

nope there are no other resources uded. im closing all other stuff.

 

for your fps check vertical sync like vanaraud said, it limits your fps to your monitor refresh rate which is 60 usually, it should be OFF. There's a cvar for it on ET too but im not sure if it has any impact; r_swapinterval 0

 

for me I usually close all innecessary programs so my game can run smoothly, maybe give it a go 

 

i have all other progs closed when i play. but i got lags for example also in ts. u remember the helium action. i got lag spikes in the moment . so really weird cause usually there is enough ram. i have 16gb

 

regarding the cfg cmd, i maybe deleted it as i tweaked my cfg. gonna check it. vsync disabling on mac seems maybe hard to do, cause u cannot open setting for graphic driver at mac. but ill google when i come home. thx guys =)

Share this post


Link to post
Share on other sites
  • 0

nothing worked :(

 

here a part of m cfg:

 

 

 
seta com_soundMegs „64“
seta com_crashed   "0"
seta com_maxfps     „125“
seta com_hunkMegs   „328“
seta com_zoneMegs   „64“
seta pmove_fixed "0"
seta r_ext_compressed_textures "1"
 
seta snaps „20"
seta rate „25000"
seta cl_wwwDownload   „0“
seta cl_allowDownload „0“
seta cl_packetdup „1“
seta cl_maxpackets “100“
seta cl_timeNudge „0“
 
seta r_primitives „2“
 
seta sv_maxRate "42000"
seta sv_dl_maxRate "42000"
seta sv_wwwFallbackURL ""
seta sv_wwwDlDisconnected      "0"
seta sv_wwwBaseURL ""
seta sv_wwwDownload "0"
seta sv_allowDownload „0“

Share this post


Link to post
Share on other sites
  • 0

mouse lag + 60fps is probably caused by vsync, as everyone said

 

there's some stuff around on how to disable "beam synchronization" on Mac (That's how it's called there apparently) but since I don't have a Mac I can't test it.

 

Your config looks fine

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

seta com_soundMegs „64“

 

seta com_maxfps     „125“

seta com_hunkMegs   „328“

seta com_zoneMegs   „64“

 

 

Does ET read those  characters properly?  I assume those are from where Schnee edited the cfg file.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

mouse lag + 60fps is probably caused by vsync, as everyone said

 

there's some stuff around on how to disable "beam synchronization" on Mac (That's how it's called there apparently) but since I don't have a Mac I can't test it.

 

Your config looks fine

 

 

 

Update: This no longer works in El Capitan as the switch to the Metal graphics API has broken Beam Off and Quartz Debug no longer has the option to disable Beam Sync. I'm not currently aware of any way to disable Beam Sync in El Capitan, but please let me know in the comments if you find one and I will update the guide.

 

yeah i tried beam sync. apparently it's not compatible with el captain anymore ffs :D

 

 Does ET read those  characters properly?  I assume those are from where Schnee edited the cfg file.

 

this doesn't have any impact :)

Share this post


Link to post
Share on other sites
  • 0

I had a similar problem before, don't know if this will work for you too but try turning thread optimization off in GPU settings.

 

Source: http://fearless-assassins.com/topic/45274-i-call-upon-the-lag-wizards/?do=findComment&comment=395443

 

 

not working on mac =) thank you!

Share this post


Link to post
Share on other sites
  • 0

Add this to your .cfg and see if it helps:

 

/seta r_finish 0

 

Very good for getting familiar with cvars http://antman.info/wolf/cvar/#.V_XmIfSU-70 (yeyeye old friend site :P)

 

 

trying this! antman, yeah ive downloaded some cfgs from perfor, raziel and co there to tweak my own :P

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Add this to your .cfg and see if it helps:

 

/seta r_finish 0

 

Very good for getting familiar with cvars http://antman.info/wolf/cvar/#.V_XmIfSU-70 (yeyeye old friend site :P)

 

 

seems to work, gonna read through. just my mac seems kinda f***ed up after last update. using lot of cpu at the start. :/

Share this post


Link to post
Share on other sites
  • 0

seems to work, gonna read through. just my mac seems kinda f***ed up after last update. using lot of cpu at the start. :/

upgraded to Sierra? Coz even if tiny, you were supposed to get a little increase in the perfs.

 

 

From what I have read and if I'm not wrong, you're not the only one to get such issues. Most gamers are kinda stuck since the latest upgrades. Someone made a patch-up job in C++ to turn off beamsync but even the tool (x-tool 8) allowing to add such code seems messed since its last release.

Edited by Ann!b@l

Share this post


Link to post
Share on other sites
  • 0

beamsync isnt working since osx 10.11 they removed beam and added something else. so i dl xtoll and stuff but u cannot remove vsync anymore. f***ing mac. and no not on sierra so far. due to my music software and hardware i always wait till next update so all gonna work smooth. im still on capitain.

Share this post


Link to post
Share on other sites
  • 0

beamsync isnt working since osx 10.11 they removed beam and added something else.

I'm aware :)

 

edit: found the discussion again about it. http://stackoverflow.com/a/39458304

Edited by Ann!b@l

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.