Jump to content
  • 0
=Plat00n=

unplayable ET need help

Question

Hi guys i not been playing much ET lately i have issues since i got a new GPU R9 380. I always remember when i used to have my old gpu everytime i update drivers et would go to f*** and i would have to go back to old driver.

 

So if there is any AMD users that knew the setting to use for amd catalyst control center for ET or if there any topics i have missed about this issue.

 

Thanks Plat00n

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Could you describe more specifically what issues you have with et?

If it's fps drops try different values on r_primitives 2 (values 0 1 2, default 0) do vid_restart after each value change.

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

its more to do with jaggered edging, screen tearing and keep getting black in windows and on players.

 

its most be 100% to do with ccc and this being a old game there most be a setting in ccc which is making the game unplayable.

 

my r_primitives has always been on 2 will try 0-1 now 

Share this post


Link to post
Share on other sites
  • 0

Have you tried uinstalling drivers in safe mode? Then you might want to use amd's auto driver detect? (solved my problem with display driver errors). You could also set lowest avaliable setting for et profile or use program settings in amd's drop down menus. No overheating there I'm assuming :)

Share this post


Link to post
Share on other sites
  • 0

Tried  r_primitives values no luck there 

 

Only time i have ever had issues with this game was when i tried to update new drivers it happened on my old gpu and now doing the same with my new gpu 

 

I tested all my games and they all working just ET playing up is there something that need to be turned off in ccc to play older games.

Share this post


Link to post
Share on other sites
  • 0

I remember when I used to have amd..

 

Try going into the Catalyst Control Center, set the "Wait for vertical refresh" to preformance or something like that.

Also try to set the OpenGL to enable.

 

It may fix it

 

Puni.

Share this post


Link to post
Share on other sites
  • 0

Dont use Crimson drivers they dont work with ET. 16.3.2 or similar is current and works on my AMD. Crimson is usually Beta and sucks :)

 

Vsync off should fix tearing.

 

r_ignorehwgamma 0 or 1 depending which you prefer and map..

 

You can also tell ET which opengl to use, cant remember exactly how but you extract a file from the AMD driver set you want and put in main et directory. If the above doesnt fix it let me know I will dig out the instructions for manual opengl version setup.

Edited by Barn!e
  • Like 2

Share this post


Link to post
Share on other sites
  • 0

Open up ET with Administrator rights and run it in compatibility mode.  Make sure the control catalyst isn't running as well.

 

Have you tried to do a fresh install of ET with no Custom CFG and the issue still occurring?

 

Also try running ET with your Firewall Turned off.

Edited by Mortemex

Share this post


Link to post
Share on other sites
  • 0

Catalyst Control Center is most likely the issue. Manually disable the following in CCC, if they apply to your system:

  • Threaded Optimization
  • Antialiasing (and all related options)
  • Shader Cache
  • Vertical Sync

Disabling Catalyst AI - Please read

 

Make sure the Raptr overlay is not active for ET. Even better, disable Raptr and AMD Gaming Evolved entirely.

 

Use /r_primitives 2

Try /r_swapinterval 0

Share this post


Link to post
Share on other sites
  • 0

GPU Mode - 

Drivers version - 

CC Version - 

 

Take game screenshot and tweet it to AMD every few days asking for the help with game name. You use the media presence and they will fix it up for next release. :)

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Can't you just roll back the driver to previous,or is this just for nvidia. :unsure:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×