Jump to content
  • 0
DFighter

Issue starting ET

Question

I have a new pc and I installed ET but it won't open
error: could not load openGL subsystem when I check the error I assume it's something with the vid card, but I don't know what to do exactly.
can anyone help me and explain in the simplest way possible what I have to do to get it running :P 

thanks in advance

Edited by DFighter

Share this post


Link to post
Share on other sites

23 answers to this question

Recommended Posts

  • 0

it's fixed by installing the original drivers or something atleast that is what my father said -_-

  • Like 3

Share this post


Link to post
Share on other sites
  • 0

no it's not that. already tried that hehe. but in the error logs as far I understand them it has something to do with my vid card

Edited by DFighter

Share this post


Link to post
Share on other sites
  • 0

is your install completely fresh? could be that some settings that you used on your old system are not compatable with your new pc (most likely resolution)

Share this post


Link to post
Share on other sites
  • 0

A reply from ol'smoke in a similar topic states: 

 

 

Try this and see what happens.

 

Remove all traces of the drivers for your video card.  Let windows use the basic driver.

Then fire it up and see what happens.  If nothing happens and the image is clear, then it

is probably the video card having problems doing what the driver wants it to do.

Only fix I ever found for this was to get a new video card.

 

One problem I had recently was an older video card that ran fine in Windows XP, but would not run much at all

in Windows 7.  Even though the maker had supplied Win7 hardware updates and a driver.  It just didn't like Win7.

 

One other thing that can cause this is an updated driver for your vidcard.  I fixed a similar problem last year for a guy.

After he updated his drivers, the card screwed up.  So I removed all the drivers from Windows for his card and then

installed an older driver.  It worked fine.

That might be a good start for diagnostics?

Share this post


Link to post
Share on other sites
  • 0

A reply from ol'smoke in a similar topic states: 

 

 
 

That might be a good start for diagnostics?

he aint broken hehe gta v works fine too it's probably a setting or a update on my vid card my father did it in the old days however he aint around -_-

the other things like removing traces etc I don't really understand and I run windows 8 or 9 ( the newest )

 

Share this post


Link to post
Share on other sites
  • 0

Update your Graphics card drivers,i think that your running windows basic drivers for your graphics card,cause i had this same problem.

Share this post


Link to post
Share on other sites
  • 0

Hi DFighter, long time not seen :)

 

would you be so kind and paste the full log here. 

Edited by stabak

Share this post


Link to post
Share on other sites
  • 0

U need to change the resolution, at least thats what i see is from error logs... try to set it in your cfg different r_mode

Share this post


Link to post
Share on other sites
  • 0

If what aniky says doesn't work, in link provided by dd there is a suggestion to use this: http://slimdrivers.nl.softonic.com/

That might actually work, since it's probably a driver issue.

Share this post


Link to post
Share on other sites
  • 0

I tried what madara posted but when I enter the text it says target is not correct and I also tried to add r_mode 4 in my cfg but cant exec it cause ET don't open -_-

Share this post


Link to post
Share on other sites
  • 0

Hi DFighter, long time not seen :)

 

would you be so kind and paste the full log here. 

Hi mate :) indeed some time ago

 

here is the full log

 

ET 2.60b win-x86 May  8 2006
----- FS_Startup -----
Current search path:
C:\Program Files (x86)\Wolfenstein - Enemy Territory\etmain\pak2.pk3 (22 files)
C:\Program Files (x86)\Wolfenstein - Enemy Territory\etmain\pak1.pk3 (10 files)
C:\Program Files (x86)\Wolfenstein - Enemy Territory\etmain\pak0.pk3 (3725 files)
C:\Program Files (x86)\Wolfenstein - Enemy Territory\etmain\mp_bin.pk3 (6 files)
C:\Program Files (x86)\Wolfenstein - Enemy Territory/etmain
 
----------------------
3763 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
...detecting CPU, found AMD w/ 3DNow!
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\Windows\system32\opengl32.dll' ): succeeded
...setting mode 4: 800 600 FS
...using desktop display depth of 32
...calling CDS: ok
...registered window class
...created window@0,0 (800x600)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 32, 24, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (4)
...setting mode 4: 800 600 FS
...using colorsbits of 16
...calling CDS: ok
...created window@0,0 (800x600)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
...assuming '3dfxvgl' is a standalone driver
...initializing QGL
...WARNING: missing Glide installation, assuming no 3Dfx available
...shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
GLW_StartOpenGL() - could not load OpenGL subsystem

Share this post


Link to post
Share on other sites
  • 0

Think if i remember correctly to set settings in launch icon.

 

Right click on the ET icon at ur desktop and click properties, at target bar add after location:

 

"C:\Program Files (x86)\Wolfenstein - Enemy Territory\ET.exe" +set r_mode 6

 

Double click the icon and ET should open in this resolution.

Share this post


Link to post
Share on other sites
  • 0

1. latest DirectX version installed
2. latest Graphics card driver
3. search and change/add in \\Enemy Territory\etmain\profiles\ETUI\etconfig.cfg
 

seta r_mode "-1"
seta r_customwidth "your width"
seta r_customheight "your height"

or

 

seta r_mode "0 to 11 based on resolution"

0 = 320x240 
1 = 400x300 
2 = 512x384 
3 = 640x480 
4 = 800x600 
5 = 960x720 
6 = 1024x768 
7 = 1152x864 
8 = 1280x1024 
9 = 1600x1200 
10 = 2048x1536 
11 = 856x480 (wide) 
 

if nothing will work:

try to rename (not delete, maybe you need to look about some old settings) your \\Enemy Territory\etmain\profiles\ETUI\etconfig.cfg and restart game.
new etconfig will be created and should work. (you have to switch all settings, since its running in lets say "safe mode")

Edited by stabak

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.