Jump to content
  • 0
yakuruy

Invalid pk.3 Files

Question

So I haven't been able to go on the S1 server because it always boots me for having invalid pk.3 files, and just now I got booted from hardcore as well, for the same reason. Does anyone know how I could fix this?

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

deleate  your silent folder connect to silent and let the files re download should fix it

Share this post


Link to post
Share on other sites
  • 0

Run the game as administrator (right click and press "run as administrator". Worked for me and still does when I get that error :P

Share this post


Link to post
Share on other sites
  • 0

if nothing above works, you can set your config to cl_allowdownload 1 (or something). Had a similar problem few years back where the way to fix it was to turn off the allowdownload and turn it back on again. But also be aware that the cl_allowdownload might give maleware (which was the case many years ago) don't think people doing that now, but you never know. Youc an also manually download the missing pk3 files.

 

Another thing if you get booted by the server for invalid pk3 files. Just exit the game/close it completely, start as Admin and connect to server, that should fix it,

Share this post


Link to post
Share on other sites
  • 0

1st: Can't run it as I'm using a mac

2nd:  Deleting silent folder didnt work as I'm connecting to servers without even needing to download anything despite deleting the folder.

3rd: I always run as admin

4th: Didnt work either :(

 

 

 

 

deleate  your silent folder connect to silent and let the files re download should fix it

 

 

Run the game as administrator (right click and press "run as administrator". Worked for me and still does when I get that error  :P

 

 

if nothing above works, you can set your config to cl_allowdownload 1 (or something). Had a similar problem few years back where the way to fix it was to turn off the allowdownload and turn it back on again. But also be aware that the cl_allowdownload might give maleware (which was the case many years ago) don't think people doing that now, but you never know. Youc an also manually download the missing pk3 files.

 

Another thing if you get booted by the server for invalid pk3 files. Just exit the game/close it completely, start as Admin and connect to server, that should fix it,

 

Share this post


Link to post
Share on other sites
  • 0

 

2nd:  Deleting silent folder didnt work as I'm connecting to servers without even needing to download anything despite deleting the folder.

 

 

You are able to connect and play on some FA Silent-mod servers?  

 

You need to take special precautions with your name, etkey and silent.dat if you are going to test this problem on non-FA servers.  

Share this post


Link to post
Share on other sites
  • 0

Hi, you should have opened by stating that you were a Mac user. Please provide your OS and client version as well as if you are using the ET Legacy client (with its version as well). In addition please provide a screen shot of the error or crash log.

 

Regards,

xenozbad

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×