Jump to content
  • 0
staticwarp

new place, lag spikes making et unplayable

Question

I just moved into a new apartment and discovered that et is now uplayable because of lag spikes. everything was working great at my old place with an AT&T dsl connection (computer connected wirelessly through the ATT modem/router), now i'm using a time warner cable modem and connecting through a cisco wireless router. i'm using windows 7.

 

screenshots are in this album:

http://s28.photobucket.com/user/szaszhareen/library/et%20lag%20ss

 

the connection works great for everything else. I can stream several videos at once, download large files without issue, stream video and music while my roommate is also streaming video and music, all with no lag or problems. the problems only start when i try to play et. I get severe lag spikes and packet loss every few seconds. once or twice it has stabilized enough to play for an hour or so, but i usually give up after 10-15 minutes of solid yellow/green/red spikes and complete connection loss.

 

the only thing that has changed is my internet connection. is there something i can try changing in the router settings? anything i should try changing in et? the very last thing i want to do is call my isp, since it's in my roommate's name that is going to be a hassle and all they ever tell you to do is reset everything, which i've already tried several times.

 

any ideas would be much appreciated, it's a total bummer not being able to play. :(

 

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

thanks for the suggestions - i'm quite happy to report that i replaced the existing wireless router with another i had in a box somewhere. the new router is working flawlessly with et so far (fingers crossed). :)

 

thank you again for the help!  :thanks

Share this post


Link to post
Share on other sites
  • 0

is there a lag problem in other fps games ?

 

 

have you changed anything recently to your folders for ET or changed config?

 

do you use cl_maxpackets 100 or rate 32000?
 

 

reset your wireless router?

 

did you try another server besides the one you usually play on

 

 

 

 

 

 

 

http://fearless-assassins.com/forum-11/announcement-9-how-to-recognize-your-lag/

Share this post


Link to post
Share on other sites
  • 0

et is the only game i own/play, so i can't check other games.

 

no recent changes to et or config.

 

i use cl_maxpackets 100.

 

i've reset the cable modem, wireless router, wireless adapter, my ip, and my computer. the lag spikes remain.

 

this problem persists on jay1 and jay2 servers, i will try some other random servers and see what happens. 

 

thanks for posting the recognize your lag thread, i'm taking a look at that now.

Edited by staticwarp

Share this post


Link to post
Share on other sites
  • 0
here are the results from winmtr using jay1.clan-fa.com:

 


|------------------------------------------------------------------------------------------|

|                                      WinMTR statistics                                   |

|                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |

|------------------------------------------------|------|------|------|------|------|------|

|                             192.168.1.1 -    0 |   41 |   41 |    1 |   31 |  252 |    6 |

|                          142.254.133.17 -    0 |   41 |   41 |   10 |   44 |  263 |   15 |

|         tge7-1.snaxtx4101h.texas.rr.com -    3 |   38 |   37 |    6 |   33 |  215 |   11 |

|     tge0-8-0-5.snaptx1901r.texas.rr.com -    0 |   41 |   41 |    8 |   45 |  278 |   17 |

|          agg22.snavtxuu02r.texas.rr.com -    0 |   41 |   41 |   12 |   50 |  271 |   19 |

|          agg23.hstqtxl301r.texas.rr.com -    3 |   38 |   37 |   17 |   55 |  317 |   17 |

|           ae-2-0.cr0.hou30.tbone.rr.com -    0 |   41 |   41 |   16 |   51 |  320 |   17 |

|           ae-0-0.cr0.dfw10.tbone.rr.com -    3 |   38 |   37 |   21 |   63 |  315 |   31 |

|              ae1.pr1.dfw10.tbone.rr.com -    0 |   41 |   41 |   22 |   73 |  301 |   28 |

|         xe-1-3-2.cr1.dfw1.us.nlayer.net -    0 |   41 |   41 |   19 |   69 |  309 |   32 |

|         xe-0-2-1.cr1.ord1.us.nlayer.net -    0 |   41 |   41 |   42 |   86 |  320 |   46 |

|          ae1-30g.ar1.ord1.us.nlayer.net -   34 |   18 |   12 |   49 |  145 |  317 |   50 |

|            tge8-1.ar2.ord1.us.scnet.net -    0 |   41 |   41 |   41 |   86 |  320 |   50 |

|                               8.9.4.227 -    3 |   38 |   37 |   39 |   74 |  247 |   41 |

|________________________________________________|______|______|______|______|______|______|

   WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

 

speedtest:

 

3329604812.png

 

 

i've run speedtests during non-peak times and get about 10 mbps dl speed, so my avg is probably somewhere between 4 and 10 mbps. i'm looking into port forwarding now, hopefully that will solve this issue.

Edited by staticwarp

Share this post


Link to post
Share on other sites
  • 0

Well for starters have you tried to play it without wifi as its new router? I guess you´ve already set new connection in win7? Also firewall disabled? And yeah ISP can be a problem as I´ve discovered that on peak hours I have +50 ping and lag. So winMTR could tell us a bit.

Share this post


Link to post
Share on other sites
  • 0

His problem is not ET config related.

Could be alot of things..

 

The first step to help us diagnosis your problem would be to run a winmtr report. Use the ET server IP as hostname and run it for 500 packets and post the result in txt format.

 

http://winmtr.net/

 

Could also run it for google.com for comparation purpose

 

Edit: typed too slow :P

From the look of your report I would say that your router is the problem.

Your ping from comp to router and from router to first iteration is way too high altough it doesn't explain 100% no connection

 

Edit2: just saw that you use wifi.

There might be too much interferances (.cellphone, other wireless)

Wall might be too concrete etc.. Did you try on cable?

 

You should do another on cable.

41 packets is not enough you should run it for at least 250 , 500 at best

Share this post


Link to post
Share on other sites
  • 0
 192.168.1.1 -    0 |   41 |   41 |    1 |   31 |  252 |    6 |

142.254.133.17 -    0 |   41 |   41 |   10 |   44 |  263 |   15 |

Share this post


Link to post
Share on other sites
  • 0

thanks guys, here is a longer winmtr report after disabling router firewalls and enabling port forwarding, this is still on wireless connection:

 

|------------------------------------------------------------------------------------------|
|                                      WinMTR statistics                                   |
|                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
|                             192.168.1.1 -    3 |  464 |  451 |    1 |   31 |  415 |    5 |
|                          142.254.133.17 -    3 |  463 |  450 |    7 |   47 |  336 |   34 |
|         tge7-1.snaxtx4101h.texas.rr.com -    3 |  463 |  450 |    7 |   46 |  340 |   33 |
|     tge0-8-0-5.snaptx1901r.texas.rr.com -    1 |  503 |  500 |    7 |   60 |  761 |   52 |
|          agg22.snavtxuu02r.texas.rr.com -    1 |  499 |  495 |   10 |   61 |  766 |  304 |
|          agg23.hstqtxl301r.texas.rr.com -    1 |  499 |  495 |   14 |   65 |  496 |  306 |
|           ae-2-0.cr0.hou30.tbone.rr.com -    1 |  507 |  505 |   13 |   72 |  834 |  285 |
|           ae-0-0.cr0.dfw10.tbone.rr.com -    1 |  503 |  500 |   17 |   73 |  785 |  175 |
|              ae1.pr1.dfw10.tbone.rr.com -    1 |  499 |  495 |   17 |   66 |  588 |  310 |
|         xe-1-3-2.cr1.dfw1.us.nlayer.net -    1 |  507 |  505 |   16 |   71 |  817 |   69 |
|         xe-0-2-1.cr1.ord1.us.nlayer.net -    2 |  487 |  480 |   40 |   83 |  565 |   72 |
|          ae1-30g.ar1.ord1.us.nlayer.net -    9 |  379 |  345 |   39 |   75 |  763 |   97 |
|            tge8-1.ar2.ord1.us.scnet.net -    2 |  495 |  490 |   39 |   85 |  735 |   72 |
|                               8.9.4.227 -    0 |  515 |  515 |   39 |   78 | 1077 |   89 |
|________________________________________________|______|______|______|______|______|______|
   WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

 

problem still persists.

 

i also made sure et is allowed in windows firewall. i followed the port forwarding guide here. as much as i don't feel like moving my computer i'll try this with a connection straight to the cable modem next. 

Share this post


Link to post
Share on other sites
  • 0

plugged pc straight into the cable modem, the lag problem vanishes.

 

the lame thing is that the cable modem is in the living room about 30 ft away. even if i get a 50ft lan cable i still have to go through the router since other people here have to use the internet too. i neglected to try a wired connection to the router while i had things set up out there.

 

at least we figured out that the problem is that i'm connected through the wireless router. now that we know that, is there anything else i can try to get rid of the lag when i'm connected through that router? or should i just focus on coming up with a wired solution? that would take some time, but if that's all i can do, then i'll do it. i'm getting et withdrawals here. XD

Share this post


Link to post
Share on other sites
  • 0

For starters you should enable firewall on the router. Also I noticed you have different router than in other place. So does your router have power strength settings for WIFI? If yes then dial em up. Do you play on laptop? Check power strength settings on PC\laptop also. Maybe there are better router firmware out there? Some router allow custom made linux based firmwares to be used. There are the option to change router out for for more powerful one(as I guess its the main issue, can be something else like wifi connection type used) or try wifi repeater\booster to boost your wifi signal in mid way (or how they are called as I´ve not used any of them myself).

Share this post


Link to post
Share on other sites
  • 0

Something in the walls(s) of the new apartment?

Share this post


Link to post
Share on other sites
  • 0

quick update - the new router definitely helped as i mentioned above, but i still get killer lag spikes sometimes. i am chocking this one up to shitty time warner cable internet. i've noticed lag problems with general internet browsing as well, and only during certain times of the day and week. guess i'll just have to deal with it for now. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×