Jump to content
  • 0
Sign in to follow this  
w0nder

Restriction: Service Abnormality

Question

A friend of mine is having issues connecting. He has never had an issue before, and now is getting PB error = Restriction: Service Abnormality upon connecting. I have looked around and found nothing. I was thinking it could be the antivirus so he shut it off... No go, that didnt work. I also do not see a similar post in the forums so any suggestions? Oh he is running XP.

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Close virus protection it shoold be gone :). often a update or a new one makes trouble like kasperski . use free agv :yahoo

Share this post


Link to post
Share on other sites
  • 0

Close virus protection it shoold be gone :). often a update or a new one makes trouble like kasperski . use free agv :yahoo

 

 

Tried that did not work. And it is AVG.

 

Also, >>evenbalance>>pbsetup>>run= nothing

Share this post


Link to post
Share on other sites
  • 0

Note #2: This is a restriction kick issued by Punkbuster when it doesn't pass on of the internal tests. We have received reports from users that several versions of Zonealarm may cause this behavior.

 

I would like a list of your running processes. To get them do this:

 

Start the game, minimize it, then follow these steps:

 

Start => Run.. => cmd

 

Then type:

 

tasklist /SVC > tasks.txt

 

That will create a text file with a dumb of your current processes into C:/Documents and Settings/[your user]/tasks.txt. Paste the contents in a new note.

 

From Here

Share this post


Link to post
Share on other sites
  • 0

From Here

 

I've had the same problem since I installed the latest Punkbuster update. I tried your "tasklist" but my Windows XP says that command doesn't exist...

 

Is there a way to tell my Defender Pro firewall that Punkbuster is OK to run?!?

Share this post


Link to post
Share on other sites
  • 0

yes you could alow punkbuster communication within your firewall

 

went into the firewall advanced settings and specifically look at settings for punkbuster (a andB) set incomming /outgoing to allowed

Should work

Share this post


Link to post
Share on other sites
  • 0

yes you could alow punkbuster communication within your firewall

 

went into the firewall advanced settings and specifically look at settings for punkbuster (a andB) set incomming /outgoing to allowed

Should work

 

I checked and found ET, Punkbuster a & b all set to "both". But if I turn off Punkbuster it runs fine.

Share this post


Link to post
Share on other sites
  • 0

I completely deleted and reinstalled ET. Even went into system32 folder and deleted PB. When I start it up I get a box from Defender Pro and click ALLOW for ET. Had to go into firewall manually and set allow PB also. Still has the same problem...

Share this post


Link to post
Share on other sites
  • 0

Finally got a real answer from the Punkbuster folks! I just had to turn off the "Compatibility Mode"...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×