Jump to content
  • 0
Kostaja

Trouble with ET sounds.

Question

Situation: All other sounds work fine, just ET is on "mute".

 

Yesterday evening I played and all was fine but today no sounds in ET. Winamp plays music, other games play sounds. I had to disconnect all my wiring from computer to change the CPU fan, but I don't see how this could affect anything. I did some tuning to my cfg, but today I have tried the unmodified version of that cfg + the ET's original cfg. No help.

 

ET sounds are on in ET itself and in sound mixer in my Windows 7.

 

Any ideas?

 

-Kostaja

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

no idea... I would say, first check all your s_ settings (type \s_ and press tab to see them all)

 

maybe s_volume 0 ? :D

Share this post


Link to post
Share on other sites
  • 0

s_volume is 0.9, so not that simple :)

:D

 

what about the other values? You can't hear anything at all?

Share this post


Link to post
Share on other sites
  • 0

I can't hear anything. No hit sounds, no effect sounds, no music in main menu. Also, in sound mixer in windows, i see that green bar flashing in other programs when sound is played, but nothing in ET's volume bar.

 

E: Other s_ values:

 

seta s_volume "0.9"
seta s_musicvolume "0"
seta s_separation "0.5"
seta s_doppler "1"
seta s_khz "22"
seta s_mixahead "0.2"
seta s_mixPreStep "0.05"
seta s_defaultsound "0"
seta s_wavonly "0"
seta s_bits "32"
seta s_channels "2"

Share this post


Link to post
Share on other sites
  • 0

Check also s_initsound "1"

 

What does /s_info say in console?

 

e:

And you could also fire up a map with devmap e.g. /devmap oasis

Then type in console /s_show "1"

 

If sounds are played by the game they will be shown in console, then your problem is most likely some mixer setting in Windows.

 

Oh you have set s_bits "32" :P Try s_bits "16"

Edited by S3ti

Share this post


Link to post
Share on other sites
  • 0

I´d go with sound drivers reinstallation, also did you put all wires back in correct position? Some wrong position could affect how sound card is working. Check sound settings and the box: disable front panel jack detection: tick it on and off...

Share this post


Link to post
Share on other sites
  • 0

Problem is solved.

 

After I had disconnected all my wiring and put them back, there is a popup menu which lets you choose what type of audiosystem you have connected to the computer. If I choose speakers, ET wont play any sounds. When I reconnected the wiring and chose headphones, all sounds came back. Could this be because I have only 2 small speakers, and ET somehow gets confused because my soundcard supports multichannel audio? Don't know, but I'm sure glad things worked out :)

 

E: Forgot the most important: Thanks everybody for all your help :)

Share this post


Link to post
Share on other sites
  • 0

But did you choose speakers and played with the: "disable front panel jack detection" setting, it has helped me always?

Share this post


Link to post
Share on other sites
  • 0

No I didn't do that. Just went straight to gaming :) I will try that just to see if it works for me too, that way I will atleast learn how to adjust that if necessary in the future.

 

Does that front jack detection mute all the sounds coming from the back output or how does it work? I have a vague idea how it might work in some situations, but for me this was a very specific problem with only ET being the problematic program.

 

ps. Vacation started and writing this while destroying my hangover with some booze, so bear with me if I'm not so clear in my thoughts :yahoo

Share this post


Link to post
Share on other sites
  • 0

"disable front panel jack detection" I have no idea what it does or how it works, if you have sound output in front panel besides on backpanel from mobo then I guess it should disable front panel detection. But so far I´ve only noticed it mutes some sounds and sometimes it makes things working, in random order:P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.