Jump to content
  • 0
Skull

I have to use pb_cl_enable to get my xp back

Question

EDIT: For some unknown reason, after using the pb enable command the past two days it's starting up fine and recognizing my xp.

Edited by Skull

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Just for future cases, you should do the following commands in the exact order: /pb_cl_enable, /pb_system 1, /pb_writecfg, /reconnect

 

That should make sure you don't have to rewrite /pb_cl_enable every time your xp is reset.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

pb_system 1 is unrelated

 

PB_System [0/1]
PB can conflict with other software on some systems due to vigorous memory scanning; Changing this setting may reduce or eliminate conflicts if you have problems on your system; this setting can only be changed before connecting to a server

 

it has nothing to do with guids or xp. I've always used 0, and that is the default value as well. Never had a problem with guids (unless I disable pb myself to play etpro, and I forget to enable it again).

 

To make sure pb is enabled, just add this line to your autoexec.cfg

seta cl_punkbuster "1"

 

or run et with +set cl_punkbuster 1 from the command line (or your server browser, etc.)

 

p.s.

don't rely on 'unknown reasons', because your problems will be back :P

Edited by SunLight

Share this post


Link to post
Share on other sites
  • 0

cl_punkbuster is read only, best to do pb_cl_enable

you need pb to get xp in jaymod

Share this post


Link to post
Share on other sites
  • 0

cl_punkbuster is read only, best to do pb_cl_enable

you need pb to get xp in jaymod

it's not read only if you change it when et starts

Share this post


Link to post
Share on other sites
  • 0

You don't need to have pb enabled to get your xp saved, the cvar cl_guid is just empty if pb is disabled.

 

Just look up your guid with pb enabled, type "cl_guid" in console and do "condump" to save the console to a textfile.

Then copy your guid into your config like this: seta cl_guid "yourguidwhatever"

 

Should save your XP then and you don't need to enable pb unless the server needs it :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×