Jump to content
jiidu

No sound in Enemy Territory Ubuntu/Debian/Mint - Enemy Territory

Recommended Posts

1. Put an empty file to /home/ folder

2. name it for example "ets"

3. Open terminal and write "chmod +x ets"

4. Open "ets"-file you made with Gedit for example.

5. Write in file:

 

wget -q -O - http://nullkey.kapsi.fi/et-sdl-sound/et-sdl-sound.gz | gzip -d > et-sdl-sound && chmod a+x et-sdl-sound;

./et-sdl-sound;

 

and save the file.

 

6. You can now play Enemy Territory with sounds.

Just write ./ets in your terminal.

 

THIS BUG DOESN'T APPEAR WITH EVERY LINUX MINT USER!

But if I helped someone, I'm glad I could help you smile.png

Edited by Fearless Staff

Share this post


Link to post
Share on other sites

Why would you download, extract and set the permissions of the script every time you start ET? You only have to do that once and should be able to run ./et-sdl-sound each time you want to start ET.

Share this post


Link to post
Share on other sites

Also a note to others this might only work for you depending on your hardware configuration. If you are still having problems. Ubuntu has a full guide on installing/setting up ET which covers various other methods to deal with your sound and other issues you might want to try including this one.

Share this post


Link to post
Share on other sites

Why would you download, extract and set the permissions of the script every time you start ET? You only have to do that once and should be able to run ./et-sdl-sound each time you want to start ET.

 

Actually when i remove the dowloading / permission part (wget -q -O - http://nullkey.kapsi...et-sdl-sound.gz | gzip -d > et-sdl-sound && chmod a+x et-sdl-sound;)

the script doesn't work anymore (or works only once). This is only scipt that works for ME. So if someone is having same problems than me he sould tryt this1 :)

 

And the file is only 18,8 kb so It doesn't take long to run this script, only 1 sec or less and works like dream;)

Share this post


Link to post
Share on other sites

I'm glad I found this tutorial, I upgraded to ubuntu 12.04 and was unable to get ET working again with sound. I googled and tried a dozen other elaborate fixes but none worked except this one.

 

Two notes: I used a different file name than "ets". I used "etsound" in my home folder instead. That way I will remember what it is when I look in my home folder later.

 

Also, the URL gets shortened when you post on this forum, so if anyone is copying and pasting the text as it appears, you will need to fill in the rest of the website address that gets reduced. The full address is

 

nullkey.kapsi.fi/et-sdl-sound/et-sdl-sound.gz

 

Again, thanks for posting this fix for no sound. It works good for me in ubuntu-12.04.

Share this post


Link to post
Share on other sites

×