Jump to content
  • 0

Question

hi..

 

i have a question:

 

i play on server beginners xp save

 

i lost my xp over 20000 points and again over 10000 ... other members help me and i find the problem : cdkey have invalid letters and signs..

i repair it. and check my guid ... all ok!

1 weak later i lost again my xp "DAILY" > i start again-again-again(daily) by 150 XP ... this is not funny :( - medic lv0 :(

ur rules is - XP SAVE and over 50000XP = LV1 admin... and over 40000XP for join FA .... hmmm no chance for me...

 

can anyone help me with this problem or give me plz a statement why server by half of players start by 150XP again!??!

 

thx

 

PS: i play 1-2x /weak on ur hardcoreserver - and my XP is save...

 

respectfull

Codename_EGO

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

There was a jaymod bug that lead to xp and level reset for almost everyone on beginners server this week. However, when you start with 150 xp every time you connect and you are saying that you have a valid etkey in your etmain folder, I guess you need to enabled PB.

 

Not working?

If /cl_guid reveals that you have an *Unknown* guid, join a server then type the following:

/pb_cl_enable; pb_system 1; pb_writecfg; reconnect;

This should solve all issues.

Source

 

 

Alternatively go to main menu in ET, press Play Online and click on enable punkbuster there.

Share this post


Link to post
Share on other sites
  • 0

So to be clear:

1. You have ETKEY file in your etmain folder in C:\Programs...\ET. (In case of Vista check tutorial for alternative placement)

2. You have enabled PB in BOTH- ETMAIN and Jaymod? (If you start ET and open console right away after couple of secs in blue there should be written someting like: pnkbstr.A loaded pnkbstrB and punkbuster started succesfully)

3. You don´t use any alternative methods to run ET?(xfire, etc)

Also what does cl_guid produce? A string of 0000 or a string of different characters?

Share this post


Link to post
Share on other sites
  • 0

Try making etkey read-only in right-click properties

Share this post


Link to post
Share on other sites
  • 0

I think the bug only happens when people log on, and not during established game-play.

 

I suspect that the jaymod xp-handler is calling the end-session routine instead of the begin-session routine, or something. That is, the empty temp-hold-xp-var is being written to the server user-xp-database instead of copying from the database to the temp-xp-hold-var.

 

I visualize that normally, the user-xp+admin info is copied to a temp-var, xp is added to the temp-var during play, and this temp-var is occasionally stored in the xp-database and ALWAYS stored at end-of-session.

 

Has anybody ever noticed that not all of their new XP is saved when a server crashes? That might tend to validate the above scenario.

 

The variables mentioned are all of my own invention and not necessarily to be found in any Jaymod code.

 

ADDED: It could also be the End-Session routine! It could be getting called a second time, after the zero-temp-xp-var routine has 0d the var that ES then writes into the DB. Or it could be that a new Ozone Hole has opened up over the database server and too many cosmic rays hitting the device and flipping bits, willy-nilly.

Edited by RedBaird

Share this post


Link to post
Share on other sites
  • 0

by me its all ok.. guid , etkey , pb a and b updatetet and allowed on firewall... redbaird have right... i see that all admin lv1 or highter have he XP and the rest lost xp again/daily :(

plz check ur server.cfg ..i think its a little bug with xp save for all lv 0 users ... :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×