Jump to content
Sign in to follow this  
vke

Not connecting?

Recommended Posts

Hey guys. So i got BF2 working great, been pwning bots for the past day while the huuuuuugggggeeeee patch was downloading. and now that i want to be killed by people, I get a connection error. I don't have a firewall, I don't have antivirus, I have the BF2 ports opened, still nothing. Internet works fine, ET works fine, new wolf works okayish... but im hooked on BF2 and i don't care if the others work :P Please help me!

 

:thanks:thanks:thanks

Share this post


Link to post
Share on other sites

its oldish. I got it about 4 months ago and it wouldnt run on my crappy pc. You can get it on Amazon for less than $10.

 

I really really really need some help. Im literally going crazy. I need to fly the heli XD Ive tried everything i know to fix this problem. Update pb, run as admin, open ports, remove firewall, new ethernet cables, reset my routers, deleted a bunch of stuff for more hd space, reinstalled BF2, redownloaded all patches. Its drivin me nuts! It worked perfectly before the 1.5 patch, should i just go back to 1.41?

Edited by Valkyrie

Share this post


Link to post
Share on other sites

u have SS that error?

try connecting by xfire

Share this post


Link to post
Share on other sites

Where do the ss get saved? I can't seem to find them :hmm

 

this is exactly what it says though

 

You have failed to connect. Please check your network connection(s) and try again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.