Jump to content
  • 0
*ConQuerY*

ET Memory and Connection

Question

Hello there,

I need some help with my ET memory like topic says,

I want to change:

RAM for ET(hunkmegs) and RAM for load a map,but i can't even i put every other amount or RAM,

Other config stays as they were except these one above,

So Is possible to solve this somehow?

Cheers,

 

ConQ

 

EDIT:In my etconfig i put a RAM which i want but in console it shows me wrong,

Example,

i have put 160 in my cfg,same as in autoexec and console says:

com_hunkmegs is ''128''

Latched: ''160''

Share this post


Link to post
Share on other sites

21 answers to this question

Recommended Posts

  • 0

ok,

1. you can't change zonemegs after the game has started, you can change it only from the command line because the game needs that memory before it reads your autoexec.

2. you say you use 128 (your whole memory?) have you checked total hunk in use, or just total hunk? Have you checked megabytes in zone blocks or total zone?

 

/meminfo

 

 

268435456 bytes (256.00 MB) total hunk

25165824 bytes ( 24.00 MB) total zone

 

0 bytes ( 0.00 MB) low mark

5780736 bytes ( 5.51 MB) low permanent

8926520 bytes ( 8.51 MB) low tempHighwater

 

0 bytes ( 0.00 MB) high mark

3595680 bytes ( 3.43 MB) high permanent

3677920 bytes ( 3.51 MB) high temp

5783916 bytes ( 5.52 MB) high tempHighwater

 

9376416 bytes ( 8.94 MB) total hunk in use

5334020 bytes ( 5.09 MB) unused highwater

 

1043028 bytes ( 0.99 MB) in 753 zone blocks

64 bytes ( 0.00 MB) in dynamic botlib

85832 bytes ( 0.08 MB) in dynamic renderer

957132 bytes ( 0.91 MB) in dynamic other

93728 bytes ( 0.09 MB) in small Zone memory

in this case i didn't load any map, you can see I have around 9megs of hunk and 1 of zone in use.

 

 

 

for the sound:

\s_list

 

 

 

8[16bit] : ***DEFAULT***[resident ]

0[16bit] : sound/misc/menu2.wav[resident ]

Total resident: 8

135002100 bytes (128.75MB) free sound buffer memory, 2060 bytes (0.00MB) total used

2060 bytes (0.00MB) sound buffer memory have been allocated since the last SND_setup

 

 

 

2. you did a /vid_restart and hunkmegs is still 128? Dumb question, what is the exact name of the cvar you tried to change, com_hunkmegs?

edit: Ah ok, I see you said latched, just ignore this was actually dumb... Strange that you can't change com_hunkmegs even after a vid_restart, are you trying this just after loading et, or while you are playing on a server? Because some servers force some settings on you.

 

Ow my total hunk in use is:37.77 and 4.49 in 5489 zoneblocks,i have tried to change it in game yes,also copied cfgs to every of my mods hunk is still 128 and zone 32 even in cfgs write its 160,32 :/

I did vid_restart before game and in the game still nothing,

Probably my crappy computer don't allow such a higher memory for ET,

Guess it better leave it on 128,24 :/

Share this post


Link to post
Share on other sites
  • 0

Did you have tryed what i have said ?

 

Before i had posted it i did try it and it was working fine for me. And if i use the settings like you (in game) i have the same problems. I cant save it from there, and after every Restart the game is starting with the same settings.

 

And no, if you use this link it dont connect you to any server. In first way its just a Link on your Desktop.

It first will you connect to a server if you put the command +connect Serverip:port in it.

 

 

 

also maybe anaswer the questions (OS / PC settings like how much ram did you have ?) if you want help.

Share this post


Link to post
Share on other sites
  • 0

Did you have tryed what i have said ?

 

Before i had posted it i did try it and it was working fine for me. And if i use the settings like you (in game) i have the same problems. I cant save it from there, and after every Restart the game is starting with the same settings.

 

And no, if you use this link it dont connect you to any server. In first way its just a Link on your Desktop.

It first will you connect to a server if you put the command +connect Serverip:port in it.

 

 

 

also maybe anaswer the questions (OS / PC settings like how much ram did you have ?) if you want help.

 

-windows xp professional

-768 MB of RAM

-AMD 1.6GHz

-nVidia FX5200(128Mb)

 

Can you explain me more this ''mail to'' ?Is that something like compress or ''send to''?

If it is then i do another ET shortcut on my desktop right?

I have done that,but when i do + set com_hunkmegs xxx; +set com_soundmegs xxx; + set com_zonemegs xxx; like u said it shows me

''The name '+' in Target Box is not valid.Make sure the path and the file name is correct''

Share this post


Link to post
Share on other sites
  • 0

If it is then i do another ET shortcut on my desktop right?

I have done that,but when i do + set com_hunkmegs xxx; +set com_soundmegs xxx; + set com_zonemegs xxx; like u said it shows me

''The name '+' in Target Box is not valid.Make sure the path and the file name is correct''

 

It is just a shortcut (sry i used the word Link :? ).

 

Did you delete the game path ? you have just to put it too (like:"C:\Games\ET\ET.exe" +set com_hunkmegs 512; +set com_zonemegs 128)

 

so i guess i ts all explained on this :P, had nothing to do with compressing or Mailing, i just used the wrong word :rolleyes:

 

Since you just have 786 MB Ram you have to try how much, or better if you can increase these settings.

Share this post


Link to post
Share on other sites
  • 0

U did,this works :)

Its ok,i sometimes use other words for the same thing hehe,

So this problem solved,thanks a lot Stabak ;)

 

ConQ

Share this post


Link to post
Share on other sites
  • 0

problem solved, to get it all in one:

 

make a shortcut from your ET.exe and go to the shortcut edit mode.

look for the linked game path and insert the parameters behind this.

so the link should looked like

 

C:\Games\ET\ET.exe" +set com_hunkmegs 512; +set com_zonemegs 128

 

you can also insert the server IP from the Server you wanted to connect, maybe if you want to connect to a Server immediately after Gamestart.

 

"C:\Games\ET\ET.exe" + connect 178.63.72.170:27960

 

(I have shortcuts on my desk for each FA server :) )

 

 

 

\closed

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×