Jump to content
-=HipKat=-

Windows Dolby Digital on Realtek Audio Drivers

Recommended Posts

SO, for some reason, DD is not enabled on Realtek Drivers. There is a work around using an older, patched driver. I wonder if anyone has tried this on here, or thinks it's legit and does Windows Restore roll back Driver changes? THe problem is that mopst of these links are several years old. I suppose I can just uninstall and reinstall the newest drivers if there are issues. These are some links that go over the process

 

https://www.gizdev.com/get-dolby-atmos-sound-system-dts-audio-with-realtek-mod-driver/

 

https://www.techpowerup.com/forums/threads/unlocked-realtek-hd-audio-drivers-for-windows-10-dolby-digital-live-dts-interactive.228612/

 

https://superuser.com/questions/1095458/windows-10-and-realtek-optical-output-5-1-dts-how-to-enable

Share this post


Link to post
Share on other sites
Posted (edited)

Biggest problem with Windows 10 is the lack of legacy support (there is none tbh) and unsigned drivers. I have the problem myself with my zboard fang, Yes its easy to turn unsigned driver restrictions off but just so you know you will have to do it every time there is a large windows update (1803, 1806, 1903, etc), they all reset windows back to default so your drivers will be over written by "signed" ones after each major windows 10 update and unsigned driver restrictions will be turned back on. So not only will you have to turn unsigned driver restrictions off you will also have to replace the drivers via device manager each time they are replaced, not a great hardship but fooking annoying.

 

As you say you can simply allow windows to replace the drivers via update driver if they don't work. Only thing i dont liek about unsigned drivers off the web is you don't really know what your getting unless you create them yourself, but if you could do that its doubtful you'd have posted this thread so lets leave that till another time. lol 

 

I cant see why it wouldn't work, i might even have a dabble with it myself later if i get time.

Edited by Snuffs99

Share this post


Link to post
Share on other sites

Disabling driver enforcement on anything after Vista is a bit of a pain. The third party drivers are likely legit, made by people like you who want Dolby features that were included on their mobos to work.
For the record though, all drivers that are for Vista will work on Vista+ and that includes Windows 10.

First thing I'd check though is the mobo manufacturer's official site-- often times they continue support with beta software at the very least. if that doesn't work, I'd check Dolby's software site. Last I checked, they offer software downloads.

To answer your question about Windows Restore- yes it does rollback driver changes.

  • Like 1

Share this post


Link to post
Share on other sites

Just a question mate, do you play mainly with headphones or speakers? And if with speakers, who much? 2.1? 5.1?

Share this post


Link to post
Share on other sites

Install VLC and use that it has direct sound for surround sound with DD you just have to enable it through preferences

 

That is what I use to watch any movies I have installed or copied from older DVD's

 

What your looking into is driver related and if it supports Dolby Digital or not it should if you have the correct codec's installed for the system

 

All you have to do is make sure if the application supports one of the two codec types AC3 or A52 for Dolby Digital

 

Realtek gives support for DD with these codecs just make sure to install the proper system file

 

https://www.realtek.com/en/component/zoo/category/pc-audio-codecs-high-definition-audio-codecs-software

  • Like 1

Share this post


Link to post
Share on other sites
On 8/23/2019 at 2:39 AM, N3farious said:

Just a question mate, do you play mainly with headphones or speakers? And if with speakers, who much? 2.1? 5.1?

5.1 Speakers, which is why I want to unlock Dolby Digital. It's absolutely stupid that a 1 yr old, top of the line MB doesn't just have DD 5.1 sound.

Share this post


Link to post
Share on other sites
21 hours ago, DoubleDragon said:

Install VLC and use that it has direct sound for surround sound with DD you just have to enable it through preferences

 

That is what I use to watch any movies I have installed or copied from older DVD's

 

What your looking into is driver related and if it supports Dolby Digital or not it should if you have the correct codec's installed for the system

 

All you have to do is make sure if the application supports one of the two codec types AC3 or A52 for Dolby Digital

 

Realtek gives support for DD with these codecs just make sure to install the proper system file

 

https://www.realtek.com/en/component/zoo/category/pc-audio-codecs-high-definition-audio-codecs-software

Well, this would be for gaming, mostly, which makes VLC not useful for what I want. The other thing, being a  noob, is I's that I don't know which I need, AC3 or A52 (And of course I never thought to just check Realtek's site lol)

Share this post


Link to post
Share on other sites
35 minutes ago, -=HipKat=- said:

5.1 Speakers, which is why I want to unlock Dolby Digital. It's absolutely stupid that a 1 yr old, top of the line MB doesn't just have DD 5.1 sound.

What motherboard do you have? Model?

Share this post


Link to post
Share on other sites
11 minutes ago, N3farious said:

What motherboard do you have? Model?

ASUS Rog Strix MAximus-X Hero

Share this post


Link to post
Share on other sites

AC3 and A52 are same thing one was made in the 90's the other is just recently 

 

to be honest vlc audio codec carries over to the system once it is installed tho not enabled it can be triggered in windows media player

 

if you right click on windows media players tool bar when it's open you will find tools

 

in tools you will find a options tab

 

when it opens click on devices and select the device you are working on

 

from there you can select S/PDIF

 

when you have both the codec and the device set up it use to allow playback through this method it should still be the same

 

Windows Media Player is the direct sound driver by default built in everything goes through it even if it's not open

 

spdif.thumb.png.e492af34038ccfcf91afff93ea210e95.png

  • Like 1

Share this post


Link to post
Share on other sites
On 8/24/2019 at 7:03 AM, DoubleDragon said:

AC3 and A52 are same thing one was made in the 90's the other is just recently 

 

to be honest vlc audio codec carries over to the system once it is installed tho not enabled it can be triggered in windows media player

 

if you right click on windows media players tool bar when it's open you will find tools

 

in tools you will find a options tab

 

when it opens click on devices and select the device you are working on

 

from there you can select S/PDIF

 

when you have both the codec and the device set up it use to allow playback through this method it should still be the same

 

Windows Media Player is the direct sound driver by default built in everything goes through it even if it's not open

 

spdif.thumb.png.e492af34038ccfcf91afff93ea210e95.png

I'll try that out,. I did d/l thje Driver version 2.82 and it does show DD and DTS in the Windows Sound Settings, but still plays in stereo. I'll try the VLC Player and if that doesn't work, I still have those links to the patcher in my OP

Share this post


Link to post
Share on other sites

If your still not getting your settings right might need to try this 

 

 

Share this post


Link to post
Share on other sites
5 hours ago, DoubleDragon said:

If your still not getting your settings right might need to try this 

 

 

I'll check this out after I have my coffee. I did try the patcher, still only getting PCM/Stereo out of the S/PDIF Output

Share this post


Link to post
Share on other sites

Well I give up. I was able to set my sound to Dolby 5.1 (That video was useless - it's almost 2 yrs old, for one thing). My Surround Sound showed it was getting Dolby Digital input but the rear speakers had no sound at all.

Maybe time to look at sound cards?

Share this post


Link to post
Share on other sites

hmm I'm using dd/dts speakers(Z-5500) for years and I never had this problem.

56.jpg.13d13d62c9994bec49d6ad5336c7cfaf.jpg

That's how it looks on my PC(Polish language xd)

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


About Us

We are glad you decided to stop by our website and servers. At Fearless Assassins Gaming Community (=F|A=) we strive to bring you the best gaming experience possible. With helpful admins, custom maps and good server regulars your gaming experience should be grand! We love to have fun by playing online games especially W:ET, Call of Duty Series, Counter Strike: Series, Minecraft, Insurgency, DOI, Sandstorm, RUST, Team Fortress Series & Battlefield Series and if you like to do same then join us! Here, you can make worldwide friends while enjoying the game. Anyone from any race and country speaking any language can join our Discord and gaming servers. We have clan members from US, Canada, Europe, Sri Lanka, India, Japan, Australia, Brazil, UK, Austria, Poland, Finland, Turkey, Russia, Finland, Germany and many other countries. It doesn't matter how much good you are in the game or how much good English you speak. We believe in making new friends from all over the world. If you want to have fun and want to make new friends join up our gaming servers and our VoIP servers any day and at any time. At =F|A= we are all players first and then admins when someone needs our help or support on server.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.