Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

OpenGL Error

- - - - -

  • Please log in to reply
13 replies to this topic

#1
dedz

dedz

    L3: Novice

  • Regular User
  • 143 posts
8
A step in the right direction
  • Server:Hardcore ET
Normally, I have this stuff down with no errors. But apparently there's something in my CFG that i can't seem to find. Help?

Posted Image



//Razz
//Name: POET.et
//Razz - doubleslashteam - #poet.et @ qnet
 
 
 
unbindall
bind \ name ^7Roach
bind ] name "^0dst^2/^h/^7Razz"
 
//Controls ---
 
bind W "+forward"
bind S "+back"
bind A "+moveleft"
bind D "+moveright"
bind Q "+leanleft"
bind E "+leanright"
bind SPACE "+moveup"
bind C "+movedown"
bind X "+prone"
bind CAPSLOCK "+speed"
bind SHIFT "+sprint"
bind F "+activate"
seta sensitivity 1.5
bind T "messagemode"
bind Y "messagemode2"
bind V "mp_quickmessage"
bind TAB "+scores"
bind L "openlimbomenu"
bind G "+mapexpand"
bind . "zoomin"
bind , "zoomout"
bind ALT "stats"
bind CTRL "+topshots"
bind MOUSE1 "+attack"
bind MOUSE2 "weapalt"
bind R "+reload"
bind B "+zoom"
bind F1 "vote yes"
bind F2 "vote no"
bind F11 "screenshot"
bind F12 "record"
bind 1 "weaponbank 1"
bind 2 "weaponbank 2; com_maxfps 71"			
bind 3 "weaponbank 3; com_maxfps 125"
bind 4 "weaponbank 4"
bind 5 "weaponbank 5"
bind 6 "weaponbank 6"
bind 7 "weaponbank 7"
bind KP_INS "selectbudyall"
bind i "vsay MinesCleared"
bind mouse5 "+zoom ; +attack; -attack; -zoom"
bind F5 "setspawnpt 0;say_team spawning^zZERO"			
bind F6 "setspawnpt 1;say_team spawning^oONE"			
bind F7 "setspawnpt 2;say_team spawning^tTWO"			
bind F8 "setspawnpt 3;say_team spawning^tTHREE"			
bind F9 "setspawnpt 4;say_team spawning^gFOUR"

seta cg_fov 110
bind mouse4 "com_maxfps 50; wait 2; cl_yawspeed 1700; +left; wait 10; -left; com_maxfps 125"
 
//-----------------------------------------------
 
 
//Game options ---
 
seta name ^0dst^2/^h/^7Razz
seta cl_run 1
seta cg_autoReload 0
seta cg_autoswitch 0
seta cl_wwwDownload 1
seta cl_allowDownload 1
seta cg_complaintPopup 1
seta cg_useScreenshotJPEG 1
seta cg_announcer "1"
seta com_hunkmegs "132"
seta com_zonemegs "24"
seta com_soundmegs "132"

//-----------------------------------------------
 
//View Options ---
 
seta cg_drawGun 1
seta cg_drawCompass 1
seta cg_drawReinforcementTime 1
seta cg_drawFPS "2"
seta cg_crosshairHealth 0
seta cg_drawCrosshairNames 0
seta cg_wolfparticles 0
seta cg_coronas 0
seta cg_blinktime "0"
seta cg_blooddamageblend "0"
seta cg_bloodflash "0"
seta cg_bloodtime "0"
seta cg_bobpitch "0"
seta cg_bobroll "0"
seta cg_bobup "0"
seta cg_bobyaw "0"
seta cg_brasstime "0"
seta cg_centertime "1"
seta cg_drawsmallpopupicons "1"
seta cg_drawcrosshair "5"
 
//-----------------------------------------------
 
//Graphics ---
 
seta r_mode 8
seta r_customaspect 0
seta r_customheight "1024"
seta r_customwidth "1600"
seta r_fullscreen 1
seta r_detailtextures 0
seta r_ext_compressed_textures 0
seta r_dynamiclight 0
seta r_picmip "1"
seta r_ignorehwgamma "1"
seta r_gamma 3
seta r_mapoverbrightbits 3
seta r_overbrightbits 0
seta r_intensity 1
seta r_drawfoliage "0"
seta r_wolffog 0
seta r_displayrefresh 75
seta r_texturemode "GL_LINEAR_MIPMAP_NEAREST"
r_fastsky 1
 
//-----------------------------------------------
 
//Server Options ---
 
set sv_minping 
set sv_maxping 
seta match_latejoin 1
seta match_readypercent 
set sv_maxclients 
set sv_minclients 
seta match_mutespecs 1
seta team_maxplayers 
seta team_noControls 1
seta g_warmup 
seta timelimit 
set g_complaintlimit 
set sv_pure 1
seta refereePassword none
set sv_Password none
set vote_limit 3
set vote_percent 50
set g_allowVote 1
set vote_allow_comp 0
set vote_allow_kick 1
set vote_allow_map 1
set vote_allow_matchreset 0
set vote_allow_mutespecs 0
set vote_allow_nextmap1
set vote_allow_pub 0
set vote_allow_referee 0
set vote_allow_shuffleteams 1
set vote_allow_swapteams 1
set vote_allow_friendlyfire 1
set vote_allow_timelimit 0
set vote_allow_warmupdamage 1
set vote_allow_antilag 0
set vote_allow_balancedteams 0
set server_motd0  ^NEnemy Territory ^7MOTD 
 
//-----------------------------------------------
 
//Misc ---
 
seta maxfps 125
seta cl_autoupdate 0
seta cg_popupLimboMenu 1
seta cg_crosshairSize 35
seta rate 25000
seta r_texturebits 32
seta r_colorbits 32
seta r_stereo 1
seta r_drawSun 0
seta cg_shadows 0
seta r_highQualityVideo 1
seta s_khz 44
seta ui_menuFiles "ui/menus.txt"
seta cg_drawBuddies 1
seta cg_crosshairColor cyan
seta cg_drawIcons 1
seta cg_lagometer 1
bind F3 "ready"
bind F4 "notready"
seta cl_doubletapdelay 0

//-----------------------------------------------
 
//ETPro

seta b_althud "1"
seta b_althudflags "7"
seta b_antilag "1"
seta b_antiwarp "1"
seta b_backupcvars "0"
seta b_chatalpha "0"
seta b_chatflags "1"
seta b_chatsounds "0"
seta b_descriptivetextscale "0.6"
seta b_drawclock "0"
seta b_drawpromotions "0"
seta b_drawranks "1"
seta b_drawrewards "0"
seta b_drawspectatorteamflags "0"
seta b_fireteamalpha "1"
seta b_fireteamlatchedclass "1"
seta b_goatsound "0"
seta b_hitsounds "1"
seta b_locationmode "3"
seta b_locationmaxchars "20"
seta b_locationjustify "-1"
seta b_logbanners "1"
seta b_muzzleflash "0"
seta b_numpopups "6"
seta b_popupfadetime "0"
seta b_popupstaytime "80000"
seta b_popuptime "1"
seta b_shovesounds "1"
seta b_simpleitems "1"
seta b_tracers "0"
seta b_votetextscale "0.6"
seta b_weapaltreloads "0"



Click here to login or here to register to remove this ad, it's free!

#2
JoeDirt

JoeDirt

    L11: Assassin

  • Administrators
  • 5,290 posts
3,169
Is a bearer of wisdom
  • Admin:21
  • Server:None
Reinstall your video driver.

#3
dedz

dedz

    L3: Novice

  • Regular User
  • 143 posts
8
A step in the right direction
  • Server:Hardcore ET
I don't think that would help, it happens on another player's computer too.

(edit - it only crashes when i vid_restart after i exec and only for this config but no other)

Edited by Razz, 30 July 2010 - 09:04 AM.


#4
Papito*

Papito*

    The Love Maker

  • ET Member
  • 4,988 posts
1,467
Name known to all
  • Admin:15
  • Server:Hardcore ET
  • Alias:Mex!ckano
  • T-M:ET: 3-2
Contributor
As said Joe, that Error happen when you video driver is not the correct one.
Download Everest for more details about your drivers.

#5
Saizou

Saizou

    L7: Teacher

  • Leader
  • 1,445 posts
107
On the road to fame
  • Admin:20
  • Server:Jay1
  • Alias:Saizou, Boris
Contributor
So far from personal experience it's either the drivers or you are trying to start the game with wrong resolution settings, ie trying to start up a game with 1400x1050 fullscreen mode while your monitor has 1280x1024 as maximum resolution. So double check what resolution are you using in that .cfg.
EDIT: by that r_mode 8 line that would mean 1280x1024 resolution, I think that shouldn't cause problems.

#6
dedz

dedz

    L3: Novice

  • Regular User
  • 143 posts
8
A step in the right direction
  • Server:Hardcore ET

So far from personal experience it's either the drivers or you are trying to start the game with wrong resolution settings, ie trying to start up a game with 1400x1050 fullscreen mode while your monitor has 1280x1024 as maximum resolution. So double check what resolution are you using in that .cfg.
EDIT: by that r_mode 8 line that would mean 1280x1024 resolution, I think that shouldn't cause problems.


Yeah i did think about the resolution, but i still got kicked. the resolution works fine for me on any other config, but not this one

#7
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,967
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor
If your stock install works then it's your config issue.

If your stock W:ET install doesn't work then it's your directX and video driver issue.

Also make different configs for each mod. Never ever mix etpro config with jaymod or etpub. Will cause issues if you exceed cvar limit or 16Kb (i think it's 15 or 16) size or so.

Why you need "set server_motd0 ^NEnemy Territory ^7MOTD" in your config? Never change etconfig.cfg. Always make autoexec.cfg and do changes in it and execute that one and use "set" and not "seta"

#8
dedz

dedz

    L3: Novice

  • Regular User
  • 143 posts
8
A step in the right direction
  • Server:Hardcore ET

Why you need "set server_motd0 ^NEnemy Territory ^7MOTD" in your config? Never change etconfig.cfg. Always make autoexec.cfg and do changes in it and execute that one and use "set" and not "seta"


I was too lazy to start from scratch, and i used this config maker thing that had those cvars in it already. I added in the graphic and HUD settings myself.

And I do have different configs for different mods, one for ETPro and one for ETPub. I didn't change the etconfig.cfg, I never touched it.

#9
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,967
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor
You have many server side cvars in your config. Example:

seta ui_menuFiles "ui/menus.txt"
sv_xxx cvars

Also cvars under '//Server Options ---' are useless. Remove them. :)

#10
dedz

dedz

    L3: Novice

  • Regular User
  • 143 posts
8
A step in the right direction
  • Server:Hardcore ET

You have many server side cvars in your config. Example:

seta ui_menuFiles "ui/menus.txt"
sv_xxx cvars

Also cvars under '//Server Options ---' are useless. Remove them. :)


I'll try it.

What i did just now is i took out all the configs i dont use or even need in my etmain folder including the autoexec.cfg, then i copied the config i have pasted here and made a new .cfg file. Now when i try to load ET it just automatically crashes right away with the OpenGL error.

also, i editted the

seta r_mode 8
seta r_customaspect 0
seta r_customheight "1024"
seta r_customwidth "1600"

to

seta r_mode -1
seta r_customaspect 1
seta r_customheight "1024"
seta r_customwidth "1280"

Edited by Razz, 30 July 2010 - 03:48 PM.


#11
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,967
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor
I would say go to etmain folder and delete every folder inside it. Then delete each mod folder you have.

Now start ET and it will ask you to make new profile and it will re load stock config :)

#12
dedz

dedz

    L3: Novice

  • Regular User
  • 143 posts
8
A step in the right direction
  • Server:Hardcore ET
haha its so much more organized now, thanks. and the configs are reset and whatnot. now all i need to do is find out what it is in that config exactly thats causing it to crash.

would the com_hunkmegs/zonemegs/soundmegs have any effect on it?

#13
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,967
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor
Any r_xxxx graphics related can be the cause of issue. Also you should never tell game what refresh rate to use, since it depends on what your monitor can handle.

r_displayrefresh 75

Remove above cvar from your config.

#14
dedz

dedz

    L3: Novice

  • Regular User
  • 143 posts
8
A step in the right direction
  • Server:Hardcore ET
Well, it's not the graphic settings. I just copied the r_ cvars only and saved them as a config and tested it on the hardcore server. Loaded fine with no crash or anything.

Edit- It's all fixed. All i had to do was fix in my config where it says "seta maxfps 125" to "seta com_maxfps 125" lol. i need to invent an ET config spellchecker. thanks for the help dare

Edited by Razz, 30 July 2010 - 05:21 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users