Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

Connection Interrupted - label constantly shown on screen

- - - - - enemy territory et network connection interrupted

  • Please log in to reply
9 replies to this topic

#1
boki

boki

    L3: Novice

  • ET Member
  • 236 posts
189
On a distinguished road
  • Admin:14
  • Server:Jay1
  • Alias:=F|A= boki >>>
  • Steam ID:boki_grozni
  • T-M:4-0
Contributor

Hi ET people, I have a strange issue. White letters, big on my screen - Connection Interrupted - are constantly there, flickering often very fast. There is no reason for that, and it happen even when I have 20 snaps and the lagometer is perfectly thin green and blue. But I came to the root cause - it is happening only when I set com_maxfps value greater than 125 (which my CPU can handle perfectly fine). So I think it is a matter of tine tuning between several parameters. I will eventually solve this, but to save some time, I wonder if anyone knows how to deal with it. An explanation of the root cause would be also nice.




Click here to login or here to register to remove this ad, it's free!

#2
RedBaird

RedBaird

    What does this thing do? I will push it and see...

  • Leader
  • 6,628 posts
5,261
Glorious beacon of light
  • EvolveHQ:FA_Redbaird
  • Admin:20
  • Server:Jay1
  • Alias:=F|A=RedBaird
  • T-M:ET: 13-4

Donator

Got a short demo of it?  Don't bother as the replay will not show the "connection interrupted" because ET is not then connected to the Internet and will show no connection troubles.  :)

 

 

ADDED:

 

I Googled wolfenstein flickering connection interrupted and found an interesting 13-year old thread on Splash Damage.

 

When I increased my max fps to 333, I began having the symptoms that you describe.  I also had that at 300, but not at 250.  The problem also disappeared when I looked at certain textures.  :)  I was in the second Axis spawn on GoldRush.


Edited by RedBaird, 07 October 2016 - 04:36 PM.


#3
boki

boki

    L3: Novice

  • ET Member
  • 236 posts
189
On a distinguished road
  • Admin:14
  • Server:Jay1
  • Alias:=F|A= boki >>>
  • Steam ID:boki_grozni
  • T-M:4-0
Contributor

I found this, some guy Rain wrote it on http://forums.warche...on-Interrupted:
 


"Connection interrupted" technically means that the client is more than 64 (CMD_BACKUP) commands (i.e. usercmd_ts) behind the server, so the onset of high-framerate weirdness depends on your latency to the server. Since the engine generates a client command internally for every frame rendered (even though it doesn't actually send one every frame.)

For example, if you have 2000ms latency on the dot and you're getting over 32fps, you'll end up over 64 commands behind and the client will display "connection interrupted." Likewise, if you have a 150ms ping (plus 50ms for the worst case inter-snapshot delay = 200ms), the game will stop working properly when you exceed 320fps. When you're on a network with lots of jitter (e.g. the intarweb), it's quite easy for things to bounce around enough that you'll see "connection interrupted" flicker quite a bit at really high framerates even if your ping isn't all that high.


#4
RedBaird

RedBaird

    What does this thing do? I will push it and see...

  • Leader
  • 6,628 posts
5,261
Glorious beacon of light
  • EvolveHQ:FA_Redbaird
  • Admin:20
  • Server:Jay1
  • Alias:=F|A=RedBaird
  • T-M:ET: 13-4

Donator

I found this, some guy Rain wrote it on http://forums.warche...on-Interrupted:
 

 

That is the same one that I found.  That is why I gave you my search terms.  :)



#5
Chuckun

Chuckun

    The Chuckunator

  • Co-Leader
  • 5,946 posts
1,682
Name known to all
  • Admin:19
  • Server:Hardcore ET
  • Alias:=F|A=TeaAndScones
Contributor

I'll give this a go too.  Strangely, since updating from 4mbps broadband (100-180ms) to 74mbps fibre optic (20-30ms), I have really bad lag with connection interrupted when I try play ET now :(



#6
Vetter2003

Vetter2003

    L3: Novice

  • ET Member
  • 250 posts
247
Will become famous
  • Admin:12
  • Server:Jay1
  • Alias:Vetter
  • T-M:1-0

Donator

Had the same issue Boki, Since I got my new system I was playing around with FPS to see what it could handle. I could run 333 FPS steady but connection interrupted was constantly flickering on my screen. I lowered down to 200 FPS and no more connection interrupted. 

 

Now when I'm spec'ing someone on certain players I'll get the connection interrupted flickering, so not sure how that all works but yeah same deal good  ping, no lag, just think its pushing more information than my connection can handle.

 

VETTER



#7
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,123 posts
3,269
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor

"some guy Rain" is one of etpro coders and also worked at ET 2.60b, or is some other Rain with the same nick.

 

"There is no reason for that" = "I don't know why" :P

 

That being said, you also play with a high ping, if you read that description from Rain, it's also another reason. Why do you need more than 125 fps? Over a certain fps value the advantage is almost nonexistent



#8
Vetter2003

Vetter2003

    L3: Novice

  • ET Member
  • 250 posts
247
Will become famous
  • Admin:12
  • Server:Jay1
  • Alias:Vetter
  • T-M:1-0

Donator

Why do you need more than 125 fps? Over a certain fps value the advantage is almost nonexistent

 

 

Valid point and I agree, but I was just testing out my new computer and was puzzled by the connection interrupted when set to high FPS



#9
LenovoNoteBook

LenovoNoteBook

    L3: Novice

  • ET Trial
  • 127 posts
44
Getting Better
  • Admin:11
  • Server:Jay3
  • Alias:Lenovo.NoteBook

I found this, some guy Rain wrote it on http://forums.warche...on-Interrupted:
 

 

I had the same problem but for different reasons, has happened to me that whenever I finished a map on beginners 2 xps forever server, I cleared it in 5000 and the RATE flashed connection interrupt, I found out by accident, typing the command / players just rewrote RATE 34000 msg connection interrupt is canceled and everything returned to normal, I solved by deleting both etconfig.cfg from etmain and even jaymod, the second plea is that when a server is saturated with players, there is too much spam some clients have trouble maybe because they have a lower quality connection than others, and then when you meet lags of them and the connection interrupt msg, I have noticed that if you turn up the RATE exchange of information between the client and the server is + fast, as if the server is affolato and many players have the ping is stable and higher should raise the RATE, then I noticed watching your settings you use the "timenudge to -50, I tried to do anchio, decreased me almost half the table, but the lagometer continues to have big yellow triangles, that increase as you fight, until you get into connection interrupt and kill you, so I tried to reset it to 0 , it came back okay on lagometer and he gave no + connection interrupts.



#10
DoubleDragon

DoubleDragon

    L3: Novice

  • Regular User
  • 102 posts
65
Getting Better
  • Server:Jay1
  • Alias:^uDouble^yDragon

Most of the time it's how much your PC can handle in theory you can figure out how much by using a program to bench mark your pc or video card the best I think to figure out what your FPS actually is would be to use this 4D Benchmark Render from Guru3d it works on Windows 10 it registers windows 10 as Windows 8 but basically that's what windows 10 is http://www.guru3d.co...5-download.html

 

I wouldn't actually download graphics drivers from here you will find applications that are useful tho. The connection Interrupted is just a way of saying your PC is out performing the server sending and receiving of Packets based on your hardware and that you exceed the threshold of the graphics card's FPS range but exceeding the maxfps range you can support.







Also tagged with one or more of these keywords: enemy territory, et, network, connection interrupted

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users