Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

Jay1 laggy

- - - - -

  • Please log in to reply
37 replies to this topic

#31
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,970
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor

I really don't see any issue from u lagometer screenshots. Each one has 125 FPS + green bar (some jitters I see) and nice 17+ snaps. 




Click here to login or here to register to remove this ad, it's free!

#32
Haruhi Suzumiya

Haruhi Suzumiya

    L3: Novice

  • Regular User
  • 280 posts
217
Will become famous
  • Server:None
  • Alias:Haruhi Suzumiya
  • Steam ID:http://steamcommunity.com/id/HaruhiiSuzumiyaa
I have the same problem but it also happens on silent and HC. Once about 2/3 of the slots are filled I get spikes that make it not worth playing.

@dare - check out yellow spikes in the frame graph. If he's like me then he'll have no packet loss and steady FPS while getting massive spikes that'll drop 50+ frames. The only thing to show this is the yellow extrapolation spikes.

#33
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,970
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor

I have the same problem but it also happens on silent and HC. Once about 2/3 of the slots are filled I get spikes that make it not worth playing.

@dare - check out yellow spikes in the frame graph. If he's like me then he'll have no packet loss and steady FPS while getting massive spikes that'll drop 50+ frames. The only thing to show this is the yellow extrapolation spikes.

 

The yellow spikes happens because of rate limit from server to client side and it's because of packet fragmentation. Sample - 

client send   33 : s=201740 ack=64196
client recv 1308 : s=64197 fragment=0,1300
client send   34 : s=201741 ack=64196
client send   34 : s=201742 ack=64196
client send   34 : s=201743 ack=64196
client send   34 : s=201744 ack=64196
client send   34 : s=201745 ack=64196
client send   35 : s=201746 ack=64196
client recv  725 : s=64197 fragment=1300,717
client send   36 : s=201747 ack=64197

Code - 

// rate command

   // if the client is on the same subnet as the server and we aren't running an
   // internet public server, assume they don't need a rate choke
   if ( Sys_IsLANAddress( cl->netchan.remoteAddress ) && com_dedicated->integer != 2 && sv_lanForceRate->integer == 1 ) {
      cl->rate = 99999;   // lans should not rate limit
   } else {
      val = Info_ValueForKey( cl->userinfo, "rate" );
      if ( strlen( val ) ) {
         i = atoi( val );
         cl->rate = i;
         if ( cl->rate < 1000 ) {
            cl->rate = 1000;
         } else if ( cl->rate > 90000 ) {
            cl->rate = 90000;
         }
      } else {
         cl->rate = 5000;
      }
   }

Their is nothing wrong technically with small yellow spikes when you are playing with 50 players. You are going to get it on any server. 

 

For jaymod best is to enable autorate and let it do the work. Anything above 45K-50K i don't find useful much. For the hack of testing I can increase the rate limit on server all the way to 90K.  In fact, increased it and let me know if you guys notice any difference. I wouldn't expect much since server is already optimized. 



#34
Haruhi Suzumiya

Haruhi Suzumiya

    L3: Novice

  • Regular User
  • 280 posts
217
Will become famous
  • Server:None
  • Alias:Haruhi Suzumiya
  • Steam ID:http://steamcommunity.com/id/HaruhiiSuzumiyaa
Is there a fix for this? I disconnect from jaymod well before the problems start because everyone knows when 40+ jaymoddders get together, well, that's how black holes are formed.

I'm curious to why it would happen on silent/HC. Somewhere around 10v10 and up I get the same problem while others seem to be fine even when the servers full. They'll even be running the he same connection settings and fps.

Their is nothing wrong technically with small yellow spikes when you are playing with 50 players. You are going to get it on any server. 
 
For jaymod best is to enable autorate and let it do the work. Anything above 45K-50K i don't find useful much. For the hack of testing I can increase the rate limit on server all the way to 90K.  In fact, increased it and let me know if you guys notice any difference. I wouldn't expect much since server is already optimized.


They're not little by any means. Many will last a full second and make the game unplayable. Latency will also rise as the problem starts in regards to bullet reg and delayed hit sounds.

#35
motafied

motafied

    L5: Journeyman

  • Regular User
  • 722 posts
450
Has a brilliant future
  • Xbox Live:DAVEBAWZ
  • EvolveHQ:equaLz
  • Admin:10
  • Server:Silent #1
  • Alias:equaLz

Donator

I don't know when you raised the /rate. but I noticed a little difference tonight, maybe it also depends on the map. I notice there is huge lag on Capuzzo, especially on the first part of the map... But anyway, thanks for looking into it DD, huge respect from my side for all the time you putted into this great community. ;)

 

I hope others will found a way to get a more stable gameplay. It's also hard since there are people playing with high and low pings from all over the world...



#36
-=HipKat=-

-=HipKat=-

    L6: Expert

  • Platinum VIP
  • 875 posts
616
Has a brilliant future
  • Xbox Live:HipKat2000
  • EvolveHQ:HipKat
  • Admin:7
  • Server:Jay1
  • Alias:Saint Anger
  • Steam ID:HipKat200030$

If  so many people notice that over 40 players cause FPS/lag problems, maybe time to limit the slots to 40 players??

 

And maybe that will push more people to Jay 2, and other servers



#37
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,970
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor

Is there a fix for this? I disconnect from jaymod well before the problems start because everyone knows when 40+ jaymoddders get together, well, that's how black holes are formed.

I'm curious to why it would happen on silent/HC. Somewhere around 10v10 and up I get the same problem while others seem to be fine even when the servers full. They'll even be running the he same connection settings and fps.


They're not little by any means. Many will last a full second and make the game unplayable. Latency will also rise as the problem starts in regards to bullet reg and delayed hit sounds.

 

If you get huge yellow spikes lasting for long time then it might be hard drive issue at client side. You can easily re-create it if you turn on some HD IO intensive task. Doesn't mean you have it but just posting it so in case if someone is suffering from that. 

 

silEnT and Jaymod both code are different. Jaymod handles 50 players easily and while silEnT from 0.9.0 should be able to achieve it. Both uses autorate functionality. 

 

Also note - If someone is spamming lots of ammo or medic packs and if u are around that or you are around more players i.e. more information u get and u get more fragmented packets and yellow spikes. 

 

Now I understand their are 3 types yellow spikes - 

 

1. One because of fragmentation i.e. u get packets not in line 

2. Another because of missing packets i.e. u client starts extrapolating. 

3. Client resource issue

 

If u hit case 1 - then their is nothing really anyone can do. 

If you hit case 2 and 3 - then we can try to look into it why its happening.

 

Can you post u hardware specs? 



#38
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,970
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor

If  so many people notice that over 40 players cause FPS/lag problems, maybe time to limit the slots to 40 players??

 

And maybe that will push more people to Jay 2, and other servers

 

It's not all the people. Jay1 is almost full all the time. Over the years, only few issues popped up. On internet if you want to achieve super straight green and blue line in lagometer then you should play in local. You would notice same issues with 40 slots. 

 

Also for you, you have the FPS issues while replaying demo as well. When you play demo i.e. it's played from local and it shows true FPS that your system is capable of since no network part is involved. 

 

I would say give etlegacy a shot. 


I don't know when you raised the /rate. but I noticed a little difference tonight, maybe it also depends on the map. I notice there is huge lag on Capuzzo, especially on the first part of the map... But anyway, thanks for looking into it DD, huge respect from my side for all the time you putted into this great community. ;)

 

I hope others will found a way to get a more stable gameplay. It's also hard since there are people playing with high and low pings from all over the world...

 

Eh no. Their are tons of others who do same :P This community is my baby so I try to do best for it ;) But thank you for the kind words!

 

For testing do this - 

 

\rate 85000

 

See how it works for you. 

 

Then do \rate 45000 and see how it works. 

 

Once done make sure you have cg_autorate 1  set. I might be off with cvar but double check. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users