Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

installing ET on ubuntu 9.10 libgtk1.2 help!!

- - - - -

  • Please log in to reply
10 replies to this topic

#1
nekla

nekla

    Newbie

  • User
  • 3 posts
0
Unknown at this point
Hello
i have 32bit pc i think and
i tried to install ET on my ubuntu and tried:
sudo apt-get install libgtk1.2
and it says it no longer available to download

Package libgtk1.2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package libgtk1.2 has no installation candidate


please help!!

Edited by nekla, 07 January 2010 - 01:35 PM.



Click here to login or here to register to remove this ad, it's free!

#2
Desu

Desu

    L7: Teacher

  • Regular User
  • 1,383 posts
27
A step in the right direction
  • Admin:3
taken from Roar forums.
credit goes to range_

I think I can help you.

Terminal: Applications > Accessories > Terminal

Enter this commands one by one:

2.55: wget http://ftp.games.sky...ux-2.55.x86.run
2.60: wget http://ftp.games.sky...ux-2.60.x86.run

You will need libgtk1.2: sudo apt-get install libgtk1.2

Add permissions: chmod +x et-linux-2.55.x86.run

Install:./et-linux-2.55.x86.run(adminstrator password needed)

Oh wait, 9.10 users are reporting difficulties in installing libgtk1.2, follow this thing to install properly.

This will open the file sources.list obviously.

Code:
sudo nano /etc/apt/sources.list



Scroll to the bottom and add the following:

Code:
deb http://archive.ubuntu.com/ubuntu/ jaunty universe
deb-src http://archive.ubuntu.com/ubuntu/ jaunty universe



Now save and close the file, return to terminal and enter the following.

Code:
sudo aptitude update && aptitude install libgtk1.2(Pw needed I think)



Edit the sources.list again.

Code:
sudo nano /etc/apt/sources.list



Remove it.

Code:
deb http://archive.ubuntu.com/ubuntu/ jaunty universe
deb-src http://archive.ubuntu.com/ubuntu/ jaunty universe



EDIT: About the language, sudo aptitude install language-pack-en does it.

Yes, couldn't be simplier. cheers

#3
hobbit

hobbit

    L10: Grand Master

  • Regular User
  • 3,246 posts
286
Will become famous
  • Admin:0
  • Server:None
  • Steam ID:pvtforrestgump
Contributor
Hackers :/

Lol Jk jk :D

#4
!Chuck4Abuck

!Chuck4Abuck

    loser

  • Busted Cheater
  • 1,905 posts
55
Getting Better
  • Admin:0
  • Server:None
oh lord private haxtors lol

#5
Desu

Desu

    L7: Teacher

  • Regular User
  • 1,383 posts
27
A step in the right direction
  • Admin:3
thats what i would say before, but after experimenting with ubuntu for 3 days and got ET working, and getting other programs such as Wine....
its not that hard! lol

#6
nekla

nekla

    Newbie

  • User
  • 3 posts
0
Unknown at this point
thank you very much :)
I just woke up so il post if i get it working or not

#7
w0nder

w0nder

    L3: Novice

  • User
  • 317 posts
7
A step in the right direction
  • Admin:0
Contributor

thank you very much :)
I just woke up so il post if i get it working or not


You will not have sound.. There are a few methods to use to enable the sound.



I am actually having the biggest noob issue, and I cannot figure out what I am missing. So I want to put my cfg in my etmain folder, but as we all know you cannot drag and drop because you do not have permission. So I try to move from the terminal and it tells me there is no such directory of /user/local/games/enemy-territory/etmain

What the hell am I missing? sudo mv w0nder.cfg ./dir/dir/dir/dir

#8
w0nder

w0nder

    L3: Novice

  • User
  • 317 posts
7
A step in the right direction
  • Admin:0
Contributor

You will not have sound.. There are a few methods to use to enable the sound.



I am actually having the biggest noob issue, and I cannot figure out what I am missing. So I want to put my cfg in my etmain folder, but as we all know you cannot drag and drop because you do not have permission. So I try to move from the terminal and it tells me there is no such directory of /user/local/games/enemy-territory/etmain

What the hell am I missing? sudo mv w0nder.cfg ./dir/dir/dir/dir



Never mind I was being retarded..

Got it figured out

chmod a+rwx /usr/local/games/enemy-territory/etmain

#9
Desu

Desu

    L7: Teacher

  • Regular User
  • 1,383 posts
27
A step in the right direction
  • Admin:3
got i need sound.
urine told me to do sudo apt-get soundfix.dll in terminal.
would that fix?

#10
w0nder

w0nder

    L3: Novice

  • User
  • 317 posts
7
A step in the right direction
  • Admin:0
Contributor
hmm I dont think so... Try this

sudo -i
echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
echo "et.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss
et

Each line is a new command obviously.. Now when et starts if this works you can make a script to start ET with this otherwise you have to do it everytime you restart PC

EXAMPLE:

gksudo echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
gksudo echo "et.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss
killall esd
et
esd
exit 0

I forgot to mention that the ESD sound server has been killed in the script. Some people do not need to do this but I did

Save as txt then use commands to give it executable permissions and to put it in your usr.local/games yada yada

Then just start from script, I am sorry if this makes no sense I am not that great at explaining things

Almost forgot..you need to give permissions or you wont download maps. at least I did

sudo chown -R user:group ~/.etwolf/

(your user and group are probably the same unless you changed groups)

#11
GerbilZ

GerbilZ

    Newbie

  • User
  • 1 posts
0
Unknown at this point

Never mind I was being retarded..

Got it figured out

chmod a+rwx /usr/local/games/enemy-territory/etmain


Ubuntu 9.04

[email protected]:~$ chmod a+rwx /usr/local/games/enemy-territory/etmain
chmod: changing permissions of `/usr/local/games/enemy-territory/etmain': Operation not permitted
[email protected]:~$


would seem that doesn't work for everyone.... :(

I was so hopeful too.. :P
-----------------------------------------------
ah. I may have had a retarded moment as well

first: sudo -i
log in as root :)

Edited by GerbilZ, 26 January 2010 - 12:18 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users