Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

Texture issue linux

- - - - - linux intel hd

Best Answer SunLight, 03 March 2013 - 05:59 AM

I play ET on 64 bit Linux too, and I use et-sdl-sound too, but I have no problems with corrupted textures.

It's either an ET config problem or your drivers.

 

What's your r_colorbits and r_texturebits value? 32?

 

try if setting r_ext_multitexture to 0 (it's 1 by default) helps

/seta r_ext_multitexture "0" unsafe

 

you can try r_ext_compressed_textures 0 too, you have to experiment, I have absolutely no idea about how to fix it :P

Go to the full post »


  • Please log in to reply
8 replies to this topic

#1
Hypnos_

Hypnos_

    L1: Learner

  • User
  • 11 posts
5
A step in the right direction
  • Server:NQ1
  • Alias:HYPNO$

Hi,

 

I have a Zenbook Prime UX31A (Intel HD graphics 4000) with Ubuntu 12.10 64 bits and I would like to play ET on it. It works great except for the textures (see attached screenshot).

I don't know what is the problem : GPU drivers or 64 bits architecture or something else ?

 

The main menu look great though, it's bugged only since I connect to a server (whatever the resolution is).

 

Any idea?

 

 

Thank you in advance ;)

Attached Thumbnails

  • shot0000.jpg



Click here to login or here to register to remove this ad, it's free!

#2
PiNoY

PiNoY

    Your Number One Super Noob Bone Breaking Samurai

  • Leader
  • 3,710 posts
1,592
Name known to all
  • Admin:20
  • Server:Jay3
  • Alias:father
  • Steam ID:verpinoy
  • T-M:ET: 8-6
Contributor

try renaming your user's.etwolf folder to a different one and start ET again to see if that helps. if you are launching ET from root, then rename root's .etwolf folder and see.



#3
Hypnos_

Hypnos_

    L1: Learner

  • User
  • 11 posts
5
A step in the right direction
  • Server:NQ1
  • Alias:HYPNO$

Thank you for your answers.

 

I don't run ET from root, and if I rename ~/.etwolf folder, I'm not able to run ET.

Also, I didn't mention that I use et-sdl-sound script in order to have the sound.

 

EDIT: I attach some screenshots of Goldrush, you can see what kind of issue I have

Attached Thumbnails

  • 2012-07-21-163313-goldrush-ga.jpg
  • 2013-03-02-185945-goldrush-ga.jpg
  • 2013-03-02-190003-goldrush-ga.jpg
  • 2013-03-02-190007-goldrush-ga.jpg

Edited by Hypnos_, 02 March 2013 - 10:02 AM.


#4
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,090 posts
3,225
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor

Did you try using a standard config? Maybe you should tweak some r_ settings one at a time, and see. I don't think et-sdl-sound can be the source of your problems.

 

I think I saw a similar bug around in the past but I forgot where, so I can't help you much. I never had the same issue myself.



#5
Hypnos_

Hypnos_

    L1: Learner

  • User
  • 11 posts
5
A step in the right direction
  • Server:NQ1
  • Alias:HYPNO$

Thank you for your answer.

 

I tried /cvar_restart but it didn't fix the problem.

 

I'm gonna reinstall and see what happens if I don't put my files in etmain/.

 

EDIT: After the reinstall, the problem persists :/


Edited by Hypnos_, 03 March 2013 - 04:01 AM.


#6
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,090 posts
3,225
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor
✓  Best Answer

I play ET on 64 bit Linux too, and I use et-sdl-sound too, but I have no problems with corrupted textures.

It's either an ET config problem or your drivers.

 

What's your r_colorbits and r_texturebits value? 32?

 

try if setting r_ext_multitexture to 0 (it's 1 by default) helps

/seta r_ext_multitexture "0" unsafe

 

you can try r_ext_compressed_textures 0 too, you have to experiment, I have absolutely no idea about how to fix it :P



#7
Hypnos_

Hypnos_

    L1: Learner

  • User
  • 11 posts
5
A step in the right direction
  • Server:NQ1
  • Alias:HYPNO$

I play ET on 64 bit Linux too, and I use et-sdl-sound too, but I have no problems with corrupted textures.

It's either an ET config problem or your drivers.

 

What's your r_colorbits and r_texturebits value? 32?

 

try if setting r_ext_multitexture to 0 (it's 1 by default) helps

/seta r_ext_multitexture "0" unsafe

 

you can try r_ext_compressed_textures 0 too, you have to experiment, I have absolutely no idea about how to fix it :P

 

You're my hero, I set both to 0 and I vid_restarted and the textures looks perfect!

 

Thank you SunLight  :kiss



#8
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,090 posts
3,225
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor

You're my hero, I set both to 0 and I vid_restarted and the textures looks perfect!

 

Thank you SunLight  :kiss

cool, I'm glad it helped :P

 

now try to set only one to 1, and see if the problem is caused by both or only 1 of them, this way you can keep at least 1 at its default value



#9
PiNoY

PiNoY

    Your Number One Super Noob Bone Breaking Samurai

  • Leader
  • 3,710 posts
1,592
Name known to all
  • Admin:20
  • Server:Jay3
  • Alias:father
  • Steam ID:verpinoy
  • T-M:ET: 8-6
Contributor

Am sure this will solve my pink stairs too






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users