Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

et lags in ubuntu

* * * * * 1 votes lag

  • Please log in to reply
30 replies to this topic

#16
rajaah thunder

rajaah thunder

    L4: Apprentice

  • Inactive Member
  • 446 posts
77
On the road to fame
  • Admin:12
  • Server:Silent #1
  • Alias:=F|A=Rajaah Thunder
  • T-M:ET: 1-0
then i think there's no other way other than quitting et atleast till i get a new pc

@co-leaders , may be u can set my admin level back to 0 ... i will once again come nd follow the steps to become a member :( no other way it seems


Click here to login or here to register to remove this ad, it's free!

#17
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,093 posts
3,231
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor
did a little test on fedora+gnome2+compiz (my other linux partition)

$ glxinfo | grep renderer
OpenGL renderer string: ATI Radeon HD 5670

$ glxinfo | grep direct
direct rendering: Yes
GL_AMD_multi_draw_indirect, GL_AMD_name_gen_delete,
GL_ARB_draw_indirect, GL_ARB_draw_instanced,
GL_EXT_copy_buffer, GL_EXT_copy_texture, GL_EXT_direct_state_access,

$ glxgears
11907 frames in 5.0 seconds = 2381.395 FPS
11946 frames in 5.0 seconds = 2389.084 FPS
12391 frames in 5.0 seconds = 2478.165 FPS
11991 frames in 5.0 seconds = 2398.078 FPS
12302 frames in 5.0 seconds = 2460.275 FPS
^C

now radar benchmark (I should probably replace my cpu since that is the bottleneck @ 1.86 ghz only)...
$ cd /usr/local/games/enemy-territory/
$ ./et.x86 +set r_fullscreen 1 +set r_drawfoliage 0 +timedemo 1 +demo radar
2896 frames, 45.9 seconds: 63.1 fps

then I opened a new x server (which ofc doens't have compiz or anything)
$ xinit -- :1

and I run glxgears there:
$ glxgears
20599 frames in 5.0 seconds = 4119.640 FPS
20732 frames in 5.0 seconds = 4146.339 FPS
21704 frames in 5.0 seconds = 4340.610 FPS
20612 frames in 5.0 seconds = 4122.258 FPS
21531 frames in 5.0 seconds = 4306.170 FPS

as you can see it's way faster than before
went back to my normal desktop via ctrl+alt+F1 (in my case f1, it might be different)

replaced compiz with metacity to test (of course all windows decorations are screwed but who cares, it's a test)
$ metacity --replace &

$ glxgears
20663 frames in 5.0 seconds = 4132.467 FPS
22196 frames in 5.0 seconds = 4439.159 FPS
21380 frames in 5.0 seconds = 4275.944 FPS
21092 frames in 5.0 seconds = 4218.370 FPS
^C

it's faster too (same speed as second X server)

tried et again, while I was testing without compiz:
$ cd /usr/local/games/enemy-territory/
$ ./et.x86 +set r_fullscreen 1 +set r_drawfoliage 0 +timedemo 1 +demo radar
2896 frames, 44.9 seconds: 64.5 fps

et is *not* faster in my case, maybe it is in your case

#18
rajaah thunder

rajaah thunder

    L4: Apprentice

  • Inactive Member
  • 446 posts
77
On the road to fame
  • Admin:12
  • Server:Silent #1
  • Alias:=F|A=Rajaah Thunder
  • T-M:ET: 1-0
it seems there's problem in my graffix drivers i think

is this the correct driver ? if yes thn i am out of my mind
OpenGL renderer string: Mesa DRI Intel® 945GM x86/MMX/SSE2

#19
Anton Chigurh

Anton Chigurh

    L6: Expert

  • Recruiting Team
  • 927 posts
401
Has a brilliant future
  • Admin:17
  • Server:Beginners #2
  • Alias:=F|A=Anton
  • T-M:ET: 6-3
    CoD: 0-0
    TF2: 0-0
Mesa is a driver but you won't get great results.

#20
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,093 posts
3,231
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor
have you tried to run et in a new X server?

to create a new X server type:
$ xinit -- :1

you can even start et straight away, with something like:
$ cd /usr/local/games/enemy-territory/
$ xinit ./et.x86 +set r_fullscreen 1 -- :1

to switch screens you need to use ctrl+alt+F1 (or F2, etc. there are many virtual consoles usually)

maybe you also need something like xauth, I dunno, for me it works even without

Mesa is a driver but you won't get great results.

yes

#21
Anton Chigurh

Anton Chigurh

    L6: Expert

  • Recruiting Team
  • 927 posts
401
Has a brilliant future
  • Admin:17
  • Server:Beginners #2
  • Alias:=F|A=Anton
  • T-M:ET: 6-3
    CoD: 0-0
    TF2: 0-0
You can always check for the latest intell driver / library at http://intellinuxgra...rg/2012.07.html

#22
rajaah thunder

rajaah thunder

    L4: Apprentice

  • Inactive Member
  • 446 posts
77
On the road to fame
  • Admin:12
  • Server:Silent #1
  • Alias:=F|A=Rajaah Thunder
  • T-M:ET: 1-0
how to i close one if i open a X server

#23
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,093 posts
3,231
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor

how to i close one if i open a X server


To switch screens use ctrl+alt+F1 or F2, F3, etc. I don't know which number is which in your pcTo close the extra X server, there should be a terminal in it, just type exit and it will close. Or close the last application in it, and it will close. You can kill it with Alt+SysRq(i.e. pint scrn)+k, ctrl+alt+backspace, of course if those key combinations are enabled in your system. You can also kill it from another terminal by finding the process id and killing it, or using stuff like htop, etc.If you reboot it wont be there anymore, so you don't have to worry about it anyway

#24
rajaah thunder

rajaah thunder

    L4: Apprentice

  • Inactive Member
  • 446 posts
77
On the road to fame
  • Admin:12
  • Server:Silent #1
  • Alias:=F|A=Rajaah Thunder
  • T-M:ET: 1-0

To switch screens use ctrl+alt+F1 or F2, F3, etc. I don't know which number is which in your pcTo close the extra X server, there should be a terminal in it, just type exit and it will close. Or close the last application in it, and it will close. You can kill it with Alt+SysRq(i.e. pint scrn)+k, ctrl+alt+backspace, of course if those key combinations are enabled in your system. You can also kill it from another terminal by finding the process id and killing it, or using stuff like htop, etc.If you reboot it wont be there anymore, so you don't have to worry about it anyway



just one more doubt . I have installed et in rajaah/documents/et

also , i have installed the et-sdl sound script ... how to execute the script so that i get the fullscreen + sound in x server ?

#25
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,093 posts
3,231
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor

just one more doubt . I have installed et in rajaah/documents/et

also , i have installed the et-sdl sound script ... how to execute the script so that i get the fullscreen + sound in x server ?

First of all, you need to check if you actually get more fps in a second X server, and you don't need sound for that test.

If it really goes faster, then you can make a script to load et with et-sdl-sound, then you run that script with xinit. I can show you what I used with Fedora, now on Arch Linux I don't have pulseaudio, consolekit and all that stuff, so I get sound more easily

You need to change the paths (path to your libsdl, et-sdl-sound) with your own of course, and maybe change pulse with alsa if you don't use pulseaudio. If there is something you don't understand in the scripts feel free to ask

script to run et with et-sdl-sound: etsound.sh
#!/bin/bash
ETSDL_SDL_LIB="/usr/lib/libSDL-1.2.so.0"
#export SDL_AUDIODRIVER="alsa"
export SDL_AUDIODRIVER="pulse"

cd "/usr/local/games/enemy-territory/"

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
LD_PRELOAD="${LD_PRELOAD}:/usr/local/games/enemy-territory/sdlsound/et-sdl-sound/et-sdl-sound.so" ./et.x86 $*

script I used to run et on a new X server on Fedora: et_newx.sh
#!/bin/bash
if ! xauth list | grep ':1'; then
  echo "adding cookie..."
  xauth add :1.0 MIT-MAGIC-COOKIE-1 `xauth list | grep :0 | sed 's/[[:print:]]*KIE-1 //'`
else
  echo "cookie already added:"
  echo `xauth list | grep :1 | sed 's/[[:print:]]*KIE-1 //'`
fi

xinit /usr/bin/ck-launch-session /usr/local/games/enemy-territory/etsound.sh $* -- :1

I do ck-launch-session for consolekit, otherwise I have no sound. you could try just xinit /usr/local/games/enemy-territory/etsound.sh $* -- :1

I would suggest to try and see if et works with sound without having to do that xauth command, and without ck-launch-session (which could even be obsolete, since my Fedora install is 2 years old). But just et-sdl-sound. In other words, open a new X server, and type the commands you would normally type for et-sdl-sound alone

#26
rajaah thunder

rajaah thunder

    L4: Apprentice

  • Inactive Member
  • 446 posts
77
On the road to fame
  • Admin:12
  • Server:Silent #1
  • Alias:=F|A=Rajaah Thunder
  • T-M:ET: 1-0
a small update sun ...
i had installed et not as root user but in home/rajaah/Documents/et ... so changed the path to $cd /home/rajaah/Documents/et
then i tired initializing x server and et at once by $ xinit ./et.x86 +set r_fullscreen 1 -- :1
but an error message stating tat u dont have permission so i used sudo be4 the command ...
thn another mssg came that an xserver is already open use --- to close blah blah blah ..

thn i hit ctrl+alt+f1 ... i thought an xserver was already open .. thn a command prompt sort of fullscreen window opened i logged in again usin username and passwd , thn again used cd /home.../et
thn i hit ./et.x86
an error mssgs came " could not load opengl subsystem "

did i do anything wrong here?
thn another error message came could not open

edit :also i tried using exit , it did not close , so had to physically switch it off .. any help here would be appreciated ..

thanx in advance ,
=F|A=Rajaah Thunder

#27
Anton Chigurh

Anton Chigurh

    L6: Expert

  • Recruiting Team
  • 927 posts
401
Has a brilliant future
  • Admin:17
  • Server:Beginners #2
  • Alias:=F|A=Anton
  • T-M:ET: 6-3
    CoD: 0-0
    TF2: 0-0
did you chmod all the necessary files and folders?

#28
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,093 posts
3,231
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor

a small update sun ...
i had installed et not as root user but in home/rajaah/Documents/et ... so changed the path to $cd /home/rajaah/Documents/et
then i tired initializing x server and et at once by $ xinit ./et.x86 +set r_fullscreen 1 -- :1
but an error message stating tat u dont have permission so i used sudo be4 the command ...

don't run et as root. It's not necessary. Which kind of message did you have? permission to do what, exactly? could you type the exact message here?

thn another mssg came that an xserver is already open use --- to close blah blah blah ..

thn i hit ctrl+alt+f1 ... i thought an xserver was already open .. thn a command prompt sort of fullscreen window opened i logged in again usin username and passwd , thn again used cd /home.../et
thn i hit ./et.x86
an error mssgs came " could not load opengl subsystem "


you have to try all F numbers, maybe F1 was just another virtual console, and you don't need to login again after opening a new X server. You just need to know which F key is your main desktop.

You switched to an unused virtual console, instead of your original X server (your desktop). You need to try all F numbers, not only F1. ET cannot run without an X server, your desktop when you run your pc is an X server (hence the error about opengl)

edit :also i tried using exit , it did not close , so had to physically switch it off .. any help here would be appreciated ..

to kill the secondary xserver you could do this:

go to some terminal via ctrl+alt+Fnumber.
You have to find the correct number for your original desktop and open a terminal, or you can go to an unused virtual console and login there, maybe as root.

type:
ps aux | grep xinit
(maybe ps aux | grep [x]init
if you don't wanna find grep itself, there are many ways)
This will list all xinit processes in your system.

- you will find in the list your main X server (xinit will have :0 in the command line ) and the one you created (it will have :1 )

kill the one with :1 by typing:
kill number

where number is the first number you find in the line, after your user name. It should close.

 
when you type just:
xinit -- :1

what happens? you get an empty desktop, maybe with a terminal in it, or you have a desktop similar to your original one?

Because xinit could run some initialization script (if I remember correctly it should be ~/.xinitrc). We don't want another X server with compiz and stuff, we want a 'bare' one. Then you could try starting ET from there (maybe you need some other authorization stuff before you can run it)

#29
rajaah thunder

rajaah thunder

    L4: Apprentice

  • Inactive Member
  • 446 posts
77
On the road to fame
  • Admin:12
  • Server:Silent #1
  • Alias:=F|A=Rajaah Thunder
  • T-M:ET: 1-0
thanx sun .. was able to open xserver and play et

but the bad thing was that ... the demo results are
2896 frames, 124.9 seconds: 23.2 fps

#30
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,093 posts
3,231
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor
it's a bit faster than in the normal desktop, right? have you tried glxgears?

maybe if you tweak your config a bit you can get some extra fps... if you want you can post your config here, and I'll check it





Also tagged with one or more of these keywords: lag

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users