Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

Install Wolfenstein ET in linux

* * * * * 1 votes

  • Please log in to reply
14 replies to this topic

#1
foley

foley

    L1: Learner

  • User
  • 16 posts
0
Unknown at this point
Hello
Our machine has been hacked 2 days ago, it uses linux and we are having problems installing wolfenstein enemy territory on it. It should be easy, we have to install it and then put our backup files from the jaymod server, but we cant.

The error we get this:

./setup.sh : line 143: 25598 Cancelado "$setup" "$@" 2>> $NULL
The setup program seems to have failed on x86/glibc-2.1



Im not very good at linux so i dont know what that error means.

Can someone help me?

Thanks ;)

Edited by foley, 29 March 2012 - 08:28 AM.



Click here to login or here to register to remove this ad, it's free!

#2
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,093 posts
3,229
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor
Could you please give more details, like, is it 32 or 64 bits o/s? Which Linux distro, and which ET version (is it 2.60?) Do you have other error lines before that, or that is all the output you get?
I think for 64 bits you have to install some package first

#3
Chuckun

Chuckun

    The Chuckunator

  • Co-Leader
  • 5,935 posts
1,658
Name known to all
  • Admin:19
  • Server:Hardcore ET
  • Alias:=F|A=TeaAndScones
Contributor
On some distros you have to install the 32bit compatibility lib yourself.

#4
foley

foley

    L1: Learner

  • User
  • 16 posts
0
Unknown at this point
Hello, thanks for your reply

We are using an Ubuntu 8, the machine is 32 bits and here is a pic from the error:

http://s3.subirimage...4942erroret.jpg

We are trying to install et 2.55 because then we want to put the 2.55+ patch.

#5
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,970
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor
Your PIC gives me 403 error. Can u please upload the error pic on forums?

#6
foley

foley

    L1: Learner

  • User
  • 16 posts
0
Unknown at this point
Done but i dont know how to upload it to forum so i put it in my site

http://www.elenemyte...es/error-et.jpg

Edited by foley, 29 March 2012 - 10:53 AM.


#7
rolf

rolf

    L7: Teacher

  • User
  • 1,302 posts
149
On the road to fame
  • Admin:16
  • Server:COD4 #1
  • T-M:ET: 0-0
    Cod: 2-2
    TF2: 0-0
@foley: in your original link you had :81 behind it, if that was removed it would work too :) Furthermore, you might consider updating your Ubuntu, 8.04 is quite old. And if I remember correctly, sudo sh et...run would work too, without ./ in front of et. But I guess that isn't part of the problem.

Anyway, since it cancels on glibc, can you confirm which version of glibc you have installed? Or better, can you update glibc? do "sudo apt-get install glibc" and remember/write down/post here the version of glibc you're about to install. Check again after that :)

I'm currently downloading ET too, to figure out what happens on line 143 :P


EDIT:
script is useless, 143 refers to something in the code itself. In the script, the first 329 lines are the script, after that there is a huge list of binary things which are not readable. Install glibc correctly, and then let us know if it works or on what it crashes.

Edited by rolf, 29 March 2012 - 11:43 AM.


#8
foley

foley

    L1: Learner

  • User
  • 16 posts
0
Unknown at this point
Hi rolf, thanks for your help, i have done "sudo apt-get install glibc" and it says "glibc pack couldnt be found".

My provider is OVH and i dont know why it only has ubuntu 8.04 but i cant update :(

#9
rolf

rolf

    L7: Teacher

  • User
  • 1,302 posts
149
On the road to fame
  • Admin:16
  • Server:COD4 #1
  • T-M:ET: 0-0
    Cod: 2-2
    TF2: 0-0
do "sudo apt-get search glibc", and install the glibc-someversionnumber

I can't really test it for you if it works (I'm proudly without Ubuntu these days), but I guess it was that command and google agrees with me.

#10
foley

foley

    L1: Learner

  • User
  • 16 posts
0
Unknown at this point

do "sudo apt-get search glibc", and install the glibc-someversionnumber


It says: Operation invalid: search

:o

#11
Krauersaut

Krauersaut

    L9: Master

  • Regular User
  • 2,228 posts
980
I am just really nice
  • Server:None
Contributor
apt-cache, not apt-get.

#12
rolf

rolf

    L7: Teacher

  • User
  • 1,302 posts
149
On the road to fame
  • Admin:16
  • Server:COD4 #1
  • T-M:ET: 0-0
    Cod: 2-2
    TF2: 0-0
sudo apt-get update
sudo apt-cache search glibc,

an older version where apt-get search didn't exists, so you first have to update the current package repo on your own pc, and then search in that repo. Told ya there is a reason why you shouldn't run 8.04 :P


@Krauer: in current Ubuntu apt-get search works too, I only forgot that 8.04 is old :P

Edited by rolf, 29 March 2012 - 12:39 PM.


#13
Krauersaut

Krauersaut

    L9: Master

  • Regular User
  • 2,228 posts
980
I am just really nice
  • Server:None
Contributor

@Krauer: in current Ubuntu apt-get search works too, I only forgot that 8.04 is old :P


I just tried it on 11.10 and it does not work.

#14
rolf

rolf

    L7: Teacher

  • User
  • 1,302 posts
149
On the road to fame
  • Admin:16
  • Server:COD4 #1
  • T-M:ET: 0-0
    Cod: 2-2
    TF2: 0-0
Hmz, I know pretty sure that I got at least search working without apt-cache, but I'm not able to retry it anyhow. Probably I'm thinking about another linux distro.

#15
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,970
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor
Try this:

sudo apt-get install ia32-libs

Why not simply host on our france server :P We do provide hosting :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users