Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

ET for MAC

- - - - -

  • Please log in to reply
30 replies to this topic

#1
b0rR*4cHo

b0rR*4cHo

    L7: Teacher

  • ET Member
  • 1,040 posts
403
Has a brilliant future
  • Admin:16
  • Server:Jay1
  • T-M:ET: 8-3
Contributor
I just downloaded ET onto my macbook and when I try to join FA Recruiting XPS it says that I need to enable PB and I click enable but nothing happens and I am still not able to join the server. :(


Click here to login or here to register to remove this ad, it's free!

#2
Chuckun

Chuckun

    The Chuckunator

  • Co-Leader
  • 5,935 posts
1,658
Name known to all
  • Admin:19
  • Server:Hardcore ET
  • Alias:=F|A=TeaAndScones
Contributor
Yeah you're probably missing the PB files.. Hopefully other MAC users here will be able to supply you with their pb folder.. (this doesnt contain any sensitive personal data or GUIDs etc)..

Then you'll need to copy your old etkey to etmain and enable PB :)

(possibly followed by \pb_cl_enable; pb_cdkeyreg; pb_system 1)

#3
b0rR*4cHo

b0rR*4cHo

    L7: Teacher

  • ET Member
  • 1,040 posts
403
Has a brilliant future
  • Admin:16
  • Server:Jay1
  • T-M:ET: 8-3
Contributor
i did what you said yesterday. i put all of my ET stuff onto a flash drive (not sure if that would work) and tried to put it on a PC laptop and it didnt work. i also lost the jaymod folder too. so i just decided to download it onto my macbook
i think i found what folder you were talking about on evenbalance.com

#4
Chuckun

Chuckun

    The Chuckunator

  • Co-Leader
  • 5,935 posts
1,658
Name known to all
  • Admin:19
  • Server:Hardcore ET
  • Alias:=F|A=TeaAndScones
Contributor

i did what you said yesterday. i put all of my ET stuff onto a flash drive (not sure if that would work) and tried to put it on a PC laptop and it didnt work. i also lost the jaymod folder too. so i just decided to download it onto my macbook
i think i found what folder you were talking about on evenbalance.com


I also said that if you were transfering to/from pc / mac then it wouldn't work since they're different builds.. Only the etkey should be copied.. Mac uses a mac version of ET, windows uses the win version of ET :P

But as you describe at this stage that ET is installed but PB will not turn on, you are missing the PB folder etc.. If you have found it then copy it to your root wolfenstein installation folder, and copy your etkey from windows into the etmain folder in your user area. After that, load ET and in console do \pb_cl_enable; pb_system 1; pb_cdkeyreg; then connect.

Chuck

#5
b0rR*4cHo

b0rR*4cHo

    L7: Teacher

  • ET Member
  • 1,040 posts
403
Has a brilliant future
  • Admin:16
  • Server:Jay1
  • T-M:ET: 8-3
Contributor
ok i download the folder. do you mean put it inside the white thing that is labled "Wolfenstein ET 2.60c" if i open that up the option would be "wolfenstein ET folder" if that is opened then i can see two folders "docs" or "etmain"

#6
b0rR*4cHo

b0rR*4cHo

    L7: Teacher

  • ET Member
  • 1,040 posts
403
Has a brilliant future
  • Admin:16
  • Server:Jay1
  • T-M:ET: 8-3
Contributor
actually it wont let me do any of those because it says "wolfenstein ET 2.60c cannot be modified" "wolfenstein ET cannot be modified"

#7
Chuckun

Chuckun

    The Chuckunator

  • Co-Leader
  • 5,935 posts
1,658
Name known to all
  • Admin:19
  • Server:Hardcore ET
  • Alias:=F|A=TeaAndScones
Contributor
Well the place you need to put the pb folder is in the same folder as Docs and etmain :)

You may have to be logged in as root to do it, or lookup how to use the terminal in mac to move the pb folder there as a superuser

(something like User/$ sudo cp /pb /home/applications/wolfenstein-enemyterritory/ - I dont have a clue about Mac's sorry..) I would suggest looking it up.

#8
b0rR*4cHo

b0rR*4cHo

    L7: Teacher

  • ET Member
  • 1,040 posts
403
Has a brilliant future
  • Admin:16
  • Server:Jay1
  • T-M:ET: 8-3
Contributor
ok i dont think i download the right thing

on here http://evenbalance.c...age=dl-wolf.php

what am i suppose to download?

#9
Chuckun

Chuckun

    The Chuckunator

  • Co-Leader
  • 5,935 posts
1,658
Name known to all
  • Admin:19
  • Server:Hardcore ET
  • Alias:=F|A=TeaAndScones
Contributor
EDIT: To answer above post - thats for RTCW not Enemy Territory - EvenBalance no longer give out files for Enemy Territory.. I dunno where you can get them :(

But if you do find the right files (some people on this forum use Mac ET), this is what I was gonna say:

Ok well considering mac and linux are both unix I will assume you can do the following.

In the terminal do:
cd /path/to/downloads/folder/where/the/pb/folder/is/
then assuming the PB folder you downloaded is just called 'pb' do:
sudo cp -R pb /path/to/wolfenstein/folder/where/etmain/and/docs/folder/is/

it will ask for admin password when you do that.

#10
b0rR*4cHo

b0rR*4cHo

    L7: Teacher

  • ET Member
  • 1,040 posts
403
Has a brilliant future
  • Admin:16
  • Server:Jay1
  • T-M:ET: 8-3
Contributor
this is how NOT good with computers i am when you download the game it download pb... only you have to install that after you install the game... i didnt see the box haha. hoping this works

#11
Chuckun

Chuckun

    The Chuckunator

  • Co-Leader
  • 5,935 posts
1,658
Name known to all
  • Admin:19
  • Server:Hardcore ET
  • Alias:=F|A=TeaAndScones
Contributor

this is how NOT good with computers i am when you download the game it download pb... only you have to install that after you install the game... i didnt see the box haha. hoping this works


Haha I thought so :P Good luck!

#12
b0rR*4cHo

b0rR*4cHo

    L7: Teacher

  • ET Member
  • 1,040 posts
403
Has a brilliant future
  • Admin:16
  • Server:Jay1
  • T-M:ET: 8-3
Contributor
ok its installed but when i try to connect its says pb is not enabled. i click enable but nothing happens.
do i need to type those 3 scripts again? if what were they again?

#13
Chuckun

Chuckun

    The Chuckunator

  • Co-Leader
  • 5,935 posts
1,658
Name known to all
  • Admin:19
  • Server:Hardcore ET
  • Alias:=F|A=TeaAndScones
Contributor
first check that you have a pb folder along with etmain and Docs like you said before.. if its there you are ready to go.. make sure your etkey from your PC is in the etmain folder on your mac :)

If you do find the pb folder with Docs and etmain then do /pb_cl_enable; pb_system 1; pb_cdkeyreg before connecting to a server :)

#14
b0rR*4cHo

b0rR*4cHo

    L7: Teacher

  • ET Member
  • 1,040 posts
403
Has a brilliant future
  • Admin:16
  • Server:Jay1
  • T-M:ET: 8-3
Contributor
ok now its PB is working... but now its saying i have an incorrect GUID?

#15
Chuckun

Chuckun

    The Chuckunator

  • Co-Leader
  • 5,935 posts
1,658
Name known to all
  • Admin:19
  • Server:Hardcore ET
  • Alias:=F|A=TeaAndScones
Contributor
that should be fixed if you have your etkey in the etmain folder and you have done /pb_cl_enable; pb_system 1; pb_cdkeyreg;

You might also have to copy your etkey to another etmain folder in your user application data folder.. not sure if mac has that or not..




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users