Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

ET Memory and Connection

- - - - -

  • This topic is locked This topic is locked
21 replies to this topic

#1
*ConQuerY*

*ConQuerY*

    L4: Apprentice

  • ET Member
  • 591 posts
240
Will become famous
  • Admin:15
  • Server:NQ1
  • Alias:=F|A=ConQuerY
  • Steam ID:Jambra92
  • T-M:ET: 6-3
Hello there,
I need some help with my ET memory like topic says,
I want to change:
RAM for ET(hunkmegs) and RAM for load a map,but i can't even i put every other amount or RAM,
Other config stays as they were except these one above,
So Is possible to solve this somehow?
Cheers,

ConQ

EDIT:In my etconfig i put a RAM which i want but in console it shows me wrong,
Example,
i have put 160 in my cfg,same as in autoexec and console says:
com_hunkmegs is ''128''
Latched: ''160''


Click here to login or here to register to remove this ad, it's free!

#2
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,970
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor
Post your config here.

#3
*ConQuerY*

*ConQuerY*

    L4: Apprentice

  • ET Member
  • 591 posts
240
Will become famous
  • Admin:15
  • Server:NQ1
  • Alias:=F|A=ConQuerY
  • Steam ID:Jambra92
  • T-M:ET: 6-3

Post your config here.




Here it is :

http://www.2shared.c...G/etconfig.html

#4
stabak

stabak

    L8: Grand Teacher

  • Co-Leader
  • 1,795 posts
332
Has a spectacular aura
  • Admin:19
  • Server:None
  • Steam ID:Stabak
  • T-M:ET 1-0
Contributor
meh why you dont post it here ?

like this
Spoiler


how does it look in your autoexec / etconfigs in your mod folders ?

also try to start the game with a (Desktop-) link and change the properties (right Mouse click -> properties) like this Untitled.jpg

In changing Hunkmegs and Soundmegs i never had problems, in changing Zonemegs this was the only way to solve this problem for me.

#5
*ConQuerY*

*ConQuerY*

    L4: Apprentice

  • ET Member
  • 591 posts
240
Will become famous
  • Admin:15
  • Server:NQ1
  • Alias:=F|A=ConQuerY
  • Steam ID:Jambra92
  • T-M:ET: 6-3
TBH didnt know how to do that im sorry,
I connect every time with et.exe,
Hmm in my every cfg in mod folders i have put 160 but no effect,it will always be 128
I'll try what u posted,btw what is Zonemegs exactly?

#6
**MrDeaTh.

**MrDeaTh.

    Huge Moron

  • Regular User
  • 446 posts
27
A step in the right direction
  • Admin:0
  • Server:Silent #1
Contributor

Hello there,
I need some help with my ET memory like topic says,
I want to change:
RAM for ET(hunkmegs) and RAM for load a map,but i can't even i put every other amount or RAM,
Other config stays as they were except these one above,
So Is possible to solve this somehow?
Cheers,

ConQ

EDIT:In my etconfig i put a RAM which i want but in console it shows me wrong,
Example,
i have put 160 in my cfg,same as in autoexec and console says:
com_hunkmegs is ''128''
Latched: ''160''


Hi , *ConQuerY*

Maybe I help you ,

- Open your console and write /com_hunkmegs 256 , I use it and I got 512 RAM.
Also,
- ET also use "Virtual Memory" , You can follow the steps in the 2011-11-15_223714.jpg showed.

I hope you got what you need !

Thanks,
Have fun !!

#7
*ConQuerY*

*ConQuerY*

    L4: Apprentice

  • ET Member
  • 591 posts
240
Will become famous
  • Admin:15
  • Server:NQ1
  • Alias:=F|A=ConQuerY
  • Steam ID:Jambra92
  • T-M:ET: 6-3
Well i tried to do all(except virtual memory)
And my hunkmegs are still 128 :/

ConQ

#8
Novice

Novice

    L7: Teacher

  • Co-Leader
  • 1,318 posts
559
Has a brilliant future
  • EvolveHQ:novice123
  • Admin:19
  • Server:Hardcore ET
  • Alias:#ender
  • T-M:ET: 4-3
Pretty sure ET is locked/maxed to 192mb hunkmegs, subtracting the sound megs from that total. Can't really go higher no matter how much ram/memory you have. Believe this is a quake engine limitation.

Believe this is the best that can be used:


//#!hardware
seta com_zoneMegs "32"
seta com_soundMegs "64"
seta com_hunkMegs "128"


#9
kami

kami

    L6: Expert

  • Co-Leader
  • 829 posts
237
Will become famous
  • Admin:19
  • Server:None
  • Alias:=F|A=adonai
  • Steam ID:STEAM_0:1:32418610
  • T-M:COD: 3-3
Contributor
Hey,

Do you have a autoexec.cfg in your etmain? If not, just create one there with "com_hunkmegs "160"" in it. You might need to undo the desktop link thing.
At least thats whats working for me.

Happy *in'

#10
Anton Chigurh

Anton Chigurh

    L6: Expert

  • Recruiting Team
  • 926 posts
401
Has a brilliant future
  • Admin:17
  • Server:Beginners #2
  • Alias:=F|A=Anton
  • T-M:ET: 6-3
    CoD: 0-0
    TF2: 0-0
Isn't this just a read / write issue where u have no permissions to save settings?

#11
stabak

stabak

    L8: Grand Teacher

  • Co-Leader
  • 1,795 posts
332
Has a spectacular aura
  • Admin:19
  • Server:None
  • Steam ID:Stabak
  • T-M:ET 1-0
Contributor

TBH didnt know how to do that im sorry,
I connect every time with et.exe,
Hmm in my every cfg in mod folders i have put 160 but no effect,it will always be 128
I'll try what u posted,btw what is Zonemegs exactly?


1.
com_zoneMegs = Ram used for Map
com_soundMegs = Ram used for sound
com_hunkMegs = Ram used for the game

2.
to get the link: just go to your Game instalation path, rightclick on the ET.exe -> mail to -> Desktop (create a Link)

than go to your desktop and use right mousebutton on the linked ET.exe file. Properties -> tab: lInk -> Filed: Target (idk if this are the right designations in the English Windows version)

In this Filed you have the path to the original game .exe now you write to this path the following things:
+ set com_hunkmegs xxx; +set com_soundmegs xxx; + set com_zonemegs xxx; (replace xxx with the ram you want to give)

Now start the game on the link :) thats all


Btw. what is your OS ? and what are your PC settings ?


Pretty sure ET is locked/maxed to 192mb hunkmegs, subtracting the sound megs from that total. Can't really go higher no matter how much ram/memory you have. Believe this is a quake engine limitation.

Believe this is the best that can be used:


//#!hardware
seta com_zoneMegs "32"
seta com_soundMegs "64"
seta com_hunkMegs "128"


nope
wet-20111115-230836.JPG

Highest hunkmegs are 1419 about zone- and soundmegs idk.

But you really dont need this high settings.
I belive the settings written above are enough. Maybe set hunkmegs to 248 or 512,
but if you increase the other settings you will not see any change.

#12
*ConQuerY*

*ConQuerY*

    L4: Apprentice

  • ET Member
  • 591 posts
240
Will become famous
  • Admin:15
  • Server:NQ1
  • Alias:=F|A=ConQuerY
  • Steam ID:Jambra92
  • T-M:ET: 6-3

1.
com_zoneMegs = Ram used for Map
com_soundMegs = Ram used for sound
com_hunkMegs = Ram used for the game

2.
to get the link: just go to your Game instalation path, rightclick on the ET.exe -> mail to -> Desktop (create a Link)

than go to your desktop and use right mousebutton on the linked ET.exe file. Properties -> tab: lInk -> Filed: Target (idk if this are the right designations in the English Windows version)

In this Filed you have the path to the original game .exe now you write to this path the following things:
+ set com_hunkmegs xxx; +set com_soundmegs xxx; + set com_zonemegs xxx; (replace xxx with the ram you want to give)

Now start the game on the link :) thats all


Btw. what is your OS ? and what are your PC settings ?




nope
wet-20111115-230836.JPG

Highest hunkmegs are 1419 about zone- and soundmegs idk.

But you really dont need this high settings.
I belive the settings written above are enough. Maybe set hunkmegs to 248 or 512,
but if you increase the other settings you will not see any change.


Thanks Stabak,but plz can you tell me is possible to connect on every server with that setting not only chosen IP adress or?

My computer are pretty sux,
1.6 GHz processor(AMD)
768 MB of RAM
128 MB graphic cars(nVidia fx5200)

TBH that was one of reason why i post this,
So for me its better to use lower RAM settings or?
Thanks,

ConQ

#13
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,090 posts
3,225
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor
I think the one that can only be set from the command line (shortcut) is zonemegs, for the others you need a /vid_restart unless you put them in your autoexec.
As far as I know, the game reads the command line first, then your profile config (for the mod you load), then autoexec.cfg (of that mod, but it should fallback to etmain one if you don't have any autoexec in that mod's folder)

If you start ET without any other parameter you'll start etmain. If you start with +set fs_game jaymod you start jaymod, etc. this is important for the profiles folder (if it's etmain, jaymod, etpro, etc.)

If you tell me how you change that memory setting (command line, mod profile, autoexec, where autoexec is located...) and if you start et with etmain or some other mod (+set fs_game ...) it's easy to tell why it is latched.

If you are in doubt about memory usage, you can still join a server, maybe with a big map, and type:
/meminfo
and see how much memory you are actually using when you play. If you don't use it all, then raising the value is meaningless.

edit:
for /meminfo you have to look at:
( xx MB) total hunk in use -> (how much com_hunkmegs you are using)
( yy MB) in n zone blocks -> (how much zonemegs)

for sounds you can list the sounds with:
/s_list
at the bottom you will see how much sound memory is used and how much is free.

hope this helps

#14
**MrDeaTh.

**MrDeaTh.

    Huge Moron

  • Regular User
  • 446 posts
27
A step in the right direction
  • Admin:0
  • Server:Silent #1
Contributor
Thanks SunLight , Good Info for me

Have good day ,

Thanks,
Have fun !!

#15
*ConQuerY*

*ConQuerY*

    L4: Apprentice

  • ET Member
  • 591 posts
240
Will become famous
  • Admin:15
  • Server:NQ1
  • Alias:=F|A=ConQuerY
  • Steam ID:Jambra92
  • T-M:ET: 6-3

I think the one that can only be set from the command line (shortcut) is zonemegs, for the others you need a /vid_restart unless you put them in your autoexec.
As far as I know, the game reads the command line first, then your profile config (for the mod you load), then autoexec.cfg (of that mod, but it should fallback to etmain one if you don't have any autoexec in that mod's folder)

If you start ET without any other parameter you'll start etmain. If you start with +set fs_game jaymod you start jaymod, etc. this is important for the profiles folder (if it's etmain, jaymod, etpro, etc.)

If you tell me how you change that memory setting (command line, mod profile, autoexec, where autoexec is located...) and if you start et with etmain or some other mod (+set fs_game ...) it's easy to tell why it is latched.

If you are in doubt about memory usage, you can still join a server, maybe with a big map, and type:
/meminfo
and see how much memory you are actually using when you play. If you don't use it all, then raising the value is meaningless.

edit:
for /meminfo you have to look at:
( xx MB) total hunk in use -> (how much com_hunkmegs you are using)
( yy MB) in n zone blocks -> (how much zonemegs)

for sounds you can list the sounds with:
/s_list
at the bottom you will see how much sound memory is used and how much is free.

hope this helps



I always start my game via ET.exe and then just click on FA servers(don't play any other servers)
I have autoexec where i set hunkmegs and zone megs(160,32) but when i start et and check console its still the same(128,24)
Im on server atm(map venice) i check mem info and total hunk i use is 128 and total zone is 24,still no changes,
When i set in game hunkmegs 160 and zonemegs 32,then vid_restart i still get this
com_hunkmegs is 128 latched 160 and zonemegs is 32,
edit:i dont use any parameter,i normally start game in etmain,

ConQ




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users