Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

Brightness Problem

- - - - - et+ ubuntu 8.04

  • Please log in to reply
14 replies to this topic

#1
Shana

Shana

    L6: Expert

  • ET Member
  • 993 posts
666
Has a brilliant future
  • EvolveHQ:th3ory13
  • Admin:16
  • Server:NQ1
  • Alias:Th3ory, Shana
  • Steam ID:STEAM_0:1:72802134
  • T-M:ET: 11-6
I've got strange problem when i play et sometimes my brightness configuration is going down. I see its 2.0 but it's 1.0 and each 10, 15, 20 mins i have to change my brightenss again.


Click here to login or here to register to remove this ad, it's free!

#2
Ghostwind

Ghostwind

    L5: Journeyman

  • Regular User
  • 619 posts
104
On the road to fame
  • Admin:14
  • Server:Jay3
  • Alias:=F|A=.
I assume you are playing on a laptop? try turning your powersaving feature off. that should help

#3
Shana

Shana

    L6: Expert

  • ET Member
  • 993 posts
666
Has a brilliant future
  • EvolveHQ:th3ory13
  • Admin:16
  • Server:NQ1
  • Alias:Th3ory, Shana
  • Steam ID:STEAM_0:1:72802134
  • T-M:ET: 11-6
Nope. I'm playing on stationary pc and I've ubuntu 8.04(that version is the best for et)

Edited by mazi1313, 03 October 2011 - 04:34 AM.


#4
Helmut the soldier

Helmut the soldier

    L5: Journeyman

  • Busted Cheater
  • 774 posts
60
Getting Better
  • Admin:0
  • Server:NQ1
  • Alias:=F|A=Orel*(Mstitel)
Yes, brightness is not the only problem which appears in W:ET..... There are still many glitches there (for example looking through walls.ie)

#5
Shana

Shana

    L6: Expert

  • ET Member
  • 993 posts
666
Has a brilliant future
  • EvolveHQ:th3ory13
  • Admin:16
  • Server:NQ1
  • Alias:Th3ory, Shana
  • Steam ID:STEAM_0:1:72802134
  • T-M:ET: 11-6
Looking through walls(caen 2 near church) is quite good but you can't shoot through them. Any other solvation to my brightness problem? Btw thanks for help.

#6
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,093 posts
3,229
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor

Looking through walls(caen 2 near church) is quite good but you can't shoot through them. Any other solvation to my brightness problem? Btw thanks for help.

My brightness goes down every time I need to check something on the internet while I play, I run et on a second X server (which also makes me 999 every time I switch :( ), when I switch back to et I have to set my r_gamma again, so I have made a bind, plus I noticed that I have to set it to 1.0 before setting it to the higher value again or it won't work.

I had the same problem on windows with et minimizer, but on windows I can solve with r_ignorehwgamma 1. Pity that on Linux this cvar is not implemented.

Maybe your problem is different, I don't know if you minimize et or not

#7
Ghostwind

Ghostwind

    L5: Journeyman

  • Regular User
  • 619 posts
104
On the road to fame
  • Admin:14
  • Server:Jay3
  • Alias:=F|A=.
yeah I have the same problem on my laptop (with fedora core, and every other distro I have run). My work around has been to start ET as a window, connect to the server. once I am connect I go full screen. After you go full screen you can use your brightness shortcut to brigten your screen. but do it before the game loads or you will have to restart x.

#8
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,093 posts
3,229
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor
I use this script to run ET on Fedora (maybe it could be done in a more elegant way but I am nub :D )

#!/bin/bash
if ! xauth list | grep ':1'; then
echo "adding cookie..."
xauth add :1.0 MIT-MAGIC-COOKIE-1 `xauth list | grep :0 | sed 's/[[:print:]]*KIE-1  //'`
else
echo "cookie already added:"
echo `xauth list | grep :1 | sed 's/[[:print:]]*KIE-1  //'`
fi
xinit /usr/bin/ck-launch-session /usr/local/games/enemy-territory/etsound +set r_fullscreen 1 $* -- :1

and then in my config I have this:

bind F9 "r_gamma 1.0; wait 30; r_gamma 2.0"

so when I ctrl+alt+f7 back to ET I just press f9 to get my gamma back. I set it to 1 then to my value (2.0) because if I set it to 2.0 straight away it doesn't change, at least in the past it didn't havent tried it recently.

#9
Ghostwind

Ghostwind

    L5: Journeyman

  • Regular User
  • 619 posts
104
On the road to fame
  • Admin:14
  • Server:Jay3
  • Alias:=F|A=.
more ellegant than my solution :) I will have to try it out myself :)

#10
Shana

Shana

    L6: Expert

  • ET Member
  • 993 posts
666
Has a brilliant future
  • EvolveHQ:th3ory13
  • Admin:16
  • Server:NQ1
  • Alias:Th3ory, Shana
  • Steam ID:STEAM_0:1:72802134
  • T-M:ET: 11-6
On my ubuntu i can't minimize et :( and got stil the same problem(got ati drive)

#11
Ghostwind

Ghostwind

    L5: Journeyman

  • Regular User
  • 619 posts
104
On the road to fame
  • Admin:14
  • Server:Jay3
  • Alias:=F|A=.

On my ubuntu i can't minimize et :( and got stil the same problem(got ati drive)


hit alt+enter

#12
Shana

Shana

    L6: Expert

  • ET Member
  • 993 posts
666
Has a brilliant future
  • EvolveHQ:th3ory13
  • Admin:16
  • Server:NQ1
  • Alias:Th3ory, Shana
  • Steam ID:STEAM_0:1:72802134
  • T-M:ET: 11-6
alt+enter doesn't work because my et window just resizing :(

#13
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,093 posts
3,229
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor

On my ubuntu i can't minimize et :( and got stil the same problem(got ati drive)

That's why I run it on a second X server (check that script in my post above), so I can switch to the other desktop with ctrl+alt+Fn, only I have to solve the 999 ping problem (if it's possible at all).
I haven't tried hard to understand why it goes 999, because I don't switch for a long time, just the time needed to change songs or quickly change my config so I don't care. But if I keep it too much in the other desktop I get kicked for 999..

#14
Shana

Shana

    L6: Expert

  • ET Member
  • 993 posts
666
Has a brilliant future
  • EvolveHQ:th3ory13
  • Admin:16
  • Server:NQ1
  • Alias:Th3ory, Shana
  • Steam ID:STEAM_0:1:72802134
  • T-M:ET: 11-6
You can use ET switch :

Get this : http://hem.bredband....h-0.1.14.tar.gz

Then open your console and enter : Code: sudo apt-get install build-essential xserver-xorg-dev libxxf86vm-dev libxpm-dev libxmu-dev


Then extract and complie using those cmds : Code: tar xvzf etswitch-0.1.14.tar.gz
cd etswitch-0.1.14/
sudo ./configure --prefix=/usr
sudo make install
sudo chmod 777 /usr/bin/etswitch
sudo chmod -R 755 ~/.etswitch


If you succeeded those steps, you have now to bind your etswitch in order it works during the game : Code: etswitch -c


Then final step, you must had a command line in your ET start script (which you prolly already have). Your launch script should looks like this : Code: #!/bin/bash

echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss // line which redirect ET sound to oss sound manager
echo "et.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss // id.

etswich & // this is the line which launch your ET switch when you're execing your ET script
et "$*" // line which launch ET



Well from my part i use a way more simple method but which was reported as not working by many ubuntu users ... Anyway here is what i do to minimize ET :

- just do Alt+ENTER during game >> it minimizes your game as expected but your mouse pointer disappears as well when you're on your desktop
- to get back your pointer just push your console bind (usually ² on keyboard) and the mouse pointer should magically appeared Posted Image

(you can also open you console before doing Alt+ENTER of course)

Hope it'll help you.

Topic to close, Brightness and minimize problem was solved.

#15
nomex78

nomex78

    L3: Novice

  • Inactive Member
  • 156 posts
27
A step in the right direction
  • Admin:12
  • Server:Jay3
  • T-M:ET: 1-1
alt+enter is good option, but that really lagging.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users