Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

Script problems

- - - - -

  • Please log in to reply
13 replies to this topic

#1
hobbit

hobbit

    L10: Grand Master

  • Regular User
  • 3,246 posts
286
Will become famous
  • Admin:0
  • Server:None
  • Steam ID:pvtforrestgump
Contributor
I've been trying out a cfg I wrote up but it always gives me FPS lag although it should be a FPS-high cfg.
Unbindall

set Name "^0hobb^h!^0t"

//Controls//

bind W "+forward"
bind S "+back"
bind A "+moveleft"
bind D "+moveright"
bind Q "+leanleft"
bind E "+leanright"
bind SPACE "+moveup"
bind MOUSE2 "+movedown"
bind X "+prone"
bind CAPSLOCK "+speed"
bind SHIFT "+sprint"
bind F "+activate"
seta sensitivity 1.8
bind T "messagemode"
bind Y "messagemode2"
bind V "mp_quickmessage"
bind TAB "+scores"
bind L "openlimbomenu"
bind G "+mapexpand"
bind . "zoomin"
bind , "zoomout"
bind ALT "+stats"
bind CTRL "+topshots"
bind MOUSE1 "+attack"
bind MOUSE4 "weapalt"
bind R "+reload"
bind B "+zoom"
bind F1 "vote yes"
bind F2 "vote no"
bind F3 "ready"
bind F4 "notready"
bind F11 "screenshot"
bind F12 "record"
bind 1 "weaponbank 1"
bind 2 "weaponbank 2"
bind 3 "weaponbank 3"
bind 4 "weaponbank 4"
bind MWHEELUP "weaponbank 5"
bind MWHEELDOWN "weaponbank 6"
bind 7 "weaponbank 7"
bind KP_INS "selectbudyall"
bind KP_LEFTARROW "selectbuddy1"
bind KP_5 "selectbuddy2"
bind KP_RIGHTARROW "selectbuddy3"
bind KP_HOME "selectbuddy4"
bind KP_UPARROW "selectbuddy5"
bind KP_PGUP "selectbuddy6"
bind F5 "class s 4;unbind MOUSE3;say_team ^0sol w/ panzer"
bind F6 "class m 1;unbind MOUSE3;say_team ^0medic"
bind F7 "class f 1;bind MOUSE3 vstr arty;say_team ^0fdops"
bind F8 "class e 1;unbind MOUSE3;say_team ^0eng w/ smg"
bind F9 "class c 3;unbind MOUSE3;say_team ^0cvops w/ rifle"
bind F10 "class c 1;unbind MOUSE3;say_team ^0cvops w/sten"
bind F11 "class e 2;unbind MOUSE3;say_team ^0engi w/ rifle"
bind MOUSE5 "kill;forcetapout"

bind LEFTARROW "team allies;class m 1"
bind UPARROW "vsay cheer ^2"
bind DOWNARROW "team spectator"
bind RIGHTARROW "team axis;class m 1"

//HUD//

b_altHud "2"
b_altHudFlags "4"
b_chatFlags "0"
b_chatsounds "0"
b_cmdwarnings "0"
b_cvarlist "1"
b_drawclock "0"
b_drawPromotions "0"
b_drawranks "0"
b_drawRewards "0"
b_drawspectatorteamflags "0"
b_fireteamLatchedClass "0"
b_goatsound "0"
b_hitsounds "2"
b_logbanners "0"
b_muzzleflash "0"
b_noactivatelean "1"
b_numPopups "0"
b_panzerhack "0"
b_popipFadeTime "1000"
b_popupStayTime "1000"
b_popupTime "1000"
b_predefineddemokeys "1"
b_shovesounds "0"
b_simpleitems "1"
b_tracers "0"
b_weapaltReloads "0"

//cg_ commands//

cg_announcer "1"
cg_atmosphericEffects "0"
cg_autoAction "1"
cg_autoactivate "1"
cg_autoReload "0"
cg_autoswitch "0"
cg_noAmmoAutoSwitch "1"
cg_blinktime "0"
cg_bloodDamageBlend "0"
cg_bloodFlash "0"
cg_bloodTime "0"
cg_bobpitch "0"
cg_bobroll "0"
cg_bobup "0"
cg_bobyaw "0"
cg_bobpitch "0"
cg_runpitch "0"
cg_runroll "0"
cg_brassTime "0"
cg_complaintPopUp "0"
cg_coronafardist "0"
cg_coronas "0"
cg_crosshairColor "red"
cg_crosshairColorAlt "Red"
cg_crosshairHealth "0"
cg_crosshairPulse "0"
cg_crosshairSize "48"
cg_lagometer "1"
cg_cursorHints "0"
cg_cycleAllWeaps "1"
cg_drawBuddies "1"
cg_drawCrosshair "5"
cg_drawCompass "1"
cg_drawCrosshairNames "1"
cg_drawCrosshairPickups "1"
cg_drawFireteamOverlay "1"
cg_drawFPS "1"
cg_drawgun "1"
cg_drawNotifyText "1"
cg_drawReinforcementTime "1"
cg_drawRoundTimer "1"
cg_smallPopupIcons "1"
cg_drawSnapShot "0"
cg_drawSpreadScale "0"
cg_drawWeaponIconFlash "0"
cg_enableBreath "0"
cg_footsteps "1"
cg_fov "90"
cg_gibs "0"
cg_gunX "0"
cg_gunY "0.5"
cg_gunZ "-1.5"
cg_gun_frame "0"
cg_marktime "0"
cg_noVoiceChats "0"
cg_noVoiceTexts "0"
cg_popupLimboMenu "0"
cg_printObjectiveInfo "1"
cg_quickMessageAlt "1"
cg_shadows "0"
cg_showblood "0"
cg_useScreenshotJPEG "1"
cg_wolfparticles "0"
cg_zoomDefaultSniper "20"

//cl_ commands//

cl_allowDownload "1"
cl_wwwDownload "1"
cl_autoRecord "1"
cl_autoupdate "0"
cl_avidemo "1"
cl_maxpackets "85"
cl_maxPing "200"
cl_punkbuster "1"
cl_run "1"
cl_wavefilerecord "0"
cl_packetdup "1"

//com_ commands//

com_hunkMegs "128"
com_maxfps "76"
com_zoneMegs "32"
com_soundMegs "64"

//r_ commands//
r_allowExtensions "1"
r_clampToEdge "1"
r_colorbits "32"
r_depthbits "24"
r_fastsky "1"
r_fullscreen "1"
r_ingamevideo "0"
r_ignorehwgamma "1"
r_flares "0"
r_drawsun "0"
r_drawfoliage "0"
r_dynamiclight "0"
r_gamma "1.7"
r_lodbias "2"
r_picmip "3"
r_texturebits "32"
r_textureMode "GL_LINEAR_MIPMAP_NEAREST"
r_mapoverbrightbits "1"

//Misc//

b_anticheat "1"
b_antilag "1"
b_antiwarp "1"
b_backupcvars "1"
b_demo_autotimescale "1"
b_demo_drawspectatormessages "0"
b_demo_autotimescaleweapons "1"
b_demo_dynamitecam "1"
b_demo_dynamitecounter "1"
b_demo_freecamspeed "1"
b_demo_grenadecam "1"
b_demo_mortarcam "1"
b_demo_panzercam "1"
b_demo_teamonlymissilecam "1"
demo_infoWindow "1"
demo_drawTimeScale "1"
demo_avifpsF5 "24"
demo_avifpsF4 "20"
demo_avifpsF3 "15"
demo_avifpsF2 "10"
demo_avifpsF1 "0"
cg_specSwing "0"
cg_specHelp "1"
s_khz "22"

m_pitch "0.022"
cl_mouseaccel "0"
sensitivity "1.85"
snaps "20"
rate "25000"

timerset

vid_restart
Ive already posted this cfg in the Scripts section but ive already modified it.

Here are two SS of the lagometer on ETPro:
Posted Image

Posted Image
If someone who knows more about cvars can tell me what might be causing this, I would be happy.

Also, if any1 can tell me why I can't see any events (such as XXX killed YYY) plz tell me (i have b_altHudFlags set to 4 so it should be in top left corner.)
P.S.- I know it seems that lately ive been having a lot of probs related to ET but Im trying to learn how to write up l33t
cfg's :lol: :l33t


Click here to login or here to register to remove this ad, it's free!

#2
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,970
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor
That green bar all the way up = internet problem at client side. I will post lagometer of Mexicano lagging all the way LOL..

whats u r_mode

#3
hobbit

hobbit

    L10: Grand Master

  • Regular User
  • 3,246 posts
286
Will become famous
  • Admin:0
  • Server:None
  • Steam ID:pvtforrestgump
Contributor
First i exec'd my etconfig.cfg which sets it at 4. Then I exec my cfg which doesn't have any r_mode setting. I don't see how I could be having any problems with my internet since at the time no1 was on the laptop which is the only way I ever get the green bar up :hmm.
One more SS of lagometer:

Posted Image
(click on image to see meter. for some reason the whole pic isn't being shown.)

Edit: I am going to go and do a few F11 SS in succesion to see what my lagometer looks like then and I'll post them.

#4
hobbit

hobbit

    L10: Grand Master

  • Regular User
  • 3,246 posts
286
Will become famous
  • Admin:0
  • Server:None
  • Steam ID:pvtforrestgump
Contributor
Here are the F11 SS:

Posted ImagePosted Image

Posted ImagePosted Image

Posted ImagePosted Image

#5
hobbit

hobbit

    L10: Grand Master

  • Regular User
  • 3,246 posts
286
Will become famous
  • Admin:0
  • Server:None
  • Steam ID:pvtforrestgump
Contributor
The next 3:
Posted ImagePosted Image

Posted ImagePosted Image

Posted ImagePosted Image

For all of the images, click on em to see the lagometer. For some reason their all cut off :confused

#6
vke

vke

    L6: Expert

  • Co-Leader
  • 991 posts
74
On the road to fame
  • Admin:19
  • Server:Hardcore ET
  • Alias:Valkyrie
  • Steam ID:STEAM_1:1:29319748
  • T-M:ET:1-0
Contributor
Maybe try:

set r_texturebits "16"
set r_colorbits "16"
I have these set as low as possible to get more fps, but the game looks like its 10 years old



as to not seeing obituaries i believe its set only to show relevant ones, kills you make or your deaths. It can be changed with the ingame menu.

#7
hobbit

hobbit

    L10: Grand Master

  • Regular User
  • 3,246 posts
286
Will become famous
  • Admin:0
  • Server:None
  • Steam ID:pvtforrestgump
Contributor
Ill try that and I'll also try taking my etconfig.cfg and modifying a select few cvars without making a new cfg and see how that works out.

#8
hobbit

hobbit

    L10: Grand Master

  • Regular User
  • 3,246 posts
286
Will become famous
  • Admin:0
  • Server:None
  • Steam ID:pvtforrestgump
Contributor
Ive got the lag problems fixed but the problem with no obituaries appearing (they appear in the console, just not on screen) is still actual.

#9
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,970
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor

Ive got the lag problems fixed but the problem with no obituaries appearing (they appear in the console, just not on screen) is still actual.


I would be honest with you. You are using on board graphics. Just upgrade your PC. You will really enjoy gaming.

#10
hobbit

hobbit

    L10: Grand Master

  • Regular User
  • 3,246 posts
286
Will become famous
  • Admin:0
  • Server:None
  • Steam ID:pvtforrestgump
Contributor
Tell that to my mom :lol:
Im willing to pay for atleast a new vid/graphics card maybe even in getting a new comp but i dont really need one seeing as how the only game I play is ET and RtCW. Im thinking about getting that new card and some more RAM for Wolf2...

But that won't solve the obituary problem :P :confused

#11
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,970
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor

Tell that to my mom :lol:
Im willing to pay for atleast a new vid/graphics card maybe even in getting a new comp but i dont really need one seeing as how the only game I play is ET and RtCW. Im thinking about getting that new card and some more RAM for Wolf2...

But that won't solve the obituary problem :P :confused


Here is how I suggest:

As number of player on server increases you will need more graphics power to render all things.

You are playing on 20 slot server and Etpro mainly. One of the best mode coded ever for 30 slots.

Half of the Etpub players will lag out totally on Etpro because Etpro doesn't have skipcorrection. You will totally freeze on Etpro if you lag. Having pathetic internet (general not you only) will only freeze you and delay your shot and not anyone else.

On board graphics card was made to run windows 98 but not windows xp with gaming.

I have watched lagometer of few player who complain here they lag and always asked their PC specs. Here is what I found:

1. They run Celeron processors.
2. They run low speed internet or are downloading porns/p2p/softwares/etc.
3. They run on board graphics card.
4. They run IDE drives.
5. They are having less then 1Gb RAM.
6. They use router and net is being shared by their whole family and sometimes their wifi frequency is interfering with neighbor wifi signals or their micro wave ovens.

If any of above conditions = true, we can't do much. In the end FPS = client side 99% time.

#12
hobbit

hobbit

    L10: Grand Master

  • Regular User
  • 3,246 posts
286
Will become famous
  • Admin:0
  • Server:None
  • Steam ID:pvtforrestgump
Contributor
Yea we have a laptop connected to the internet through wifi and that is usually why i get laggy. But that's only when someone else is using the laptop ofc. But ive got that lag prob fixed. It must have been something with internet for that day. But now im having trouble finding the cvar that controls the obituaries (xxx killed yyy). I also want to ask any1 who knows this kind of stuff, is buying a graphics card for under $100 worth it.

#13
Tonka

Tonka

    L8: Grand Teacher

  • Honored Veteran
  • 1,775 posts
427
Has a brilliant future
  • Admin:19
  • Server:NQ3
  • Alias:Pantser

1. They run Celeron processors.
2. They run low speed internet or are downloading porns/p2p/softwares/etc.
3. They run on board graphics card.
4. They run IDE drives.
5. They are having less then 1Gb RAM.
6. They use router and net is being shared by their whole family and sometimes their wifi frequency is interfering with neighbor wifi signals or their micro wave ovens.


1. check
2.check-low speed 1.5
3.no-Radeon 9250
4.check-I think
5.check-640
6.check-dsl through phone, 4 pcs, usually noone on when I play though
:D

#14
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,970
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor

I also want to ask any1 who knows this kind of stuff, is buying a graphics card for under $100 worth it.


From here:
http://slickdeals.net/

When the deal is listed you can order it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users