Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

MAX_PACKET_USERCMDS ???

- - - - -

  • Please log in to reply
6 replies to this topic

#1
Chuckun

Chuckun

    The Chuckunator

  • Co-Leader
  • 5,935 posts
1,658
Name known to all
  • Admin:19
  • Server:Hardcore ET
  • Alias:=F|A=TeaAndScones
Contributor
Hey guys, im lagging like hell in Jay 2 right now.. And when I look at my console, it's printing "MAX_PACKET_USERCMDS" over and over - like 5times per second.. A constant stream of it.. if anyone talks or gets killed etc, you see it for a split second in console before it's disappeared up the top due to all these MAX PACKET USERCMDS messages..

It doesn't say anything else, just "MAX_PACKET_USERCMDS"

I tried setting /cl_maxpackets 100 - made no difference..

I don't get whats going on?

Chuckun

EDIT: It stops when I move to spec =/

Ok never mind guys, it was a packet overflow issue due to my high FPS - it seems the server cant cope with me refreshing 334 times per second.. (334FPS)

What I dont understand though, is the server is virtually empty, and usually I do 334FPS fine.. Even on a full server.. But I've had to set maxfps to 100 to stop it :S 200 still did it, 150 still did it, 100 was the highest I could go.. =/


Click here to login or here to register to remove this ad, it's free!

#2
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,090 posts
3,225
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor
you can't send more than 32 commands per packet, I am not sure if you have cl_packetdup set to more than 0, you can check that.

anyway, I don't see the point of having such a high amount of fps and duplicated packets, other than overflowing the server with data and filling its bandwidth, most servers force com_maxfps to be at most 125, and that's what I would do to reduce client bandwidth upload to the server ;p but in f|a servers many cvar limits are different from the grnerally used 'standards' (see m_pitch, etc.)

anyway, try to reduce cl_packetdup, or even set it to zero, since it's an (almost) useless setting.

with cl_showsend 1 you can see the commands you send per packet (set it back to 0 to avoid too much console spamming, you have to type it 'blindly', so be careful!)
the number in parenthesis should be the one, ideally it shouldn't be higher than 1 (especially for your opponents, or they will call you lagger ;p).


btw, what are your pc specs? wow 334 fps with a full server I'd like to have that, but my cpu (core2 duo @ 1.86 ghz) is too slow for et

#3
SickOne

SickOne

    L3: Novice

  • User
  • 380 posts
7
A step in the right direction
  • Admin:8
Reminds me when i tried to up my max fps on a trickjump server a while ago . 500 fps still worked , on 600 fps i couldnt move and in my console was something like : too many user frames or similar ^^

#4
Chuckun

Chuckun

    The Chuckunator

  • Co-Leader
  • 5,935 posts
1,658
Name known to all
  • Admin:19
  • Server:Hardcore ET
  • Alias:=F|A=TeaAndScones
Contributor

you can't send more than 32 commands per packet, I am not sure if you have cl_packetdup set to more than 0, you can check that.

anyway, I don't see the point of having such a high amount of fps and duplicated packets, other than overflowing the server with data and filling its bandwidth, most servers force com_maxfps to be at most 125, and that's what I would do to reduce client bandwidth upload to the server ;p but in f|a servers many cvar limits are different from the grnerally used 'standards' (see m_pitch, etc.)

anyway, try to reduce cl_packetdup, or even set it to zero, since it's an (almost) useless setting.

with cl_showsend 1 you can see the commands you send per packet (set it back to 0 to avoid too much console spamming, you have to type it 'blindly', so be careful!)
the number in parenthesis should be the one, ideally it shouldn't be higher than 1 (especially for your opponents, or they will call you lagger ;p).


btw, what are your pc specs? wow 334 fps with a full server I'd like to have that, but my cpu (core2 duo @ 1.86 ghz) is too slow for et


Well 334FPS is the limit set by PB on our servers so I have com_maxfps 334..

My specs are Core i5 460M 2.5ghz (turbo to 2.8) with Nvidia Geforce GT 420M and 3GB DDR3 1333 RAM =] (laptop)

I've never had problems before.. Usually run on 334 perfectly..

Chuckun

#5
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,090 posts
3,225
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor
so, what was your cl_packetdup value?

#6
Chuckun

Chuckun

    The Chuckunator

  • Co-Leader
  • 5,935 posts
1,658
Name known to all
  • Admin:19
  • Server:Hardcore ET
  • Alias:=F|A=TeaAndScones
Contributor
it was 1 - I changed to 0, and upped maxpackets to 105 - sorted it :)

Thanks!

#7
anal bomb

anal bomb

    L3: Novice

  • Banned
  • 185 posts
1
Unknown at this point
  • Admin:0
edit

ah nvm then :P

Edited by anal bomb, 18 December 2010 - 08:46 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users