Jump to content

  • Log in with Facebook Log in with Twitter Log In with Steam Log In with Google Sign In
  • Create Account
Photo

need a script

- - - - -

  • Please log in to reply
12 replies to this topic

#1
Jorz

Jorz

    L7: Teacher

  • Busted Cheater
  • 1,199 posts
19
A step in the right direction
  • Admin:0
  • Server:Hardcore ET
Contributor
my maxpackets change everytime i die or change map,so i do /cl_maxpackets 100 manually.is there a way to bind a key to set maxpackets to 100 and rate 32000?


Click here to login or here to register to remove this ad, it's free!

#2
Papito*

Papito*

    The Love Maker

  • ET Member
  • 4,988 posts
1,467
Name known to all
  • Admin:15
  • Server:Hardcore ET
  • Alias:Mex!ckano
  • T-M:ET: 3-2
Contributor
Jay or Pub?
/exec 'your config'
/cl_maxpackets 100
/rate 32000
/writeconfig 'your config'
if you jump from jay to pub you need do the same with your pub config, if you don't have a config just do:
/writeconfig 'your name'
if you wanna bind it:
/bind 0 "say packets fixed; cl_maxpackets 100"
/bind 9 "say rate fixed; rate 32000"

#3
ohurcool

ohurcool

    L5: Journeyman

  • Regular User
  • 710 posts
32
Getting Better
  • Admin:0
  • Server:Hardcore ET

if you wanna bind it:
/bind 0 "say packets fixed; cl_maxpackets 100"
/bind 9 "say rate fixed; rate 32000"

Please don't do that.. it will spam global chat with useless shit. Use "echo" instead of "say":

bind [key] "cl_maxpackets 100; rate 32000; echo packets & rate fixed"

Or just type these in console, and they shouldn't change again:

seta cl_maxpackets "100"

seta cg_autorate "0"

seta rate "32000"

#4
SunLight

SunLight

    L11: Assassin

  • Clan Friend
  • 5,093 posts
3,229
Is a bearer of wisdom
  • Admin:10
  • Server:ETSW2
Contributor

my maxpackets change everytime i die or change map,so i do /cl_maxpackets 100 manually.is there a way to bind a key to set maxpackets to 100 and rate 32000?


Everytime you die? lol so you must have some bind in your config, maybe some attempt to be unhittable ;) in some config you have used/downloaded.
Or maybe in the mod you play there is a config file which is loaded after every respawn (never heard but possible).

Check if you have cl_maxpackets commands in some of your config files. If you have it binded somewhere, doing a seta won't fix it.

#5
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,970
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor
Don't complain on forums for lag, when you are limiting you are rate to 32000.

#6
Jorz

Jorz

    L7: Teacher

  • Busted Cheater
  • 1,199 posts
19
A step in the right direction
  • Admin:0
  • Server:Hardcore ET
Contributor
thanks guys!

@sunlight i dont download garbage cfgs from random sites :P

@dare complain?is this help section or not?and most servers i play
dont allow rate up to 32000

#7
Jorz

Jorz

    L7: Teacher

  • Busted Cheater
  • 1,199 posts
19
A step in the right direction
  • Admin:0
  • Server:Hardcore ET
Contributor

Jay or Pub?
/exec 'your config'
/cl_maxpackets 100
/rate 32000
/writeconfig 'your config'
if you jump from jay to pub you need do the same with your pub config, if you don't have a config just do:
/writeconfig 'your name'
if you wanna bind it:
/bind 0 "say packets fixed; cl_maxpackets 100"
/bind 9 "say rate fixed; rate 32000"


writeconfig doesnt work,if i do it i get bob_ things set to 1
as for the configs i just copy paste them on every mod :P

#8
anal bomb

anal bomb

    L3: Novice

  • Banned
  • 185 posts
1
Unknown at this point
  • Admin:0

Don't complain on forums for lag, when you are limiting you are rate to 32000.



you can set it even to 200 000 000
wont change anything since et supports only 25 000

#9
daredevil

daredevil

    Profiler

  • Administrators
  • 25,166 posts
14,970
Guardian of the faith
  • Xbox Live:hellreturn
  • EvolveHQ:hellreturn
  • Admin:21
  • Server:None
  • Alias:hellreturn
  • T-M:1-0
Contributor

Don't complain on forums for lag, when you are limiting you are rate to 32000.


thanks guys!

@sunlight i dont download garbage cfgs from random sites :P

@dare complain?is this help section or not?and most servers i play
dont allow rate up to 32000


Re read my above comment.

you can set it even to 200 000 000
wont change anything since et supports only 25 000


LOL. Please, keep your rumors from ET community to yourself. :sarc

#10
PHANTASM

PHANTASM

    L8: Grand Teacher

  • Regular User
  • 1,963 posts
90
On the road to fame
  • Admin:XIII
  • Server:Jay2
Contributor

you can set it even to 200 000 000
wont change anything since et supports only 25 000


Upper limit on most FA servers is 45,000. That does NOT mean setting your rate to 45,000 is some kind of secret tweak lol. Your combination of maxpackets / fps / internet speed may function best at a different rate.

So use this code to let the server set your rate for you.

seta cg_autorate 1

#11
Papito*

Papito*

    The Love Maker

  • ET Member
  • 4,988 posts
1,467
Name known to all
  • Admin:15
  • Server:Hardcore ET
  • Alias:Mex!ckano
  • T-M:ET: 3-2
Contributor

writeconfig doesnt work,if i do it i get bob_ things set to 1
as for the configs i just copy paste them on every mod :P

so, if you can't do it, go to Wolfenstein Folder -> Jaymod/[your name or default config].cfg and open it with notepad, before just copy and paste it.

#12
Jorz

Jorz

    L7: Teacher

  • Busted Cheater
  • 1,199 posts
19
A step in the right direction
  • Admin:0
  • Server:Hardcore ET
Contributor

so, if you can't do it, go to Wolfenstein Folder -> Jaymod/[your name or default config].cfg and open it with notepad, before just copy and paste it.

ye i know,i just said writeconfig doesnt work

#13
gaoesa

gaoesa

    L3: Novice

  • Clan Friend
  • 96 posts
21
A step in the right direction
  • Server:None

you can set it even to 200 000 000
wont change anything since et supports only 25 000


Wrong. Let me explain a little about the rate setting here.

The network packets travel to you with whatever speed your network works. The rate setting doesn't have any effet on that.

The rate setting is used only for fragmented packets and file downloads when the gameserver is used as the download source. The server sends one snap for each server frame. If the snap is too big for one packet, it gets fragmented. When it is fragmented, the server uses the rate setting to estimate how long it would take the client to receive the previous fragment and it attempts to time the next sent packet over that time.

In short, the used rate is the smallest of these three values client rate, sv_maxRate, 90 000. File downloads from the game server have their own calculations with rate.

The assumption that ET would always work with 25000 rate is based on the assumption that the rate setting is not used at all. To be exact, that setting the rate to a small value would have no effect as well as setting it to a high value. The server would send the next fragment as the next snap.

Edited by ge_f, 30 October 2010 - 04:53 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users